Bug 31305

Summary: db explorer freezes IDE for minutes on fast PCs
Product: db Reporter: bht <bht>
Component: CodeAssignee: issues <issues.netbeans.org>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 3.x   
Target Milestone: 4.x   
Hardware: PC   
OS: Windows 95/98   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description bht 2003-02-21 10:49:48 UTC
IDE Build 200302110810.

I am developing with the embedded database QED
from quadcap.com. Because it's embedded I cannot
keep the database explorer open while I am running
my application.

Connecting with db explorer to and disconnecting
from an empty database takes up to 10 minutes with
an AMD Athlon XP1800+. It appears the more often I
connect the longer it takes.

There are no exceptions thrown as reported in a
similar issue:

Issue 29866, which has been closed some time ago.

When I try to get a new debugger with the update
center then there is no entry for the DB explorer.

In contrast the application that I develop
connects and disconnects instantly.

I only need a simple SQL console so if you have a
suggestion of an alternative while this issue is
being fixed I would be grateful for ideas.
Comment 1 Martin Schovanek 2003-02-21 14:33:40 UTC
Bernard - can you try it on latest build please?
This should be fixed within Issue 30946 since build 200302130100.

work-arround: close the Properties window.
Comment 2 bht 2003-02-21 23:59:58 UTC
Martin,
Thanks for your response and the property sheet workaround.
I closed the property sheet and it works.
I am really glad. Sorry I can't use the dev build because I am so much
behind schedule because of this. But I will keep an eye on it when I
install the next Q-build.
The netbeans Q-builds are a really good thing for me because I use
them with some confidence for production work.
Comment 3 Martin Schovanek 2003-02-25 11:20:04 UTC
Marked as duplicate of Issue 30946. 

*** This issue has been marked as a duplicate of 30946 ***
Comment 4 Martin Schovanek 2003-03-12 14:40:41 UTC
VERIFIED
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo