Bug 31238

Summary: Database explorer fails with PostgreSQL 7.3.x
Product: db Reporter: bgallie <bgallie>
Component: CodeAssignee: Radko Najman <rnajman>
Status: CLOSED INVALID QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 3.x   
Target Milestone: 3.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description bgallie 2003-02-19 20:53:17 UTC
Database explorer is forcing the schema name to
all UPPERCASE when trying to get a list of tables,
indices, etc.  The schema name is case sensitive
in PostgreSQL 7.3.x and must remain the same case
as returned by PostgreSQL when the database
explorer queries for the schema name.
Comment 1 bgallie 2003-02-22 02:42:01 UTC
The code appears to change the schema name to UPPERCASE if the method,
getCapitalizeUserName() in
libsrc/org/netbeans/lib/ddl/adaptors/DefaultAdaptor.java, returns
true.  The default if the property is not set is true, causing the
schema name to be changed to UPPERCASE.
Comment 2 drzewo 2003-06-12 15:56:48 UTC
This is definitely a higher priority issue, because DB explorer with
PostgreSQL is unusable. Therefore such a change of the priority
(P1->P3). I'd love to see it fixed sometime (which is simple, it just
requires testing with various DBMS). 

...till then, I will have to fix it myself in
org.netbeans.lib.ddl.adaptors.DefaultAdaptor

<cut>
 public boolean getCapitializeUsername()
 {
     Boolean flag = (Boolean)properties.get("capitializeUsername");
     if(flag == null)
     {
         //flag = Boolean.TRUE;
         flag = Boolean.FALSE; 
         properties.put("capitializeUsername", flag);
     }
     return flag.booleanValue();
 }
</cut>
Comment 3 Radko Najman 2003-07-08 13:39:50 UTC
*** Issue 34762 has been marked as a duplicate of this issue. ***
Comment 4 Radko Najman 2003-07-09 13:20:50 UTC
Cannot reproduce. It works for me with PostgreSQL 7.3.3. Because this
problem was reported by more users, the proposed fix was implemented.
(The problem has probably something to do with PostgreSQL setup)
Try to verify with dev build, please.
Comment 5 Martin Schovanek 2003-10-07 11:29:40 UTC
[Nb Build 200310060100,  jdk1.4.2, PostgreSQL 7.3.3, Linux] 
 
Steps to reproduce: 
--------------------------- 
1) create table: create table "A" ( "aBc" INT2) 
2) add column into table A 
 
No one of A colums appear under A node. 
 
Comment 6 Radko Najman 2003-10-20 10:08:36 UTC
It seems like a JDBC driver bug in getColumns() method. This method
returns an empty result set for the case-sensitive named tables. The
same problem appears with getIndexInfo() method.
Closing as INVALID.
Comment 7 dmladek 2004-08-19 09:21:35 UTC
ok
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo