Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 30998

Summary: Exceptions without ceasing: CompilerTypeEditor$NoCompiler
Product: platform Reporter: dnoyeB <dnoyeb>
Component: Property EditorsAssignee: Jesse Glick <jglick>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: pzavadsky
Version: 3.x   
Target Milestone: 3.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on:    
Bug Blocks: 19443    
Attachments: zip of log

Description dnoyeB 2003-02-12 16:11:31 UTC
Product Version       = NetBeans IDE Dev (Build
200302120100)
IDE Versioning        = IDE/1 spec=3.37
impl=200302120100
Operating System      = Windows 2000 version 5.0
running on x86
Java; VM; Vendor      = 1.3.1_07; Java HotSpot(TM)
Client VM 1.3.1_07-b02; Sun Microsystems Inc.
Java Home             = c:\jdk1.3.1_07\jre


1. open NB with a console window. (runide.exe)
2. open a CVS directory in the projects tab.
3. Delete a file.
4. When it reappears select it and choose CVS Update.
5. bring up the console window so it covers the
tree nodes and maybe the source window.  Probably
the tree nodes being covered is the key per my
other issue #30434.
6. Watch the exceptions have their way with the
IDE, until you let the tree nodes be shown.

I have attached my log.  The exceptions are 



INFORMATIONAL *********** Exception occurred
************ at Wed Feb 12 10:56:03 EST 2003
java.lang.ClassNotFoundException:
org.netbeans.beaninfo.editors.CompilerTypeEditor$NoCompiler
        at
org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:145)
        at
java.lang.ClassLoader.loadClass(ClassLoader.java:250)
        at
java.lang.ClassLoader.loadClassInternal(ClassLoader.java:310)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:190)
[catch] at
org.openide.ServiceType$Handle.getServiceType(ServiceType.java:293)
        at
org.openide.loaders.CompilerSupport.getCompilerType(CompilerSupport.java:117)
        at
org.netbeans.modules.java.JavaDataObject.getCompilerType(JavaDataObject.java:1111)
        at
org.netbeans.modules.java.JavaDataObject.files(JavaDataObject.java:202)
        at
org.openide.loaders.DataNode.getIcon(DataNode.java:168)
        at
org.netbeans.modules.java.JavaNode.getIcon(JavaNode.java:431)
        at
org.openide.nodes.FilterNode.getIcon(FilterNode.java:414)
        at
org.openide.nodes.FilterNode.getIcon(FilterNode.java:414)
        at
org.openide.nodes.FilterNode.getIcon(FilterNode.java:414)
        at
org.openide.explorer.view.NodeRenderer$Tree.getTreeCellRendererComponent(NodeRenderer.java:255)
        at
org.openide.explorer.view.NodeRenderer.getTreeCellRendererComponent(NodeRenderer.java:101)
        at
javax.swing.plaf.basic.BasicTreeUI.paintRow(BasicTreeUI.java:1304)
        at
javax.swing.plaf.basic.BasicTreeUI.paint(BasicTreeUI.java:1115)
        at
javax.swing.plaf.ComponentUI.update(ComponentUI.java:34)
        at
javax.swing.JComponent.paintComponent(JComponent.java:390)
        at
javax.swing.JComponent.paint(JComponent.java:682)
        at
org.openide.explorer.view.TreeView$ExplorerTree.paint(TreeView.java:1408)
        at
javax.swing.JComponent.paintChildren(JComponent.java:493)
        at
javax.swing.JComponent.paint(JComponent.java:691)
        at
javax.swing.JViewport.paint(JViewport.java:663)
        at
javax.swing.JComponent.paintChildren(JComponent.java:493)
        at
javax.swing.JComponent.paint(JComponent.java:691)
        at
javax.swing.JComponent.paintChildren(JComponent.java:493)
        at
javax.swing.JComponent.paint(JComponent.java:691)
        at
javax.swing.JComponent.paintChildren(JComponent.java:493)
        at
javax.swing.JComponent.paint(JComponent.java:691)
        at
org.netbeans.core.windows.frames.CloseButtonTabbedPane.paint(CloseButtonTabbedPane.java:209)
        at
javax.swing.JComponent.paintChildren(JComponent.java:493)
        at
javax.swing.JComponent.paint(JComponent.java:691)
        at
javax.swing.JComponent.paintChildren(JComponent.java:493)
        at
javax.swing.JComponent.paint(JComponent.java:691)
        at
javax.swing.JComponent.paintChildren(JComponent.java:493)
        at
javax.swing.JComponent.paint(JComponent.java:691)
        at
javax.swing.JLayeredPane.paint(JLayeredPane.java:541)
        at
javax.swing.JComponent.paintChildren(JComponent.java:493)
        at
javax.swing.JComponent.paint(JComponent.java:691)
        at
javax.swing.JComponent.paintChildren(JComponent.java:493)
        at
javax.swing.JComponent.paint(JComponent.java:691)
        at
javax.swing.JComponent.paintWithBuffer(JComponent.java:3873)
        at
javax.swing.JComponent._paintImmediately(JComponent.java:3816)
        at
javax.swing.JComponent.paintImmediately(JComponent.java:3667)
        at
javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:370)
        at
javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:119)
        at
java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:149)
        at
java.awt.EventQueue.dispatchEvent(EventQueue.java:332)
        at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:126)
        at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:93)
        at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:88)
        at
java.awt.EventDispatchThread.run(EventDispatchThread.java:80)
INFORMATIONAL *********** Exception occurred
************ at Wed Feb 12 10:56:05 EST 2003
java.lang.ClassNotFoundException:
org.netbeans.beaninfo.editors.CompilerTypeEditor$NoCompiler
        at
org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:145)
        at
java.lang.ClassLoader.loadClass(ClassLoader.java:250)
...

This could be another 'import project' issue since
this project was imported by the dev build.  the
original project was 3.4.1 release.
Comment 1 dnoyeB 2003-02-12 16:12:53 UTC
Since the tree nodes may be involved I should add

WindowsLookAndFeel
Comment 2 dnoyeB 2003-02-12 16:14:21 UTC
Created attachment 8925 [details]
zip of log
Comment 3 Jesse Glick 2003-02-17 15:58:16 UTC
I've seen these too. Something to do with #19443 I suppose. I think
core/compiler/src/META-INF/netbeans/translate.names is missing an entry.

BTW dnoyeB - please set version correctly, dev builds are considered 3.5.
Comment 4 David Konecny 2003-02-17 16:22:20 UTC
*** Issue 28442 has been marked as a duplicate of this issue. ***
Comment 5 Jesse Glick 2003-02-17 20:43:19 UTC
Yes, forgot some translate.names entries, that is all. Also for
execution & debugger.
Comment 6 Jesse Glick 2003-02-17 20:50:08 UTC
BTW easily reproducible by:

1. Run NB 3.4.1 on a fresh user dir.

2. Select ColorPreview (e.g.) in sampledir.

3. Set Compiler in prop sheet to (do not compile).

4. Shut down.

5. Start NB dev on same user dir.

6. Select ColorPreview.

7. Compile.

After step 5, or 7 at the latest, the exception is thrown. Simple
translate.names correction appears to suppress it (and load the old
compiler choice correctly).
Comment 7 dnoyeB 2003-02-17 22:08:18 UTC
interesting.  Indeed I was manipulating the colors of whitespace the
the wrap border printer line thingy.
Comment 8 Jesse Glick 2003-02-20 04:37:50 UTC
committed   * Up-To-Date  1.3        
core/compiler/src/META-INF/netbeans/translate.names
committed   * Up-To-Date  1.3        
core/execution/src/META-INF/netbeans/translate.names
added       * Up-To-Date  1.1        
debuggercore/oldapi/src/META-INF/netbeans/translate.names
Comment 9 Marian Mirilovic 2004-08-17 08:42:03 UTC
verified/closed
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo