Bug 30319

Summary: Estabilishing a database connection causes IDE to hang
Product: db Reporter: Srinivas Gundeaboina <sg136701>
Component: CodeAssignee: issues <issues.netbeans.org>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: -S1S-   
Target Milestone: 4.x   
Hardware: Sun   
OS: Solaris   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on: 28199    
Bug Blocks:    

Description Srinivas Gundeaboina 2003-01-23 19:14:01 UTC
Tried to estabilish a database connection using
the database
explorer(for pointbase).  The connection was never
estabilished and since the connection
estabilishment was there on the AWT thread, it
just hung.  I would suggest using
java.sql.driverManager.setLoginTimeout and
possibly not running this on AWT thread.

Here is the stack trace

\Full thread dump Java HotSpot(TM) Client VM
(1.4.0_02-b02 mixed mode):

"Compilation" daemon prio=2 tid=0x3932a0 nid=0x1f
waiting on monitor [e3b7f000..e3b7fc50]
        at java.lang.Object.wait(Native Method)
        - waiting on <f2499ab0> (a
java.util.LinkedList)
        at java.lang.Object.wait(Object.java:426)
        at
org.netbeans.core.compiler.CompilationEngineImpl$CompilerThread.nextJobAndTask(CompilationEngineImpl.java:162)
        - locked <f2499ab0> (a
java.util.LinkedList)
        at
org.netbeans.core.compiler.CompilationEngineImpl$CompilerThread.run(CompilationEngineImpl.java:175)

"TimerQueue" daemon prio=5 tid=0x2ac188 nid=0x18
waiting on monitor [e3fff000..e3fffc50]
        at java.lang.Object.wait(Native Method)
        - waiting on <f1ca0ee8> (a
javax.swing.TimerQueue)
        at
javax.swing.TimerQueue.run(TimerQueue.java:231)
        - locked <f1ca0ee8> (a
javax.swing.TimerQueue)
        at java.lang.Thread.run(Thread.java:536)

"Module-Actions" daemon prio=1 tid=0xe4348
nid=0x15 runnable [e487e000..e487fc50]
        at
java.net.SocketInputStream.socketRead0(Native
Method)
        at
java.net.SocketInputStream.read(SocketInputStream.java:116)
        at
java.net.SocketInputStream.read(SocketInputStream.java:144)
        at
java.io.DataInputStream.readUnsignedShort(DataInputStream.java:344)
        at
java.io.DataInputStream.readUTF(DataInputStream.java:573)
        at
java.io.DataInputStream.readUTF(DataInputStream.java:550)
        at
com.pointbase.net.netJDBCConnection.<init>(DashOB3242)
        at
com.pointbase.net.netJDBCDriver.getConnection(DashOB3242)
        - locked <f25a9298> (a
com.pointbase.net.netJDBCDriver)
        at
com.pointbase.net.netJDBCDriver.connect(DashOB3242)
        - locked <f25a9298> (a
com.pointbase.net.netJDBCDriver)
        at
com.pointbase.jdbc.jdbcUniversalDriver.getConnection(DashOB3242)
        - locked <f1f4a6b8> (a
com.pointbase.jdbc.jdbcUniversalDriver)
        at
com.pointbase.jdbc.jdbcUniversalDriver.connect(DashOB3242)
        - locked <f1f4a6b8> (a
com.pointbase.jdbc.jdbcUniversalDriver)
        at
java.sql.DriverManager.getConnection(DriverManager.java:512)
        - locked <f79bc900> (a java.lang.Class)
        at
java.sql.DriverManager.getConnection(DriverManager.java:171)
        - locked <f79bc900> (a java.lang.Class)
        at
org.netbeans.modules.db.explorer.dlg.TestDriverDialog.getConnection(TestDriverDialog.java:205)
        at
org.netbeans.modules.db.explorer.actions.TestDriverAction.performAction(TestDriverAction.java:76)
        at
org.openide.util.actions.NodeAction.performAction(NodeAction.java:178)
        at
org.openide.util.actions.NodeAction.actionPerformed(NodeAction.java:169)
        at
org.netbeans.core.ModuleActions$1.run(ModuleActions.java:95)
        at
org.openide.util.Task.run(Task.java:136)
        at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:635)

"Module-Actions" daemon prio=1 tid=0x3b3c10
nid=0x13 waiting on monitor [e49ff000..e49ffc50]
        at java.lang.Object.wait(Native Method)
        - waiting on <f0f20220> (a
java.awt.EventQueue$1$AWTInvocationLock)
        at java.lang.Object.wait(Object.java:426)
        at
java.awt.EventQueue.invokeAndWait(EventQueue.java:794)
        - locked <f0f20220> (a
java.awt.EventQueue$1$AWTInvocationLock)
        at
org.openide.util.Mutex.doEventAccess(Mutex.java:925)
        at
org.openide.util.Mutex.readAccess(Mutex.java:157)
        at
org.netbeans.core.NbPresenter.show(NbPresenter.java:699)
        at
java.awt.Component.show(Component.java:1128)
        at
java.awt.Component.setVisible(Component.java:1083)
        at
org.netbeans.modules.db.explorer.dlg.ConnectionDialog.setVisible(ConnectionDialog.java:86)
        at
org.netbeans.modules.db.explorer.actions.ConnectUsingDriverAction.performAction(ConnectUsingDriverAction.java:153)
        at
org.netbeans.modules.db.explorer.actions.AddConnectionAction.performAction(AddConnectionAction.java:49)
        at
org.openide.util.actions.NodeAction.performAction(NodeAction.java:178)
        at
org.openide.util.actions.NodeAction.actionPerformed(NodeAction.java:169)
        at
org.netbeans.core.ModuleActions$1.run(ModuleActions.java:95)
        at
org.openide.util.Task.run(Task.java:136)
        at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:635)

"Thread-7" prio=5 tid=0x3b22e8 nid=0x12 runnable
[e4b7f000..e4b7fc50]
        at
java.net.PlainSocketImpl.socketAccept(Native
Method)
        at
java.net.PlainSocketImpl.accept(PlainSocketImpl.java:343)
        - locked <f1ba22b8> (a
java.net.PlainSocketImpl)
        at
java.net.ServerSocket.implAccept(ServerSocket.java:438)
        at
java.net.ServerSocket.accept(ServerSocket.java:409)
        at
org.netbeans.modules.web.monitor.client.PortServer.run(PortServer.java:67)

"Thread-5" prio=5 tid=0xd6f90 nid=0x11 waiting on
monitor [e4f7f000..e4f7fc50]
        at java.lang.Thread.sleep(Native Method)
        at
com.sun.ffj.modules.licensemgr.LMsnCheck.sleepForSomeDays(LMsnCheck.java:177)
        at
com.sun.ffj.modules.licensemgr.LMsnCheck.run(LMsnCheck.java:104)

"Thread-4" daemon prio=5 tid=0x98fba0 nid=0x10
waiting on monitor [ee4ff000..ee4ffc50]
        at java.lang.Object.wait(Native Method)
        - waiting on <f19d63f8> (a
java.util.TaskQueue)
        at java.lang.Object.wait(Object.java:426)
        at
java.util.TimerThread.mainLoop(Timer.java:403)
        - locked <f19d63f8> (a
java.util.TaskQueue)
        at
java.util.TimerThread.run(Timer.java:382)

"Active Reference Queue Daemon" daemon prio=1
tid=0x43cff0 nid=0xf waiting on monitor
[e9f7f000..e9f7fc50]
        at java.lang.Object.wait(Native Method)
        - waiting on <f183fa60> (a
java.lang.ref.ReferenceQueue$Lock)
        at
java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:111)
        - locked <f183fa60> (a
java.lang.ref.ReferenceQueue$Lock)
        at
org.openide.util.Utilities$ActiveQueue.run(Utilities.java:2244)
        at java.lang.Thread.run(Thread.java:536)

"Thread-2" daemon prio=6 tid=0x42f3d8 nid=0xe
waiting on monitor [ee1ff000..ee1ffc50]
        at java.lang.Object.wait(Native Method)
        - waiting on <f183fad8> (a
java.util.TaskQueue)
        at
java.util.TimerThread.mainLoop(Timer.java:429)
        - locked <f183fad8> (a
java.util.TaskQueue)
        at
java.util.TimerThread.run(Timer.java:382)

"AWT-EventQueue-0" prio=6 tid=0x41a738 nid=0xd
waiting for monitor entry [ee37e000..ee37fc50]
        at
java.sql.DriverManager.getConnection(DriverManager.java:138)
        - waiting to lock <f79bc900> (a
java.lang.Class)
        at
org.netbeans.modules.db.explorer.DatabaseConnection.createJDBCConnection(DatabaseConnection.java:288)
        at
org.netbeans.modules.db.explorer.actions.ConnectUsingDriverAction$2.stateChanged(ConnectUsingDriverAction.java:108)
        at
javax.swing.JTabbedPane.fireStateChanged(JTabbedPane.java:290)
        at
javax.swing.JTabbedPane$ModelListener.stateChanged(JTabbedPane.java:222)
        at
javax.swing.DefaultSingleSelectionModel.fireStateChanged(DefaultSingleSelectionModel.java:116)
        at
javax.swing.DefaultSingleSelectionModel.setSelectedIndex(DefaultSingleSelectionModel.java:50)
        at
javax.swing.JTabbedPane.setSelectedIndexImpl(JTabbedPane.java:467)
        at
javax.swing.JTabbedPane.setSelectedIndex(JTabbedPane.java:460)
        at
javax.swing.JTabbedPane.setSelectedComponent(JTabbedPane.java:513)
        at
org.netbeans.modules.db.explorer.dlg.ConnectionDialog.setSelectedComponent(ConnectionDialog.java:90)
        at
org.netbeans.modules.db.explorer.actions.ConnectUsingDriverAction$1.actionPerformed(ConnectUsingDriverAction.java:74)
        at
org.netbeans.core.NbPresenter$ButtonListener.actionPerformed(NbPresenter.java:938)
        at
javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1767)
        at
javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1820)
        at
javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:419)
        at
javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:257)
        at
javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:258)
        at
java.awt.Component.processMouseEvent(Component.java:5021)
        at
java.awt.Component.processEvent(Component.java:4818)
        at
java.awt.Container.processEvent(Container.java:1525)
        at
java.awt.Component.dispatchEventImpl(Component.java:3526)
        at
java.awt.Container.dispatchEventImpl(Container.java:1582)
        at
java.awt.Component.dispatchEvent(Component.java:3367)
        at
java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3359)
        at
java.awt.LightweightDispatcher.processMouseEvent(Container.java:3074)
        at
java.awt.LightweightDispatcher.dispatchEvent(Container.java:3004)
        at
java.awt.Container.dispatchEventImpl(Container.java:1568)
        at
java.awt.Window.dispatchEventImpl(Window.java:1581)
        at
java.awt.Component.dispatchEvent(Component.java:3367)
        at
java.awt.EventQueue.dispatchEvent(EventQueue.java:445)
        at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:191)
        at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:144)
        at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:134)
        at java.awt.Dialog.show(Dialog.java:524)
        at
org.netbeans.core.NbPresenter.superShow(NbPresenter.java:685)
        at
org.netbeans.core.NbPresenter.run(NbPresenter.java:718)
        at
org.openide.util.Mutex$1.run(Mutex.java:928)
        at
java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)
        at
java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
        at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:191)
        at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:144)
        at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
        at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
        at
java.awt.EventDispatchThread.run(EventDispatchThread.java:98)

"AWT-Motif" daemon prio=6 tid=0x3f06a8 nid=0xb
runnable [ee67f000..ee67fc50]
        at sun.awt.motif.MToolkit.run(Native
Method)
        at java.lang.Thread.run(Thread.java:536)

"AWT-Shutdown" prio=5 tid=0x3d1900 nid=0xa waiting
on monitor [ee7ff000..ee7ffc50]
        at java.lang.Object.wait(Native Method)
        - waiting on <f17306a0> (a
java.lang.Object)
        at java.lang.Object.wait(Object.java:426)
        at
sun.awt.AWTAutoShutdown.run(AWTAutoShutdown.java:259)
        - locked <f17306a0> (a java.lang.Object)
        at java.lang.Thread.run(Thread.java:536)

"Thread-1" prio=5 tid=0x2bff8 nid=0x1 waiting on
monitor [0..ffbfdf60]

"Signal Dispatcher" daemon prio=10 tid=0xa6598
nid=0x7 waiting on monitor [0..0]

"Finalizer" daemon prio=8 tid=0xa15b0 nid=0x4
waiting on monitor [f09ff000..f09ffc50]
        at java.lang.Object.wait(Native Method)
        - waiting on <f17308a0> (a
java.lang.ref.ReferenceQueue$Lock)
        at
java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:111)
        - locked <f17308a0> (a
java.lang.ref.ReferenceQueue$Lock)
        at
java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:127)
        at
java.lang.ref.Finalizer$FinalizerThread.run(Finalizer.java:159)

"Reference Handler" daemon prio=10 tid=0xa0ba8
nid=0x3 waiting on monitor [f0b7f000..f0b7fc50]
        at java.lang.Object.wait(Native Method)
        - waiting on <f1730780> (a
java.lang.ref.Reference$Lock)
        at java.lang.Object.wait(Object.java:426)
        at
java.lang.ref.Reference$ReferenceHandler.run(Reference.java:113)
        - locked <f1730780> (a
java.lang.ref.Reference$Lock)

"VM Thread" prio=5 tid=0x9f7f0 nid=0x2 runnable 

"VM Periodic Task Thread" prio=10 tid=0xa52f8
nid=0x5 waiting on monitor 
"Suspend Checker Thread" prio=10 tid=0xa5c30
nid=0x6 runnable
Comment 1 Radko Najman 2003-01-24 14:05:36 UTC
I think this bug can be marked as duplicate of issue #29866. The
definitive fix depends on issue #28199.

*** This issue has been marked as a duplicate of 29866 ***
Comment 2 Martin Schovanek 2003-03-12 14:37:09 UTC
VERIFIED
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo