Bug 27932

Summary: NullPointerException on Menu bar Tools item
Product: apisupport Reporter: Paul Ghenis <pghenis>
Component: InspectorAssignee: Jesse Glick <jglick>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 3.x   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: ide.log

Description Paul Ghenis 2002-10-10 21:51:56 UTC
When I click in the menu bar item "Tools" I get a
NullPointerException.  The stack trace is:

java.lang.NullPointerException
        at
org.netbeans.modules.apisupport.beanbrowser.NodeExploreAction$ActSubMenuModel.getCount(NodeExploreAction.java:116)
        at
org.openide.awt.Actions$SubMenu.useAccel(Actions.java:1021)
        at
org.openide.awt.Actions.updateKey(Actions.java:744)
        at
org.openide.awt.Actions$MenuBridge.updateState(Actions.java:512)
        at
org.openide.awt.Actions$SubMenu.<init>(Actions.java:949)
        at
org.netbeans.modules.apisupport.beanbrowser.NodeExploreAction$SpecialSubMenu.<init>(NodeExploreAction.java:94)
        at
org.netbeans.modules.apisupport.beanbrowser.NodeExploreAction.getMenuPresenter(NodeExploreAction.java:57)
        at
org.openide.actions.ToolsAction.generate(ToolsAction.java:121)
        at
org.openide.actions.ToolsAction.access$200(ToolsAction.java:42)
        at
org.openide.actions.ToolsAction$Inline.run(ToolsAction.java:191)
        at
org.openide.awt.JInlineMenu.doUpdate(JInlineMenu.java:132)
        at
org.openide.awt.JInlineMenu.prepareItemsInContainer(JInlineMenu.java:121)
        at
org.openide.awt.JMenuPlus.setPopupMenuVisible(JMenuPlus.java:54)
        at
javax.swing.JPopupMenu.menuSelectionChanged(JPopupMenu.java:1218)
        at
javax.swing.MenuSelectionManager.setSelectedPath(MenuSelectionManager.java:81)
        at
javax.swing.plaf.basic.BasicMenuUI.appendPath(BasicMenuUI.java:207)
        at
javax.swing.plaf.basic.BasicMenuUI.access$400(BasicMenuUI.java:28)
        at
javax.swing.plaf.basic.BasicMenuUI$MouseInputHandler.mousePressed(BasicMenuUI.java:315)
        at
java.awt.Component.processMouseEvent(Component.java:5018)
        at
java.awt.Component.processEvent(Component.java:4818)
        at
java.awt.Container.processEvent(Container.java:1525)
        at
java.awt.Component.dispatchEventImpl(Component.java:3526)
        at
java.awt.Container.dispatchEventImpl(Container.java:1582)
        at
java.awt.Component.dispatchEvent(Component.java:3367)
        at
java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3359)
        at
java.awt.LightweightDispatcher.processMouseEvent(Container.java:3071)
        at
java.awt.LightweightDispatcher.dispatchEvent(Container.java:3004)
        at
java.awt.Container.dispatchEventImpl(Container.java:1568)
        at
java.awt.Window.dispatchEventImpl(Window.java:1581)
        at
java.awt.Component.dispatchEvent(Component.java:3367)
[catch] at
java.awt.EventQueue.dispatchEvent(EventQueue.java:445)
        at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:191)
        at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:144)
        at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
        at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
        at
java.awt.EventDispatchThread.run(EventDispatchThread.java:98)
Comment 1 Paul Ghenis 2002-10-10 21:53:55 UTC
Created attachment 7642 [details]
ide.log
Comment 2 Jesse Glick 2002-10-11 15:01:45 UTC
Upgrade your apisupport to the currently released version. See issue
#26689 for details.

*** This issue has been marked as a duplicate of 26689 ***
Comment 3 Marian Mirilovic 2005-07-15 07:41:46 UTC
closed
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo