Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 262433

Summary: org.openide.util.RequestProcessor$SlowItem: task failed due to: java.lang.ArrayIndexOutOfBoundsException
Product: javascript Reporter: pangalz
Component: DebuggerAssignee: Martin Entlicher <mentlicher>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: m1k0
Version: 8.2   
Target Milestone: 8.2   
Hardware: All   
OS: All   
Whiteboard: EXCEPTIONS_REPORT
Issue Type: DEFECT Exception Report: 224496
Attachments: stacktrace
stacktrace

Description pangalz 2016-06-14 21:14:38 UTC
This issue was reported manually by pangalz.
It already has 1 duplicates 


Build: NetBeans IDE Dev (Build javascript2-2271-on-20160613)
VM: TuxJdk 64-Bit Server VM, 25.92-b03-tuxjdk-03, TuxJdk Runtime Environment, 1.8.0_92-tuxjdk-03
OS: Linux

User Comments:
pangalz: Error while debugging NodeJS app in new javascript es6 branch.




Stacktrace: 
org.openide.util.RequestProcessor$SlowItem: task failed due to: java.lang.ArrayIndexOutOfBoundsException
   at org.openide.util.RequestProcessor.post(RequestProcessor.java:420)
   at org.netbeans.modules.web.common.sourcemap.SourceMapsScanner$ProjectSourceMapsScanner.init(SourceMapsScanner.java:178)
   at org.netbeans.modules.web.common.sourcemap.SourceMapsScanner.scan(SourceMapsScanner.java:119)
   at org.netbeans.modules.web.javascript.debugger.breakpoints.BreakpointRuntimeSetter.createBreakpointImpls(BreakpointRuntimeSetter.java:138)
   at org.netbeans.modules.web.javascript.debugger.breakpoints.BreakpointRuntimeSetter.<init>(BreakpointRuntimeSetter.java:111)
   at sun.reflect.NativeConstructorAccessorImpl.newInstance0(NativeConstructorAccessorImpl.java:0)
Comment 1 pangalz 2016-06-14 21:14:41 UTC
Created attachment 160051 [details]
stacktrace
Comment 2 pangalz 2016-06-14 21:20:57 UTC
This issue was raised while testing build #2270 (dev) of ECMAScript6: https://netbeans.org/bugzilla/show_bug.cgi?id=242387
Comment 3 pangalz 2016-06-26 12:30:45 UTC
*** Bug 262569 has been marked as a duplicate of this bug. ***
Comment 4 pangalz 2016-06-26 12:32:14 UTC
(In reply to pangalz from comment #3)
> *** Bug 262569 has been marked as a duplicate of this bug. ***

Tested against build 20160624, still buggy.
Comment 5 Martin Entlicher 2016-07-11 13:58:37 UTC
pangalz, can you please provide the source map that is causing this error? Thanks.
Comment 6 pangalz 2016-07-12 00:19:58 UTC
(In reply to Martin Entlicher from comment #5)
> pangalz, can you please provide the source map that is causing this error?
> Thanks.

There's no source map files. It occurs often with plain JS files.
Comment 7 Exceptions Reporter 2016-07-18 20:57:56 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=224496
Comment 8 m1k0 2016-07-27 12:07:12 UTC
Created attachment 161463 [details]
stacktrace

start testing with debug JavaScript file
Comment 9 Martin Entlicher 2016-08-11 14:08:24 UTC
Segments of length 1 cause problems.
Comment 10 Martin Entlicher 2016-08-11 14:12:02 UTC
Fixed by changeset:   300013:868eed7a34fe
http://hg.netbeans.org/core-main/rev/868eed7a34fe
Comment 11 Quality Engineering 2016-08-13 02:13:26 UTC
Integrated into 'main-silver', will be available in build *201608130002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/868eed7a34fe
User: mentlicher@netbeans.org
Log: #262433: Skip segments of length 1. Test included.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo