Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 247884

Summary: Autoupdate should force restart when a new module enables module which is a fragment of other module
Product: platform Reporter: Tomas Zezula <tzezula>
Component: AutoupdateAssignee: Libor Fischmeistr <lfischmeistr>
Status: RESOLVED FIXED QA Contact: au-issues
Priority: P1 CC: cezariusz, CrispyDuck, exceptions_reporter, FrantaM, jtulach, martijnburger, massiws, michbarsinai, misterm, mkhramov, palman, roti, rweaver, satory, sdedic, Shishiraithal, tomsailor, vkorecky, zdenek.rod
Version: 8.1   
Target Milestone: 8.1   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: stacktrace
stacktrace
stacktrace
stacktrace
stacktrace

Description Tomas Zezula 2014-10-13 06:12:54 UTC
When autoupdate installs a module which enables a compat module (a module which provides a compatibility patch to already loaded module and is a fragment of that loaded module) should force IDE restart. In genial it's impossible to enable module fragment of already loaded module.
Comment 1 Svata Dedic 2014-11-13 12:00:03 UTC
*** Bug 248424 has been marked as a duplicate of this bug. ***
Comment 2 Exceptions Reporter 2014-11-17 18:42:57 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=213181
Comment 3 Exceptions Reporter 2014-11-20 14:22:02 UTC
Created attachment 150596 [details]
stacktrace

can't activate  a plugin
Comment 4 Libor Fischmeistr 2015-03-11 09:41:22 UTC
Decreasing priority to P3. As soon as someone can reproduce, please increase priority and report steps to reproduce.
Comment 5 Libor Fischmeistr 2015-03-17 08:33:15 UTC
*** Bug 248575 has been marked as a duplicate of this bug. ***
Comment 6 satory 2015-04-07 08:09:23 UTC
Created attachment 153070 [details]
stacktrace

Importing old plugins from 8.0.1
Comment 7 Libor Fischmeistr 2015-04-07 08:14:01 UTC
(In reply to satory from comment #6)
> Created attachment 153070 [details]
> stacktrace
> 
> Importing old plugins from 8.0.1

Could you please attach the full IDE log and updater log here?

Thanks
Comment 8 michbarsinai 2015-04-08 17:18:26 UTC
Created attachment 153101 [details]
stacktrace

while installing plugins using the "plugins" dialog.
Comment 9 Exceptions Reporter 2015-04-08 17:18:33 UTC
This bug already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=212932
Comment 10 cezariusz 2015-04-10 16:48:13 UTC
INFO [org.netbeans.modules.autoupdate.pluginimporter.PluginImporter]: Inspecting plugins took 276 ms
WARNING [org.netbeans.core.modules]: had to upgrade dependencies for module com.strixcode.sevenbeans: added = [module org.netbeans.api.progress.compat8 > 1.40, module org.netbeans.api.templates > 1.0, module org.netbeans.api.progress.nb > 1.40, module org.netbeans.modules.projectuiapi.base/1 > 1.78.0, module org.openide.util.ui > 9.3, module org.openide.filesystems.nb, module org.openide.filesystems.compat8] removed = []; details: [#243100: Separate desktop-independent utilities, Separate projectuiapi into desktop and NetBeans independent and dependent parts, Separation of desktop and cleanup, Swing dependencies split away, Templates API has been separated into its own module.]
SEVERE [org.openide.util.RequestProcessor]: Error in RequestProcessor org.netbeans.core.startup.ModuleList$Listener
java.lang.IllegalStateException: Module org.netbeans.api.progress/1 is already enabled
	at org.netbeans.ModuleManager.attachModuleFragment(ModuleManager.java:1019)
	at org.netbeans.ModuleManager.maybeAddToEnableList(ModuleManager.java:1585)
	at org.netbeans.ModuleManager.maybeAddToEnableList(ModuleManager.java:1595)
	at org.netbeans.ModuleManager.simulateEnable(ModuleManager.java:1534)
	at org.netbeans.ModuleManager.simulateEnable(ModuleManager.java:1508)
	at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:314)
	at org.netbeans.core.startup.ModuleList.access$2400(ModuleList.java:118)
	at org.netbeans.core.startup.ModuleList$Listener.stepEnable(ModuleList.java:1409)
	at org.netbeans.core.startup.ModuleList$Listener.access$1400(ModuleList.java:1007)
	at org.netbeans.core.startup.ModuleList$Listener$1.run(ModuleList.java:1231)
	at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:127)
	at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:499)
	at org.netbeans.core.startup.ModuleList$Listener.run(ModuleList.java:1207)
Caused: org.openide.util.RequestProcessor$SlowItem: task failed due to
	at org.openide.util.RequestProcessor$Task.schedule(RequestProcessor.java:1466)
	at org.netbeans.core.startup.ModuleList$Listener.runme(ModuleList.java:1200)
	at org.netbeans.core.startup.ModuleList$Listener.fileCreated0(ModuleList.java:1129)
	at org.netbeans.core.startup.ModuleList$Listener.fileDataCreated(ModuleList.java:1108)
	at sun.reflect.GeneratedMethodAccessor13.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:483)
	at org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:487)
	at com.sun.proxy.$Proxy1.fileDataCreated(Unknown Source)
	at org.openide.filesystems.FCLSupport$DispatchEventWrapper.dispatchEventImpl(FCLSupport.java:172)
	at org.openide.filesystems.FCLSupport$DispatchEventWrapperSingle.dispatchAllEventsSync(FCLSupport.java:224)
	at org.openide.filesystems.FCLSupport$DispatchEventWrapper.dispatchEvent(FCLSupport.java:137)
	at org.openide.filesystems.FCLSupport.dispatchEvent(FCLSupport.java:105)
	at org.openide.filesystems.FileObject$ED.dispatch(FileObject.java:1388)
	at org.openide.filesystems.EventControl.invokeDispatchers(EventControl.java:213)
	at org.openide.filesystems.EventControl.exitAtomicAction(EventControl.java:188)
	at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:129)
	at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:499)
	at org.openide.filesystems.FileUtil.runAtomicAction(FileUtil.java:423)
	at org.netbeans.modules.autoupdate.pluginimporter.PluginImporter.refreshModuleList(PluginImporter.java:416)
	at org.netbeans.modules.autoupdate.pluginimporter.PluginImporter.importPlugins(PluginImporter.java:259)
	at org.netbeans.modules.autoupdate.pluginimporter.ImportManager.doImport(ImportManager.java:270)
	at org.netbeans.modules.autoupdate.pluginimporter.ImportManager.access$200(ImportManager.java:89)
	at org.netbeans.modules.autoupdate.pluginimporter.ImportManager$3$1.run(ImportManager.java:230)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1425)
	at org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:68)
	at org.openide.util.lookup.Lookups.executeWith(Lookups.java:303)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2038)
WARNING [org.netbeans.core.startup.InstalledFileLocatorImpl]: no code name base passed when looking up build_info at org.netbeans.modules.uihandler.BuildInfo.logBuildInfo(BuildInfo.java:84)
INFO [org.netbeans.modules.uihandler.Installer]: findIdentity: 48dc8b21-adec-4638-b56e-345eaf1a7077_d2104f83-6601-4855-91b7-629548fd20f7
Comment 11 misterm 2015-05-15 13:23:49 UTC
Created attachment 153693 [details]
stacktrace

Installing a plugin
Comment 12 Maksim Khramov 2015-05-25 21:07:11 UTC
Created attachment 153853 [details]
stacktrace

install some downloaded nb modules
Comment 13 Libor Fischmeistr 2015-06-02 06:50:51 UTC
Fixed - http://hg.netbeans.org/core-main/rev/80cc2ca0a956

Simpler fix - doesn't check if fragment host is already loaded.
Comment 14 Quality Engineering 2015-06-04 02:31:40 UTC
Integrated into 'main-silver', will be available in build *201506040001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/80cc2ca0a956
User: Libor Fischmeistr <lfischmeistr@netbeans.org>
Log: #247884: Autoupdate should force restart when a new module enables module which is a fragment of other module
Comment 15 Tomas Hurka 2015-06-12 13:26:08 UTC
*** Bug 252955 has been marked as a duplicate of this bug. ***
Comment 16 Libor Fischmeistr 2015-07-02 09:06:06 UTC
Fix the first installation - http://hg.netbeans.org/core-main/rev/0aacfd889305
Comment 17 Quality Engineering 2015-07-04 02:08:44 UTC
Integrated into 'main-silver', will be available in build *201507040001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/0aacfd889305
User: Libor Fischmeistr <lfischmeistr@netbeans.org>
Log: #247884: Autoupdate should force restart when a new module enables module which is a fragment of other module
Comment 18 Tomas Hurka 2015-10-29 10:37:13 UTC
*** Bug 256167 has been marked as a duplicate of this bug. ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo