Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 247706

Summary: Disabled clean build run commands
Product: projects Reporter: zlob.jc
Component: Ant ProjectAssignee: Tomas Stupka <tstupka>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: arksoft, benhaze
Version: 8.0.2   
Target Milestone: TBD   
Hardware: Macintosh (x86)   
OS: Mac OS X   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: screen of context menu
file context menu before
file context menu after reboot
main menu before
main menu after reboot
project context menu before
project context menu after reboot
screen of context menu - Window 8.1 - Netbeans 8.0.2

Description zlob.jc 2014-10-06 05:09:24 UTC
Created attachment 149720 [details]
screen of context menu

Some times all "ant" commands are switch off and impossible to turn them on. Only restart ide. Very annoying.
Comment 1 zlob.jc 2014-12-18 06:07:19 UTC
Created attachment 151160 [details]
file context menu before
Comment 2 zlob.jc 2014-12-18 06:08:04 UTC
Created attachment 151161 [details]
file context menu after reboot
Comment 3 zlob.jc 2014-12-18 06:08:54 UTC
Created attachment 151162 [details]
main menu before
Comment 4 zlob.jc 2014-12-18 06:09:43 UTC
Created attachment 151163 [details]
main menu after reboot
Comment 5 zlob.jc 2014-12-18 06:10:36 UTC
Created attachment 151164 [details]
project context menu before
Comment 6 zlob.jc 2014-12-18 06:11:17 UTC
Created attachment 151165 [details]
project context menu after reboot
Comment 7 zlob.jc 2014-12-18 06:15:44 UTC
Please give any fix or workaround. I need to work, not rebooting the IDE whole day.
Comment 8 benhaze 2015-02-03 15:04:55 UTC
same here, using ubuntu 14.04.
i encounter this problem few times, very annoying!
please fix!
Comment 9 benhaze 2015-02-03 15:12:11 UTC
as workaround: 
1. goto files tab
2. select projects build.xml file
3. right click on it an choose -> run target -> clean, JAR
Comment 10 dantonepinto 2015-05-04 17:05:16 UTC
Created attachment 153519 [details]
screen of context menu - Window 8.1 - Netbeans 8.0.2
Comment 11 dantonepinto 2015-05-04 17:48:39 UTC
As workaround:
1. With the project opened on netbeans, rename the directory of project (in filesystem).
   The Netbeans will auto close the project.
2. If not close automaticaly, force it clicking "Source" -> "Scan for External Changes" with the project selected.
3. After the project has been automatically closed, rename the directory of project to the original name (in filesystem).
4. Reopen the project on Netbeans.

Now, the options are enabled.
Comment 12 Tomas Stupka 2015-05-29 14:58:29 UTC
*** Bug 252236 has been marked as a duplicate of this bug. ***
Comment 13 Tomas Stupka 2015-06-03 14:36:03 UTC

*** This bug has been marked as a duplicate of bug 242261 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo