Bug 24360

Summary: Do not put baseLook among Looks listed in 'View As' action
Product: contrib Reporter: Vitezslav Stejskal <vstejskal>
Component: LooksAssignee: Petr Hrebejk <phrebejk>
Status: VERIFIED WONTFIX QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 3.x   
Target Milestone: 3.x   
Hardware: PC   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on:    
Bug Blocks: 23270    

Description Vitezslav Stejskal 2002-06-03 21:15:40 UTC
So called baseLook is always put among Looks listed in 'View As' action. This behavior makes 
no sense because baseLook usually delegates to one from listed Looks. It would be better to 
display only looks returned by Look.availableLooks method. It also needs to be changed in 
Look property.

Also, when availableLooks returns null or empty array it would be nice to ommit View As action 
from popup menu and Look property from property sheet. It really makes no sense for the 
user, because she can choose only one Look which is selected anyway
Comment 1 Vitezslav Stejskal 2002-06-05 12:39:17 UTC
*** Issue 24097 has been marked as a duplicate of this issue. ***
Comment 2 Petr Hrebejk 2002-06-24 11:11:53 UTC
Moving Looks issues to dev 4.0
Comment 3 Petr Hrebejk 2002-12-08 17:03:04 UTC
In the latest version of Looks. There is no BaseLook. If you want
to restrict the number of looks displayed in the ViewAs action 
please consider writting own View as action implementation using
Looks.lookSwitcherLook.
Comment 4 Marian Mirilovic 2003-07-25 19:19:28 UTC
verifying.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo