Bug 24318

Summary: Looks should support icons badging
Product: contrib Reporter: Vitezslav Stejskal <vstejskal>
Component: LooksAssignee: Petr Hrebejk <phrebejk>
Status: CLOSED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: eakle
Version: 3.x   
Target Milestone: 3.x   
Hardware: PC   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:

Description Vitezslav Stejskal 2002-06-03 10:51:05 UTC
Right now there are only getIcon, getOpenedIcon methods which can provide Image displayed 
as node's icon. Result provided by those method isn't merged with results from other Looks in 
composite. That makes neraly impossible to implement Look which adds badge and use it in 
the 
composition with other Looks. It would be greate to have method

Image getIconBadge (LookNode.Substitute s);

which results would be merged accros all Looks in composite and final badge would be applied 
to the LookNode's icon
Comment 1 Petr Hrebejk 2002-06-24 11:12:10 UTC
Moving Looks issues to dev 4.0
Comment 2 eakle 2003-04-14 19:49:12 UTC
Please also consider badging for subnodes.  For example, 
my module may want to badge a java class icon to 
indicate "class is a web service", but I may also like to 
badge individual methods within the class to 
indicate "method is a web service operation".
So, badging of subnodes would also be useful, however I 
believe it is less important than badging of the main 
(parent) node.
Comment 3 Jesse Glick 2003-04-28 15:48:51 UTC

*** This issue has been marked as a duplicate of 29239 ***
Comment 4 Marian Mirilovic 2003-07-22 10:03:24 UTC
verified, closed - it's duplicate.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo