Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 241805

Summary: Plugin cannot communicate with WildFly 8 Final
Product: serverplugins Reporter: jomu <jomu>
Component: WildFlyAssignee: ehsavoie <ehsavoie>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2    
Version: 8.0   
Target Milestone: TBD   
Hardware: PC   
OS: Windows 7   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description jomu 2014-02-13 09:38:52 UTC
Server port setup changed in RC1 and Final. Plugin can communicate with RC1 but no longer with WildFly Final. 
Plugin tries to communicate on port 9999 (management-native) which is no longer available by default in Final.
Please change either the implementation or show appropriate message to instance setup to add needed management-native port.
Comment 1 jomu 2014-02-13 09:39:28 UTC
Stackrace:
java.net.ConnectException: Connection refused: no further information
	at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
	at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:739)
	at org.xnio.nio.WorkerThread$ConnectHandle.handleReady(WorkerThread.java:318)
	at org.xnio.nio.WorkerThread.run(WorkerThread.java:531)
	at ...asynchronous invocation...(Unknown Source)
	at org.jboss.remoting3.EndpointImpl.doConnect(EndpointImpl.java:272)
	at org.jboss.remoting3.EndpointImpl.doConnect(EndpointImpl.java:253)
	at org.jboss.remoting3.EndpointImpl.connect(EndpointImpl.java:351)
	at org.jboss.remoting3.EndpointImpl.connect(EndpointImpl.java:339)
	at org.jboss.as.protocol.ProtocolConnectionUtils.connect(ProtocolConnectionUtils.java:79)
	at org.jboss.as.protocol.ProtocolConnectionUtils.connectSync(ProtocolConnectionUtils.java:110)
Caused: java.net.ConnectException: JBAS012174: Could not connect to remote://localhost:9999. The connection failed
	at org.jboss.as.protocol.ProtocolConnectionUtils.connectSync(ProtocolConnectionUtils.java:118)
	at org.jboss.as.protocol.ProtocolConnectionManager$EstablishingConnection.connect(ProtocolConnectionManager.java:256)
	at org.jboss.as.protocol.ProtocolConnectionManager.connect(ProtocolConnectionManager.java:70)
	at org.jboss.as.protocol.mgmt.FutureManagementChannel$Establishing.getChannel(FutureManagementChannel.java:204)
	at org.jboss.as.controller.client.impl.RemotingModelControllerClient.getOrCreateChannel(RemotingModelControllerClient.java:148)
	at org.jboss.as.controller.client.impl.RemotingModelControllerClient$1.getChannel(RemotingModelControllerClient.java:67)
	at org.jboss.as.protocol.mgmt.ManagementChannelHandler.executeRequest(ManagementChannelHandler.java:117)
	at org.jboss.as.protocol.mgmt.ManagementChannelHandler.executeRequest(ManagementChannelHandler.java:92)
	at org.jboss.as.controller.client.impl.AbstractModelControllerClient.executeRequest(AbstractModelControllerClient.java:236)
	at org.jboss.as.controller.client.impl.AbstractModelControllerClient.execute(AbstractModelControllerClient.java:141)
	at org.jboss.as.controller.client.impl.AbstractModelControllerClient.executeForResult(AbstractModelControllerClient.java:127)
Caused: java.io.IOException
	at org.jboss.as.controller.client.impl.AbstractModelControllerClient.executeForResult(AbstractModelControllerClient.java:129)
	at org.jboss.as.controller.client.impl.AbstractModelControllerClient.execute(AbstractModelControllerClient.java:71)
Caused: java.lang.reflect.InvocationTargetException
	at sun.reflect.GeneratedMethodAccessor65.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.netbeans.modules.javaee.wildfly.ide.commands.WildflyClient.executeOnModelNode(WildflyClient.java:206)
	at org.netbeans.modules.javaee.wildfly.ide.commands.WildflyClient.undeploy(WildflyClient.java:462)
Caused: java.io.IOException
	at org.netbeans.modules.javaee.wildfly.ide.commands.WildflyClient.undeploy(WildflyClient.java:468)
	at org.netbeans.modules.javaee.wildfly.ide.commands.WildflyClient.deploy(WildflyClient.java:480)
[catch] at org.netbeans.modules.javaee.wildfly.WildFlyDeploymentManager.distribute(WildFlyDeploymentManager.java:178)
	at org.netbeans.modules.j2ee.deployment.impl.TargetServer.deploy(TargetServer.java:686)
	at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:246)
	at org.netbeans.modules.maven.j2ee.execution.DeploymentHelper.perform(DeploymentHelper.java:266)
	at org.netbeans.modules.maven.j2ee.execution.CoSAlternativeExecutorImpl.execute(CoSAlternativeExecutorImpl.java:87)
	at org.netbeans.modules.maven.cos.CoSAlternativeExecutor.execute(CoSAlternativeExecutor.java:87)
	at org.netbeans.modules.maven.cos.CosChecker.checkRunMainClass(CosChecker.java:207)
	at org.netbeans.modules.maven.cos.CosChecker.checkRunConfig(CosChecker.java:161)
	at org.netbeans.modules.maven.execute.MavenCommandLineExecutor.run(MavenCommandLineExecutor.java:159)
	at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:153)
Comment 2 jomu 2014-02-13 09:42:48 UTC
Fix by updating standalone.xml in WildFly 8 Final:

<socket-binding-group ...>
   <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>
</socket-binding-group>

<management-interfaces>
...
            <native-interface security-realm="ManagementRealm">
                <socket-binding native="management-native"/>
            </native-interface>
</management-interfaces>
Comment 3 ehsavoie 2014-02-13 09:47:43 UTC
This has been fixed in the 1.6 version of the plugin which is not the version you are using (I assume you are using the version packaged with the beta).
Comment 4 jomu 2014-02-13 09:55:03 UTC
You are right, it is version 1.0.4. 
How can I update? I tried to update in Netbeans and there is no update available.
Comment 5 jomu 2014-02-13 10:03:03 UTC
I used the following additional update center:
http://deadlock.netbeans.org/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz, seems to work
Comment 6 graham-stewart 2014-08-16 04:00:47 UTC
This problem with the wildfly plugin still exists in version 1.0.17 which is the latest download in the plugin centre and version 8.1.0.Final of wildfly.
Comment 7 graham-stewart 2014-08-16 07:57:36 UTC
After further research: Jboss have removed the native management interface on port 9999. http://wildfly.org/news/2014/02/11/WildFly8-Final-Released/ "Note that since CR1 we have finally dropped the native management port 9999, which instead uses the HTTP management port (9990)." Posted by Jason Greene on Feb 11, 2014.

I tried to use the update centre listed by jomu however this fails during the download report a network error downloading http://deadlock.netbeans.org/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/ide/org-netbeans-modules-css-editor.nbm. Do not know why this is being downloaded because on the update for WildFly Application Server is ticked.
Comment 8 ehsavoie 2014-08-19 07:06:15 UTC
The plugin will always use port 9990 for communicating with the server.
If you are using a version prior to 8.0 or if you change this port then it will not work.
This is not a bug you might want to create an enhancement request to make this port configurable in the plugin.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo