Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 231359

Summary: Http error 411 (Length Required) from Exception reporter via http proxy
Product: ide Reporter: aldobrucale <aldobrucale>
Component: Exceptions ReporterAssignee: Tomas Danek <musilt2>
Status: RESOLVED WONTFIX QA Contact: logger-issues <logger-issues.netbeans.org>
Priority: P3 CC: mmirilovic
Version: 7.4   
Target Milestone: 7.4   
Hardware: PC   
OS: Linux   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: ide log

Description aldobrucale 2013-06-17 12:52:45 UTC
Created attachment 135885 [details]
ide log

I'm now using NB 7.4 beta (build 201306132201) but I have noticed this issue in previous dev builds. Uploading of exception via Exception Reporter constantly fails, and the ide log shows this message:


java.io.IOException: Server returned HTTP response code: 411 for URL: http://statistics.netbeans.org/analytics/upload.jsp

I've also noticed a similar error at ide startup:

java.io.IOException: Server returned HTTP response code: 411 for URL: http://statistics.netbeans.org/usageLogCollector
Comment 1 Tomas Danek 2013-06-18 07:14:56 UTC
I cannot reproduce; It seems like it may be some temporary server unavailability. I was able to file testing report from 7.4 Beta: http://statistics.netbeans.org/analytics/exception.do?id=677083 right now.
Comment 2 aldobrucale 2013-06-18 08:36:58 UTC
I understand that this feature is working for other people, but I've been unable to use the exception reporter since I started to try the dev builds for netcat 7.4. Is there any additional logger that I can enable to investigate the cause of this problem?
Comment 3 aldobrucale 2013-06-19 09:20:01 UTC
I have found out that the problem is caused by my http proxy (squid 2.7), which in this case does not handle correctly the "Transfer-Encoding: chunked" request header (I did not investigate deeper). Previous versions of Netbeans, including the new 7.3.1, just send the "Content-Length" header for these requests.

So this is not actually a netbeans bug, but since squid 2.7 is the newest version available for Debian squeeze other users may be affected by this problem.
Comment 4 Marian Mirilovic 2013-06-21 14:39:12 UTC
(In reply to comment #3)
> So this is not actually a netbeans bug, but since squid 2.7 is the newest
> version available for Debian squeeze other users may be affected by this
> problem.

We can't do anything on our side.
Comment 5 aldobrucale 2013-06-24 13:49:08 UTC
(In reply to comment #4)

> We can't do anything on our side.

Well, if this problem affects a large number of users, you could revert to the previous behaviour of sending the Content-Length header instead of "Transfer-Encoding: chunked".
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo