Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 228816

Summary: Add "ignore" in "show changes" and "diff" view
Product: versioncontrol Reporter: everflux <everflux>
Component: GitAssignee: Ondrej Vrabec <ovrabec>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: git
Version: 7.3.1   
Target Milestone: 7.4   
Hardware: PC   
OS: Linux   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:

Description everflux 2013-04-21 14:41:20 UTC
When reviewing changes (team -> show changes) I would like to have the option to add files to the .gitignore configuration.
(Right click, "ignore" like in the file/project view)
Comment 1 Ondrej Vrabec 2013-04-21 15:43:24 UTC
I'll consider adding the action to the menu.
BTW, you can ignore from the views even now. AFAIK it should be possible to select the files you want to ignore and run Team -> Git -> Ignore
Comment 2 Ondrej Vrabec 2013-04-22 08:16:46 UTC
fix: http://hg.netbeans.org/core-main/rev/ea2a955e713f
Comment 3 Quality Engineering 2013-04-24 02:14:26 UTC
Integrated into 'main-golden', will be available in build *201304232301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/ea2a955e713f
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #228816 - Add "ignore" in "show changes" and "diff" view
Comment 4 markiewb 2013-04-27 16:34:03 UTC
@Ondrej: https://netbeans.org/bugzilla/show_bug.cgi?id=182135 looks pretty similar to this issue
Comment 5 Ondrej Vrabec 2013-04-28 15:03:10 UTC
(In reply to comment #4)
> @Ondrej: https://netbeans.org/bugzilla/show_bug.cgi?id=182135 looks pretty
> similar to this issue
Yes, similar but not the same. And honestly i have no intention of fixing that. Because all commit dialogs are basically one-time snapshot of your checkout, it is currently not supported (and never was intended) to recompute every-time you change something. Because usually ignoring a file affects also other files (like .gitignore) every change in the commit dialog would have to reparse status of all files in the project. I just don't think i have enough resources to fix this minor enhancement right now. Leaving that open until enough votes come, i have some time to spare or a patch is delivered.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo