Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 227283

Summary: Allow creating Toolbar buttons for custom Maven runs
Product: projects Reporter: pekarna <pekarna>
Component: MavenAssignee: Milos Kleint <mkleint>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3    
Version: 7.3   
Target Milestone: 7.4   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:

Description pekarna 2013-03-11 13:08:51 UTC
The toolbar icons only allow standard Maven tasks like clean, clean install, install, test etc.

It would be very useful if there was a possibility to add buttons with custom Maven command to be executed (and a custom icons).

Currently, the only way is to misuse other buttons. E.g. I don't use Clean Project, so I redefined the Clean goal in Project -> Properties -> Actions to do Deploy for me.

Doesn't really need an extra editor. Even something like "Custom Action 1", "Custom Action 2", "Custom Action 3" would help; Users could use these instead of such like Clean Project.

Thanks for considering.
Comment 1 pekarna 2013-03-11 13:13:56 UTC
Note that this would also make using Maven profiles in NetBeans a lot easier. The dropdown menu selection isn't applied for builds.

Also see Bug 226242
Comment 2 Milos Kleint 2013-03-11 13:21:40 UTC
most likely a duplicate of another issue, not a defect though.



(In reply to comment #1)
> Note that this would also make using Maven profiles in NetBeans a lot easier.
> The dropdown menu selection isn't applied for builds.

I'm not following this part.
Comment 3 Milos Kleint 2013-04-22 16:36:02 UTC
http://hg.netbeans.org/core-main/rev/3a2410f34fd2

adds up to 6 custom maven execution icons/actions that can be added to Build toolbar. Only the global actions edited in Tools/Options/Maven can be associated with these. Actually The button in the dialog creates the action and the toolbar representation on the fly. Removal also possible.
Comment 4 Quality Engineering 2013-04-24 02:13:42 UTC
Integrated into 'main-golden', will be available in build *201304232301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/3a2410f34fd2
User: Milos Kleint <mkleint@netbeans.org>
Log: #227283 add  toobar action for custom maven bindings
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo