Bug 225989

Summary: [73cat] Cannot change ignored folders template in project properties using Apply button
Product: cnd Reporter: kosmonaffft
Component: ProjectAssignee: Alexander Simon <alexvsimon>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: AlyonaStashkova, ctapmex, mmirilovic, pjiricka
Version: 7.3Keywords: RELNOTE
Target Milestone: 7.3.1   
Hardware: PC   
OS: Other   
Whiteboard: 73patch1-verified sspatch
Issue Type: DEFECT Exception Report:

Description kosmonaffft 2013-02-11 16:50:44 UTC
Hello all...

I have C++ project with unit tests places in test sub-folder... In NetBeans IDE Dev (Build 201302102300) when i try to change excluded folders template in project properties, i cannot do that because after "Apply" button pressed properties returns to default state...

Steps to reproduce:
1) Create new C++ project.
2) Open project properties.
3) Change ignore folders pattern.
4) Press "Apply" button.
5) See result - you changes is lost.
Comment 1 MackSix 2013-02-13 08:09:00 UTC
This happens with NetBeans IDE 7.3 FCS (Build 201302062200) too and I can't set the encoding either, it goes back to UTF-8.
Comment 2 soldatov 2013-02-13 08:23:33 UTC
Other project types (php,java) has not Apply button. Should button be removed too in C/C++?
Comment 3 kosmonaffft 2013-02-13 08:47:36 UTC
[quote]
Mark Wilmoth <mark.wilmoth@att.net>
4:06 PM (40 minutes ago)

to netcat 
This happens with NetBeans IDE 7.3 FCS (Build 201302062200) too and I can't set the encoding either, it goes back to UTF-8. It is regression and there is no workaround as far as I know, so it should be P1.

Mark
[/quote]

So, i set P1.
Comment 4 soldatov 2013-02-13 08:49:15 UTC
very easy workaround - OK button
Comment 5 soldatov 2013-02-13 08:57:32 UTC
*** Bug 224539 has been marked as a duplicate of this bug. ***
Comment 6 kosmonaffft 2013-02-13 08:58:51 UTC
(In reply to comment #4)
> very easy workaround - OK button

If OK button works correctly and another project types have not "Apply" button, i think "Apply" button can be removed.
Comment 7 Alexander Simon 2013-02-13 09:03:23 UTC
It is regression after fixing bug #219547
Comment 8 Alexander Simon 2013-02-13 09:04:46 UTC
Maria please investigate
Comment 9 soldatov 2013-02-13 12:41:17 UTC
new test is added (testSetWindows1251)
Comment 10 Alexander Simon 2013-02-13 14:39:07 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/07ecf50ad221
Comment 11 Alexander Simon 2013-02-13 14:40:13 UTC
Vladimir V:
Please review the fix.
QA:
Please verify the fix in the trunk.
Comment 12 Alexander Pepin 2013-02-13 14:50:12 UTC
After discussion we decided not to consider that bug as a showstopper for NB 7.3 but to nominate it for patch. QA should add tests for "Apply" to the testbase.
Comment 13 kosmonaffft 2013-02-13 14:54:55 UTC
May be remove "Apply" will be better choise, because in another project types this button is missed?
Comment 14 Alexander Simon 2013-02-14 07:56:37 UTC
additional fix:
http://hg.netbeans.org/cnd-main/rev/91fd6b17e87d
Comment 15 soldatov 2013-02-18 11:51:52 UTC
verified in trunk
Comment 16 soldatov 2013-03-18 12:08:23 UTC
Verified in build 201303172200
Comment 17 kosmonaffft 2013-03-28 05:04:18 UTC
Thanks...
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo