Bug 225466

Summary: NullPointerException at org.netbeans.modules.bugtracking.jira.DownloadPlugin$1$1.run
Product: connecteddeveloper Reporter: sishbi
Component: Issuetracking FrameworkAssignee: Tomas Stupka <tstupka>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: eddiecarpenter, mmirilovic
Version: 7.3Keywords: 73_HR_FIX
Target Milestone: 7.3   
Hardware: All   
OS: All   
Whiteboard: EXCEPTIONS_REPORT
Issue Type: DEFECT Exception Report: 198131
Attachments: stacktrace

Description sishbi 2013-01-29 12:29:31 UTC
Build: NetBeans IDE 7.3 RC1 (Build 201301240957)
VM: Java HotSpot(TM) 64-Bit Server VM, 24.0-b28, Java(TM) SE Runtime Environment, 1.7.0_12-ea-b08
OS: Mac OS X

User Comments:
sishbi: Adding the JIRA issue tracking system
However, the JIRA plugin is not installed and the IDE was attempting to download the plugin




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.bugtracking.jira.DownloadPlugin$1$1.run(DownloadPlugin.java:104)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1454)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2048)
Comment 1 sishbi 2013-01-29 12:29:33 UTC
Created attachment 130775 [details]
stacktrace
Comment 2 Tomas Stupka 2013-01-30 10:24:35 UTC
wil fix the NPE, but please note that due to licensing issues, the jira plugin was temporarily removed from the 7.3 UC.
Comment 3 Tomas Stupka 2013-01-30 13:18:10 UTC
fixed in core-main #819707234a77
Comment 4 Tomas Stupka 2013-01-30 13:23:58 UTC
integrated to release73 #5ea358a19d54
Comment 5 sishbi 2013-01-30 13:35:08 UTC
Will the JIRA plugin be made available before 7.3 is released?
Comment 6 Tomas Stupka 2013-01-30 14:28:24 UTC
(In reply to comment #5)
> Will the JIRA plugin be made available before 7.3 is released?
we are working on it and we will let you know asap
Comment 7 Quality Engineering 2013-01-31 00:51:26 UTC
Integrated into 'releases', will be available in build *201301302200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/5ea358a19d54
User: Tomas Stupka <tstupka@netbeans.org>
Log: Issue #225466 - NullPointerException at org.netbeans.modules.bugtracking.jira.DownloadPlugin$1$1.run
Comment 8 Quality Engineering 2013-01-31 03:13:09 UTC
Integrated into 'main-golden', will be available in build *201301310001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/819707234a77
User: Tomas Stupka <tstupka@netbeans.org>
Log: Issue #225466 - NullPointerException at org.netbeans.modules.bugtracking.jira.DownloadPlugin$1$1.run
Comment 9 sishbi 2013-02-13 14:18:58 UTC
Lack on JIRA plugin highlighted duplicate bug.

*** This bug has been marked as a duplicate of bug 225860 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo