Bug 215877

Summary: Issue and Query dialog do not cope well with dark desktop theme
Product: connecteddeveloper Reporter: mjr_1974 <mjr_1974>
Component: Issuetracking FrameworkAssignee: Stanislav Aubrecht <saubrecht>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: tstupka
Version: 7.2   
Target Milestone: 7.4   
Hardware: PC   
OS: Linux   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on:    
Bug Blocks: 225542    
Attachments: Picture of the problem

Description mjr_1974 2012-07-24 13:59:17 UTC
Product Version = NetBeans IDE 7.2 RC1 (Build 201206272359)
Operating System = Linux version 3.5.0-4-generic running on amd64
Java; VM; Vendor = 1.7.0_05
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.1-b03

Hard coded colors in the find issue form makes it difficult to use it when using a dark desktop theme. See attached picture.
Comment 1 mjr_1974 2012-07-24 13:59:56 UTC
Created attachment 122302 [details]
Picture of the problem
Comment 2 Tomas Stupka 2012-10-25 15:33:35 UTC
*** Bug 215595 has been marked as a duplicate of this bug. ***
Comment 3 Tomas Stupka 2012-10-25 15:34:23 UTC
not hardcoded, but given by default swing look & feel colors. We should see that we somehow tune the dialogs for other color schemes ...
Comment 4 Stanislav Aubrecht 2013-02-19 10:13:10 UTC
core-main 8d755ea1b60e
Comment 5 Quality Engineering 2013-02-23 04:09:04 UTC
Integrated into 'main-golden', will be available in build *201302222300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/8d755ea1b60e
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #215877 - Issue and Query dialog do not cope well with dark desktop theme
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo