Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 215301

Summary: Enable "go to type source" from Variables window
Product: debugger Reporter: Petr Somol <psomol>
Component: JavaAssignee: Martin Entlicher <mentlicher>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: markiewb
Version: 7.3   
Target Milestone: 7.4   
Hardware: PC   
OS: Windows 7   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:
Attachments: situation when going to source through Variables would help

Description Petr Somol 2012-07-09 16:10:36 UTC
Created attachment 121850 [details]
situation when going to source through Variables would help

When debugging NetBeans sources I often find myself in a situation where a for-cycle is looped over lookup instances of an interface, while I would need to see the sources of the particular instance. The trouble here is that there is no way to jump straight to the source of a particular instance, because it is not directly referenced from the debugged source, so nothing like the usual action Ctrl-click on type name is available. However, when debugging, the current instance is displayed in Variables window. Intuitively I right-clicked the type in question in Variables window hoping to find "Go to Source" action but this is not implemented. See attachment for a situation like I have just described. I believe it would be quite practical to enable "Go to Source" from Variables right-click menu because for-cycling through concrete instances only by means of their common supertype/interface only is a common pattern.
Comment 1 markiewb 2014-12-27 11:50:52 UTC
Dup of https://netbeans.org/bugzilla/show_bug.cgi?id=81925. 

Already fixed in NB7.4 - http://wiki.netbeans.org/NetBeans_74_NewAndNoteworthy

*** This bug has been marked as a duplicate of bug 81925 ***
Comment 2 Jiri Kovalsky 2015-01-05 14:56:11 UTC
Verified.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo