Bug 213415

Summary: AssertionError: file:////spweb01/e$/Library/ from \\spweb01\e$\Library@d1a16993:74a6f603
Product: platform Reporter: Exceptions Reporter <exceptions_reporter>
Component: FilesystemsAssignee: Jaroslav Tulach <jtulach>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3    
Version: 7.2   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard: EXCEPTIONS_REPORT
Issue Type: DEFECT Exception Report: 188838
Attachments: stacktrace

Description Exceptions Reporter 2012-06-01 20:49:44 UTC
This bug was originally marked as duplicate of bug 207690, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.2 Beta (Build 201205031832)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b22
OS: Windows 7

Stacktrace: 
java.lang.AssertionError: file:////spweb01/e$/Library/ from \\spweb01\e$\Library@d1a16993:74a6f603
   at org.openide.filesystems.FileObject.toURI(FileObject.java:1165)
   at org.netbeans.modules.projectapi.SimpleFileOwnerQueryImplementation.getOwner(SimpleFileOwnerQueryImplementation.java:168)
   at org.netbeans.api.project.FileOwnerQuery.getOwner(FileOwnerQuery.java:104)
   at org.netbeans.modules.csl.core.ProjectClassPathProvider.findClassPath(ProjectClassPathProvider.java:66)
   at org.netbeans.api.java.classpath.ClassPath.getClassPath(ClassPath.java:628)
   at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater.findDependencies(RepositoryUpdater.java:1732)
Comment 1 Exceptions Reporter 2012-06-01 20:49:49 UTC
Created attachment 120228 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-06-01 22:22:13 UTC

*** This bug has been marked as a duplicate of bug 207060 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo