Bug 209466

Summary: NullPointerException at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.getFileObject
Product: platform Reporter: tk_fhd_aui <tk_fhd_aui>
Component: FilesystemsAssignee: Jaroslav Tulach <jtulach>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: exceptions_reporter, jglick, mutchd, tk_fhd_aui
Version: 7.2   
Target Milestone: 7.2   
Hardware: All   
OS: All   
Whiteboard: EXCEPTIONS_REPORT
Issue Type: DEFECT Exception Report: 185100
Bug Depends on:    
Bug Blocks: 213562    
Attachments: stacktrace
stacktrace

Description tk_fhd_aui 2012-03-12 13:17:53 UTC
Build: NetBeans IDE Dev (Build 201203110400)
VM: Java HotSpot(TM) Client VM, 19.0-b09, Java(TM) SE Runtime Environment, 1.6.0_23-b05
OS: Windows 7

Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.getFileObject(FolderObj.java:126)
   at org.netbeans.modules.project.ant.AntBasedProjectFactorySingleton.loadProject(AntBasedProjectFactorySingleton.java:229)
   at org.netbeans.api.project.ProjectManager.createProject(ProjectManager.java:365)
   at org.netbeans.api.project.ProjectManager.access$300(ProjectManager.java:85)
   at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:286)
   at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:233)
Comment 1 tk_fhd_aui 2012-03-12 13:17:57 UTC
Created attachment 116607 [details]
stacktrace
Comment 2 Exceptions Reporter 2012-03-12 14:47:21 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=185100
Comment 3 Exceptions Reporter 2012-03-16 12:23:15 UTC
Created attachment 116795 [details]
stacktrace
Comment 4 Jaroslav Tulach 2012-03-16 15:46:01 UTC
I've addded an assert with detailed info: ergonomics#57c1c0679540
Comment 5 Jaroslav Tulach 2012-03-16 15:53:45 UTC
*** Bug 208580 has been marked as a duplicate of this bug. ***
Comment 6 Quality Engineering 2012-04-04 10:12:47 UTC
Integrated into 'main-golden', will be available in build *201204040400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/57c1c0679540
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #209466: More detailed assert when factory is nul
Comment 7 mutchd 2012-04-12 09:23:59 UTC
I can still recreate this issue in the latest dev build (20120411)

Create/open a maven project and then expand the project files folder. Should happen first time it's opened.

Will then happen every time the settings file is selected. Don't know if this is something peculiar with my settings file?
Comment 8 Jesse Glick 2012-04-12 23:30:12 UTC
(In reply to comment #7)
> I can still recreate this issue in the latest dev build (20120411)

Then you should open a new bug with the more detailed assertion message included.  Normally you would just use the automated exception reporter, which would upload your log file for diagnosis.
Comment 9 Jesse Glick 2012-05-24 11:28:09 UTC
Trivially reproducible by running unit tests on a UNC drive as mentioned in bug #207060 comment #24.
Comment 10 Jaroslav Tulach 2012-06-01 22:31:30 UTC

*** This bug has been marked as a duplicate of bug 207060 ***
Comment 11 Jesse Glick 2012-06-05 20:39:09 UTC
*** Bug 213628 has been marked as a duplicate of this bug. ***
Comment 12 Jesse Glick 2012-06-06 15:44:12 UTC
*** Bug 213673 has been marked as a duplicate of this bug. ***
Comment 13 Milos Kleint 2012-10-09 06:16:44 UTC
*** Bug 219621 has been marked as a duplicate of this bug. ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo