Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 205410

Summary: Current line background overrides other highlighting
Product: debugger Reporter: Egor Ushakov <gorrus>
Component: CodeAssignee: Martin Entlicher <mentlicher>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3    
Version: 7.1   
Target Milestone: 8.0   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Egor Ushakov 2011-11-22 09:31:28 UTC
Stop on any line in the code - debugger highlights it with green background, which is ok, but now try to click on a variable on this line - editor highlights all occurrences of the variable in the code but it is not visible on the current line (because of the green background).
Comment 1 Martin Entlicher 2011-11-22 10:46:46 UTC
The same is true for breakpoints.
We'd need a way how to merge the highlights...
Comment 2 markiewb 2013-09-12 20:08:54 UTC

*** This bug has been marked as a duplicate of bug 231617 ***
Comment 3 Martin Entlicher 2013-09-13 13:34:11 UTC
It's not a duplicate of issue #231617.
This was submitted before dark theme was introduced. It's about the highlight preference, not about text readability.
Comment 4 Martin Entlicher 2014-02-11 18:13:02 UTC
This was already fixed by some other changes.
However, it has caused also the method selection used by "Step over operation" to be overridden by editor highlights. This is fixed by
changeset:   271944:ee0ee90184fb
http://hg.netbeans.org/core-main/rev/ee0ee90184fb
Comment 5 Quality Engineering 2014-02-12 02:41:20 UTC
Integrated into 'main-silver', will be available in build *201402120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/ee0ee90184fb
User: mentlicher@netbeans.org
Log: #205410: Step over operation should override all highlightings.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo