Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 201731

Summary: Follow system proxy settings in changing environment, not only at startup
Product: platform Reporter: reinouts <reinouts>
Component: -- Other --Assignee: Libor Fischmeistr <lfischmeistr>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: esmithbss, jglick, jrechtacek, lfischmeistr
Version: 7.0.1Keywords: API, API_REVIEW_FAST
Target Milestone: 7.4   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:
Bug Depends on: 207559    
Bug Blocks:    
Attachments: proposed impl of #201731

Description reinouts 2011-09-07 09:38:39 UTC
This issue is a spin-off from #194916 :

----
But the default IDE behavior is to pick up the system proxy settings.
(Currently this is a bit broken in that it considers system settings only at
startup, so you need to restart the IDE if you change proxies.)
----
Comment 1 Jesse Glick 2011-09-08 12:58:17 UTC
The current approach is to determine proxy settings in the native launcher and pass them to the NB Java process as system properties. Making NB respond correctly to system proxy changes would require having the Java process directly read, and listen to changes in, these native APIs - probably using JNA. Not sure if it is worth the trouble, but would be nice to not need to restart the IDE when going on or off VPN, etc.
Comment 2 Jiri Rechtacek 2013-03-26 12:11:29 UTC
Please review the proposed patch which introduces a new possibility to reload network proxy settings from system anytime in running IDE.
In short the related apichanges:
* drop of reading proxy settings from native launcher of IDE
* reading proxy settings via JNA libs
* if the JNA lib is not a part of distribution then fallback to the standard Java Proxy Selector (it could be changed by someone else as before can)
* added a new module core.network containing the most of that implementation, it's a friend on o.n.core module
* added new UI in Tools|Options|General to allow reload the proxies
The whole implementation in the following attachment. Thanks
Comment 3 Jiri Rechtacek 2013-03-26 12:12:15 UTC
Created attachment 133080 [details]
proposed impl of #201731
Comment 4 Libor Fischmeistr 2013-04-04 10:24:33 UTC
Thanks for review even if there were no objections.

Changes merged from system_proxy_reload branch to trunk in changeset: http://hg.netbeans.org/core-main/rev/067996975b47
Comment 5 Libor Fischmeistr 2013-04-04 10:34:19 UTC
*** Bug 148534 has been marked as a duplicate of this bug. ***
Comment 6 Libor Fischmeistr 2013-04-04 10:34:59 UTC
*** Bug 62946 has been marked as a duplicate of this bug. ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo