Bug 200646

Summary: GDBServer plugin doesn't works with 7.0.1 release (makeproject v2)
Product: cnd Reporter: _ rsmogura <rsmogura>
Component: DebuggerAssignee: Egor Ushakov <gorrus>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: kpalsson, Xypron
Version: 7.0.1   
Target Milestone: 7.0.1   
Hardware: PC   
OS: Linux   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description _ rsmogura 2011-08-03 16:26:29 UTC
During install I got:

Some plugins require plugin C/C++ Make Projects to be installed.
The plugin C/C++ Make Projects is requested in version >= 1.14.0.1 (release version 1) but only 2.0.0.1 (of release version different from 1) was found.  The following plugin is affected:       Gdbserver
Comment 1 Leonid Lenyashin 2011-08-05 09:11:44 UTC
*** Bug 200687 has been marked as a duplicate of this bug. ***
Comment 2 Egor Ushakov 2011-08-10 15:38:30 UTC
uploaded a new version, it is waiting for verification
Comment 3 _ rsmogura 2011-08-10 19:23:23 UTC
I installed it in fresh 7.0.1 and it works (it connects, values are visible, breakpoints can be setted).

Now I can use 7.0.1 Thank You.
Comment 4 Xypron 2011-08-11 06:47:15 UTC
I downloaded 
1312983926_org-netbeans-modules-cnd-debugger-gdbserver.nbm
I was able to install the plugin and to debug my code.

But I get the following warning: "Selected console type is not supported in your configuration, using External terminal instead".
Comment 5 Egor Ushakov 2011-08-11 09:26:49 UTC
(In reply to comment #4)
> I downloaded 
> 1312983926_org-netbeans-modules-cnd-debugger-gdbserver.nbm
> I was able to install the plugin and to debug my code.
> 
> But I get the following warning: "Selected console type is not supported in
> your configuration, using External terminal instead".

just switch to console type other than "Standard Output" - it is not supported on windows (see project properties->Run->Console type)
Comment 6 Egor Ushakov 2011-08-15 09:26:58 UTC
fixed, new version is verified and available from both web site and update center
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo