Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 20052

Summary: [2004-04-14] Rename "runide" to something more "memorable"
Product: platform Reporter: Torbjorn Norbye <tor>
Component: -- Other --Assignee: _ ttran <ttran>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: jglick, jtulach, ttran
Version: 3.xKeywords: ARCH
Target Milestone: 4.x   
Hardware: All   
OS: All   
URL: http://www.netbeans.org/servlets/BrowseList?listName=nbdev&by=thread&from=9725
Whiteboard: core-promod
Issue Type: ENHANCEMENT Exception Report:
Bug Depends on:    
Bug Blocks: 17815, 32080, 36561    

Description Torbjorn Norbye 2002-02-01 16:19:36 UTC
See the thread on nbdev with the Subject "runide.sh" in January 2002
for background information.

Essentially, the name "runide.sh" does not have a close association with
the tool it brings up (NetBeans), the .sh extension is unnatural (and is
there primarily to distinguish this script from launchers on other platforms).

My suggestion is that we do the following:
(1) To get around the problem where the names of the launchers include
    "clues" to what platform they are meant for, remove all launcher scripts
    from the bin/ directory and move them down one level into "platform"
    subdirectories:  "OpenVMS", "OS/2", "Windows", "Solaris", "Linux",
    "HP-UX", etc.  Somebody (Jesse?) suggested we combine all the "Unix"
    ones. That's okay, but on the other hand are we sure that for example
    OS-X users would think to look in the Unix directory? It would be ideal
    if opening the "bin" directory caused no confusion for users where to
    look for the launchers.  There should also be a "Generic" directory
    which contains a README explaining how to start NetBeans on other
    platforms where we don't provide a launcher - e.g. which class to start
    in the VM, properties to set, etc.

    Note that there are some other executables in this directory (fastjavac
    etc.) that might benefit from also getting sorted into each platform
    directory when appropriate.)

(2) Rename the launchers to something closely associated with the tool. I 
    suggest "netbeans". E.g.  Solaris/nebeans, Windows/netbeans.exe, etc.

(3) Handle the "defaults" files and configuration files similarly; they
    should be named something very generic ("defaults" might be just right)
    or in the case of files in the user's home directory (somebody said there's
    a ~/ide.cfg? I wasn't aware of that) something related to the tool, e.g.
    ~/netbeans.cfg.    The run script should be able to find these without
    modification; e.g. it should be possible to rename netbeans (and its
    default file if it is also named something based on the launcher name)
    and everything should work.

(4) Make it part of the documented branding process that the launcher 
    scripts on supported platforms should be renamed to something appropriate
    for that particular tool. This will make it possible for multiple
    applications built on top of NetBeans to coexist in the user's path
    without the need to launch them via full path.  

(5) Also rename files such as ide.policy, ide.cfg, etc. that have "ide"
    references in them to make NetBeans a platform, not just an IDE.
Comment 1 Jesse Glick 2002-02-03 12:12:32 UTC
Link to thread.
Comment 2 Jesse Glick 2002-02-26 14:31:19 UTC
branch in core: bootstrap_feb_2002
Comment 3 Marek Grummich 2002-07-22 08:32:31 UTC
Target milestone was changed from '3.4' to TBD.
Comment 4 Marek Grummich 2002-07-22 08:41:51 UTC
Target milestone was changed from '3.4' to TBD.
Comment 5 Torbjorn Norbye 2002-09-25 00:35:12 UTC
*** Issue 24890 has been marked as a duplicate of this issue. ***
Comment 6 Jesse Glick 2003-03-17 16:01:03 UTC
Will probably be requested by ARC.

Also consider cleaning up locations of files - *.cfg in bin/ is
specifically weird.
Comment 7 zikmund 2004-02-12 10:52:41 UTC
Important notices:
1) add icon to the NetBeans.exe file -- it can be then easily found in
"Open with" Windows' action.
2) leave runide.exe in development versions -- it could break many
automated tests, and remove it from beta and FCS versions.

BTW: It seems that it will be implemented in promo-D ;-), but I still
wonder how it could happen that this feature is here from 3.3.1 still
not implemented.
Comment 8 Jesse Glick 2004-03-30 13:40:23 UTC
Yarda is working on this.
Comment 9 Jaroslav Tulach 2004-04-14 10:20:33 UTC
General launcher renamed to nbexec and nbexec.exe. The product
launchers (like /usr/bin/netbeans) are going to call that launcher.
Comment 10 Marian Mirilovic 2005-12-20 15:46:55 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. Thanks in advance.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo