Bug 200196

Summary: Ubuntu: Step Over (F8) behaves as Continue (F5) [internal terminal only]
Product: cnd Reporter: yuriy_lalym <yuriy_lalym>
Component: DebuggerAssignee: Egor Ushakov <gorrus>
Status: RESOLVED INCOMPLETE QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: apepin, jlahoda, mikikiki, SMehra, tmikov
Version: 7.0.1   
Target Milestone: TBD   
Hardware: PC   
OS: Linux   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: messages.log

Description yuriy_lalym 2011-07-17 21:50:10 UTC
Product Version: NetBeans IDE 7.0.1 RC1 (Build 201106222100)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17

New Project->Samples->Welcome
Configuration->Debug

Build:
"/usr/bin/gmake" -f nbproject/Makefile-Debug.mk QMAKE= SUBPROJECTS= .build-conf
gmake[1]: Вход в каталог `/home/yura/NetBeansProjects/Welcome_1'
"/usr/bin/gmake"  -f nbproject/Makefile-Debug.mk dist/Debug/GNU-Linux-x86/welcome_1
gmake[2]: Вход в каталог `/home/yura/NetBeansProjects/Welcome_1'
mkdir -p build/Debug/GNU-Linux-x86
rm -f build/Debug/GNU-Linux-x86/welcome.o.d
g++    -c -g -MMD -MP -MF build/Debug/GNU-Linux-x86/welcome.o.d -o build/Debug/GNU-Linux-x86/welcome.o welcome.cc
mkdir -p dist/Debug/GNU-Linux-x86
g++     -o dist/Debug/GNU-Linux-x86/welcome_1 build/Debug/GNU-Linux-x86/welcome.o
gmake[2]: Выход из каталога `/home/yura/NetBeansProjects/Welcome_1'
gmake[1]: Выход из каталога `/home/yura/NetBeansProjects/Welcome_1'

BUILD SUCCESSFUL (total time: 1s)


Set breakpoint in line 35
35:    std::cout << "Welcome ..." << std::endl;

Debug:
The program stops in line 35. F8 - runs up to the end, instead of step by step.

Thus kdbg, ddd - go step by step without problems.
Comment 1 soldatov 2011-07-17 22:03:52 UTC
can you attach your messages.log file?
Comment 2 yuriy_lalym 2011-07-17 22:07:13 UTC
Created attachment 109479 [details]
messages.log
Comment 3 yuriy_lalym 2011-07-17 22:21:07 UTC
But

Product Version: NetBeans IDE 7.0 (Build 201104080000)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17

works perfectly

NetBeans 7.0.1 and 7.1 not works.
Comment 4 Egor Ushakov 2011-07-18 08:14:49 UTC
please attach gdb-log, I believe I've seen the same issue somewhere
(http://wiki.netbeans.org/GdbLog)
Comment 5 soldatov 2011-07-18 08:21:00 UTC
=thread-group-added,id="i1"
~"GNU gdb (Ubuntu/Linaro 7.2-1ubuntu11) 7.2\n"
~"Copyright (C) 2010 Free Software Foundation, Inc.\n"
~"License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>\nThis is free software: you are free to change and redistribute it.\nThere is NO WARRANTY, to the extent permitted by law.  Type \"show copying\"\nand \"show warranty\" for details.\n"
~"This GDB was configured as \"x86_64-linux-gnu\".\nFor bug reporting instructions, please see:\n"
~"<http://www.gnu.org/software/gdb/bugs/>.\n"
&"/home/sova/.gdbinit: �\235е�\202 �\202акого �\204айла или ка�\202алога.\n"
(gdb) 
2-list-features
3-gdb-set print repeat 0
4-gdb-set backtrace limit 1024
5-gdb-set print elements 0
6-file-exec-and-symbols  "/home/sova/NetBeansProjects/Welcome_2/dist/Debug/GNU-Linux-x86/welcome_2"
2^done,features=["frozen-varobjs","pending-breakpoints","thread-info","python"]
(gdb) 
3^done
(gdb) 
4^done
(gdb) 
5^done
(gdb) 
6^done
(gdb) 
7-file-list-exec-source-file
7^done,line="26",file="welcome.cc",fullname="/home/sova/NetBeansProjects/Welcome_2/welcome.cc",macro-info="0"
(gdb) 
8cd /home/sova/NetBeansProjects/Welcome_2
9-exec-arguments "arg 1" "arg 2" "arg 3" "arg 4"
&"cd /home/sova/NetBeansProjects/Welcome_2\n"
10-break-insert -f "/home/sova/NetBeansProjects/Welcome_2/welcome.cc:39"
1
11-break-insert -f "/home/sova/NetBeansProjects/Welcome_2/welcome.cc:45"
1
~"Working directory /home/sova/NetBeansProjects/Welcome_2.\n"
8^done
(gdb) 
9^done
(gdb) 
12-data-evaluate-expression "std::endl"
10^done,bkpt={number="1",type="breakpoint",disp="keep",enabled="y",addr="0x000000000040084a",func="main(int, char**)",file="welcome.cc",fullname="/home/sova/NetBeansProjects/Welcome_2/welcome.cc",line="39",times="0",original-location="/home/sova/NetBeansProjects/Welcome_2/welcome.cc:39"}
(gdb) 
&"\n"
1^done
(gdb) 
11^done,bkpt={number="2",type="breakpoint",disp="keep",enabled="y",addr="0x00000000004008d1",func="main(int, char**)",file="welcome.cc",fullname="/home/sova/NetBeansProjects/Welcome_2/welcome.cc",line="45",times="0",original-location="/home/sova/NetBeansProjects/Welcome_2/welcome.cc:45"}
(gdb) 
&"\n"
1^done
(gdb) 
13-break-insert -t _start
12^error,msg="No symbol \"endl\" in namespace \"std\"."
(gdb) 
No command for record 1^done
No command for record 1^done
13^done,bkpt={number="3",type="breakpoint",disp="del",enabled="y",addr="0x0000000000400730",at="<_start>",times="0",original-location="_start"}
(gdb) 
14-exec-run
=thread-group-started,id="i1",pid="1851"
=thread-created,id="1",group-id="i1"
14^running
*running,thread-id="all"
(gdb) 
=library-loaded,id="/lib64/ld-linux-x86-64.so.2",target-name="/lib64/ld-linux-x86-64.so.2",host-name="/lib64/ld-linux-x86-64.so.2",symbols-loaded="0",thread-group="i1"
=library-loaded,id="/usr/lib/x86_64-linux-gnu/libstdc++.so.6",target-name="/usr/lib/x86_64-linux-gnu/libstdc++.so.6",host-name="/usr/lib/x86_64-linux-gnu/libstdc++.so.6",symbols-loaded="0",thread-group="i1"
=library-loaded,id="/lib/x86_64-linux-gnu/libm.so.6",target-name="/lib/x86_64-linux-gnu/libm.so.6",host-name="/lib/x86_64-linux-gnu/libm.so.6",symbols-loaded="0",thread-group="i1"
=library-loaded,id="/lib/x86_64-linux-gnu/libgcc_s.so.1",target-name="/lib/x86_64-linux-gnu/libgcc_s.so.1",host-name="/lib/x86_64-linux-gnu/libgcc_s.so.1",symbols-loaded="0",thread-group="i1"
=library-loaded,id="/lib/x86_64-linux-gnu/libc.so.6",target-name="/lib/x86_64-linux-gnu/libc.so.6",host-name="/lib/x86_64-linux-gnu/libc.so.6",symbols-loaded="0",thread-group="i1"
*stopped,reason="breakpoint-hit",disp="del",bkptno="3",frame={addr="0x0000000000400730",func="_start",args=[]},thread-id="1",stopped-threads="all",core="0"
(gdb) 
15info proc
&"info proc\n"
~"process 1851\n"
~"cmdline = '/home/sova/NetBeansProjects/Welcome_2/dist/Debug/GNU-Linux-x86/welcome_2'\n"
~"cwd = '/home/sova/NetBeansProjects/Welcome_2'\n"
~"exe = '/home/sova/NetBeansProjects/Welcome_2/dist/Debug/GNU-Linux-x86/welcome_2'\n"
15^done
(gdb) 
No answer for: 14-exec-run
16-exec-continue
16^running
*running,thread-id="all"
(gdb) 
*stopped,reason="breakpoint-hit",disp="keep",bkptno="1",frame={addr="0x000000000040084a",func="main",args=[{name="argc",value="5"},{name="argv",value="0x7fffffffe198"}],file="welcome.cc",fullname="/home/sova/NetBeansProjects/Welcome_2/welcome.cc",line="39"},thread-id="1",stopped-threads="all",core="1"
(gdb) 
17-stack-list-frames
17^done,stack=[frame={level="0",addr="0x000000000040084a",func="main",file="welcome.cc",fullname="/home/sova/NetBeansProjects/Welcome_2/welcome.cc",line="39"}]
(gdb) 
No answer for: 16-exec-continue
18-stack-list-arguments 1
18^done,stack-args=[frame={level="0",args=[{name="argc",value="5"},{name="argv",value="0x7fffffffe198"}]}]
(gdb) 
19-exec-next
19^running
*running,thread-id="1"
(gdb) 
*stopped,reason="breakpoint-hit",disp="keep",bkptno="2",frame={addr="0x00000000004008d1",func="main",args=[{name="argc",value="5"},{name="argv",value="0x7fffffffe198"}],file="welcome.cc",fullname="/home/sova/NetBeansProjects/Welcome_2/welcome.cc",line="45"},thread-id="1",stopped-threads="all",core="2"
(gdb) 
20-stack-list-frames
20^done,stack=[frame={level="0",addr="0x00000000004008d1",func="main",file="welcome.cc",fullname="/home/sova/NetBeansProjects/Welcome_2/welcome.cc",line="45"}]
(gdb) 
No answer for: 19-exec-next
21-stack-list-arguments 1
21^done,stack-args=[frame={level="0",args=[{name="argc",value="5"},{name="argv",value="0x7fffffffe198"}]}]
(gdb)
Comment 6 Egor Ushakov 2011-07-21 13:01:17 UTC
looks like ubuntu specific issue, here are some observations:
- unable to reproduce it remotely
- reproduced only with "internal termial", not in External or Output window
- if debugger stops on a breakpoint and you immediately do step over - it works fine! but if you wait just a couple seconds it will stop on the next breakpoint not the next code line
Comment 7 yuriy_lalym 2011-07-28 22:35:47 UTC
The problem is present and in solstudio 12.3
But if the Oracle writes that solstudio 12.3 is based on NetBeans 7.0 remains a riddle as at Oracle it has turned out to involve such "function" in earlier version.
Comment 8 Leonid Lenyashin 2011-07-29 08:33:36 UTC
Have you tried to switch from Internal Terminal to something else, as Egor suggested? Does this work around your problem?
Comment 9 yuriy_lalym 2011-07-29 21:34:41 UTC
I only establish the fact. And here the external terminal?
How many I need to include external terminals to decide such problem in solstudio 12.3

class Test
{
public:
Test() = delete;
};

All is excellent. The uniform remark.
Reparce - all red;

I have deleted solstudio and to try it I do not gather while the Oracle won't solve a problem https://netbeans.org/bugzilla/show_bug.cgi?id=197359.
Comment 10 soldatov 2011-07-29 21:56:04 UTC
(In reply to comment #9)
> class Test
> {
> public:
> Test() = delete;
> };
It is a C++0x syntax.
Comment 11 Leonid Lenyashin 2011-07-30 12:08:40 UTC
(In reply to comment #9)
> I only establish the fact. And here the external terminal?
> How many I need to include external terminals to decide such problem in
> solstudio 12.3
> 
> class Test
> {
> public:
> Test() = delete;
> };
> 
> All is excellent. The uniform remark.
> Reparce - all red;
> 
> I have deleted solstudio and to try it I do not gather while the Oracle won't
> solve a problem https://netbeans.org/bugzilla/show_bug.cgi?id=197359.

Yuriy, you may want to try commenting in Russian, as most of the comment above is cryptic for me. I guess in Russian it might be easier.
Second thing is that (I guess since I can not fully understand) most of the comment above has nothing to do with the bug in debugger. So please file a separate bug.
As to use of NetBeans or Studio there is no obligation, it is totally up to you.
Just a reminder, NetBeans is open source and free of charge. No commitment to fix any specific bugs, however everyone is welcome to contribute a fix (you too)
Solaris Stusio is free of charge as well, but has a different support model. You can buy a single developer/one year support contract for ~$1.200 and they will fix bugs your report and come back with a patch within the contracted time frame.

Thank you for using our product,
Leonid.
Comment 12 Egor Ushakov 2011-10-10 08:11:29 UTC
*** Bug 198612 has been marked as a duplicate of this bug. ***
Comment 13 Alexander Pepin 2011-11-30 14:22:28 UTC
It's reproducible in 7.1RC2 build on Windows with gdb 6.8
Scenario:
- create Welcome project
- set 2 breakpoints in welcome.cc in lines 38 and 45
- do step into project, OK
- do step over several times
Result: Step Over works fine until the first BP is reached after that next Step Over works like Continue.

gdb log is:
~"GNU gdb 6.8.0.20080328-cvs (cygwin-special)\n"
~"Copyright (C) 2008 Free Software Foundation, Inc.\n"
~"License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>\n"
~"This is free software: you are free to change and redistribute it.\n"
~"There is NO WARRANTY, to the extent permitted by law.  Type \"show copying\"\n"
~"and \"show warranty\" for details.\n"
~"This GDB was configured as \"i686-pc-cygwin\".\n"
&"C:\\\\Users\\\\ap153252/.gdbinit: No such file or directory.\n"
(gdb) 
2-list-features
3-gdb-set print repeat 0
4-gdb-set backtrace limit 1024
5-gdb-set print elements 0
6-file-symbol-file "C:/Users/ap153252/Documents/NetBeansProjects/Welcome_47/dist/Debug/Cygwin_4.x-Windows/welcome_47"
7-file-exec-and-symbols  "C:\\Users\\ap153252\\Documents\\NetBeansProjects\\Welcome_47\\dist\\Debug\\Cygwin_4.x-Windows\\welcome_47"
2^done,features=["frozen-varobjs","pending-breakpoints"]
(gdb) 
3^done
(gdb) 
4^done
(gdb) 
5^done
(gdb) 
6^done
(gdb) 
7^done
(gdb) 
8-file-list-exec-source-file
9cd C:\Users\ap153252\Documents\NetBeansProjects\Welcome_47
10-exec-arguments "arg 1" "arg 2" "arg 3" "arg 4"
11set environment Path=C:\cygwin\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Java\jdk1.6.0_21\bin\;C:\Program Files (x86)\QuickTime\QTSystem\;C:\cygwin\bin;C:\Program Files (x86)\Calibre2\
12-break-insert -f "/cygdrive/C/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc:38"
13-break-insert -f "/cygdrive/C/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc:45"
14-break-insert -t main
15-exec-run
8^done,line="24",file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",macro-info="0"
(gdb) 
&"cd C:\\Users\\ap153252\\Documents\\NetBeansProjects\\Welcome_47\n"
~"Working directory /cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47.\n"
9^done
(gdb) 
10^done
(gdb) 
&"set environment Path=C:\\cygwin\\bin;C:\\Windows\\system32;C:\\Windows;C:\\Windows\\System32\\Wbem;C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\;C:\\Program Files\\Java\\jdk1.6.0_21\\bin\\;C:\\Program Files (x86)\\QuickTime\\QTSystem\\;C:\\cygwin\\bin;C:\\Program Files (x86)\\Calibre2\\\n"
11^done
(gdb) 
12^done,bkpt={number="1",type="breakpoint",disp="keep",enabled="y",addr="0x00401254",func="main",file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",line="38",times="0"}
(gdb) 
13^done,bkpt={number="2",type="breakpoint",disp="keep",enabled="y",addr="0x004012f8",func="main",file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",line="45",times="0"}
(gdb) 
14^done,bkpt={number="3",type="breakpoint",disp="del",enabled="y",addr="0x0040122b",func="main",file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",line="33",times="0"}
(gdb) 
15^running
(gdb) 
~"[New thread 4928.0x6e8]\n"
&"Error: dll starting at 0x76aa0000 not found.\n"
&"Error: dll starting at 0x74a60000 not found.\n"
&"Error: dll starting at 0x76aa0000 not found.\n"
&"Error: dll starting at 0x76bc0000 not found.\n"
~"[New thread 4928.0x1a0c]\n"
15*stopped,thread-id="1",frame={addr="0x0040122b",func="main",args=[{name="argc",value="5"},{name="argv",value="0xdb9560"}],file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",line="33"}
(gdb) 
16info threads
17-stack-list-frames
&"info threads\n"
~"  2 thread 4928.0x1a0c  0x76ebf8f5 in ntdll!RtlUpdateClonedSRWLock ()\n"
~"   from /cygdrive/c/Windows/system32/ntdll.dll\n"
~"* 1 thread 4928.0x6e8  main (argc=5, argv=0xdb9560) at welcome.cc:33\n"
16^done
(gdb) 
17^done,stack=[frame={level="0",addr="0x0040122b",func="main",file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",line="33"}]
(gdb) 
18-stack-list-arguments 1
18^done,stack-args=[frame={level="0",args=[{name="argc",value="5"},{name="argv",value="0xdb9560"}]}]
(gdb) 
19-exec-next
19^running
(gdb) 
19*stopped,reason="end-stepping-range",thread-id="1",frame={addr="0x00401230",func="main",args=[{name="argc",value="5"},{name="argv",value="0xdb9560"}],file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",line="35"}
(gdb) 
20-stack-list-frames
20^done,stack=[frame={level="0",addr="0x00401230",func="main",file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",line="35"}]
(gdb) 
21-stack-list-arguments 1
21^done,stack-args=[frame={level="0",args=[{name="argc",value="5"},{name="argv",value="0xdb9560"}]}]
(gdb) 
22-exec-next
22^running
(gdb) 
22*stopped,reason="end-stepping-range",reason="breakpoint-hit",bkptno="1",thread-id="1",frame={addr="0x00401254",func="_fu0___ZSt4cout",args=[],file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",line="38"}
(gdb) 
23-stack-list-frames
23^done,stack=[frame={level="0",addr="0x00401254",func="_fu0___ZSt4cout",file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",line="38"}]
(gdb) 
24-stack-list-arguments 1
24^done,stack-args=[frame={level="0",args=[{name="argc",value="5"},{name="argv",value="0xdb9560"}]}]
(gdb) 
25-exec-next
25^running
(gdb) 
25*stopped,reason="end-stepping-range",thread-id="1",frame={addr="0x00401260",func="_fu0___ZSt4cout",args=[],file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",line="39"}
(gdb) 
26-stack-list-frames
26^done,stack=[frame={level="0",addr="0x00401260",func="_fu0___ZSt4cout",file="welcome.cc",fullname="/cygdrive/c/Users/ap153252/Documents/NetBeansProjects/Welcome_47/welcome.cc",line="39"}]
(gdb) 
27-stack-list-arguments 1
27^done,stack-args=[frame={level="0",args=[{name="argc",value="5"},{name="argv",value="0xdb9560"}]}]
(gdb)
Comment 14 Alexander Pepin 2011-12-01 14:35:34 UTC
The last comment describes a new bug #205774
Please ignore that comment.
Comment 15 Jan Lahoda 2011-12-02 09:04:16 UTC
I can easily reproduce something similar (seen while working on bug #205774):
1. Have project and breakpoints as described in comment #13/bug #205774.
2. "Debug", after the execution stops on the first breakpoint, perform the "step over" action through the whole source code, until the debugger finishes itself (this will show disassembly at some point).
3. "Debug" again, "step over" after the stops at the breakpoint. The debugger won't stop at the next line, but will rather continue to the next breakpoint. (Different from bug #205774 - it will actually print the output of the program, so it was really performed.)
Comment 16 SMehra 2012-01-18 20:52:37 UTC
I am having the same concern since the time I upgraded from NetBeans 6.8 to NetBeans 7.0.1. It happens with me for a large module but not in a small module. I am not sure if that has a bearing. The debugger does stop at breakpoints for the larger module though.
Product Version: NetBeans IDE 7.0.1 (Build 201107282000) 
Java: 1.6.0_17; Java HotSpot(TM) Client VM 14.3-b01 
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 17 y575 2012-04-12 12:16:33 UTC
I meet the same problem with just installed NetBeans IDE Dev (Build 201204100400)
Comment 18 Egor Ushakov 2012-04-16 16:37:43 UTC
*** Bug 209130 has been marked as a duplicate of this bug. ***
Comment 19 tmikov 2012-04-16 16:52:33 UTC
Just FYI: having the same problem on Debian 6.0 (Squeeze) 64-bit. It is easy to work around, but is unpleasant.
Comment 20 Egor Ushakov 2012-05-11 13:21:21 UTC
I have just tried it on ubuntu 12.04 with gdb 7.4 and was not able to reproduce it.
Comment 21 Alexander Pepin 2012-05-11 13:37:45 UTC
Yes, it works on Ubuntu 12.04 with gdb 7.4.
I think we should close the bug as "WONTFIX".
Comment 22 Egor Ushakov 2012-05-11 13:48:38 UTC
what about windows, could you try it with the recent gdb?
Comment 23 Alexander Pepin 2012-05-11 14:37:01 UTC
Can not reproduce the bug on Windows using latest NB.
Win7+cygwin+gdb6.8
WinXP+msys+gdb7.4 (no internal terminal)
Comment 24 tmikov 2012-05-11 20:39:17 UTC
Guys, don't forget there is more than Ubuntu :-) I am using Debian Stable, for example...
Comment 25 Egor Ushakov 2012-05-12 09:49:54 UTC
(In reply to comment #24)
> Guys, don't forget there is more than Ubuntu :-) I am using Debian Stable, for
> example...

please try gdb 7.4
Comment 26 tmikov 2012-05-14 02:27:32 UTC
Manually compiling and installing gdb 7.4.1 from http://sources.redhat.com/gdb/ fixes the problem both in Ubuntu 10.04 and Debian Stable. 

However, please keep in mind that GDB 7.4 is not available in Debian Stable or Ubuntu 10.04, not even from backports (Debian backports carries 7.3), so this is not an ideal solution. But then again, I pay nothing for Netbeans, so I really appreciate all the hard work and I am OK with doing a manual install.

But was it found what is causing this? Was it a bug in GDB, or is GDB 7.4 just a minimal requirement for Netbeans? It used to work with previous versions of Netbeans.
Comment 27 TerryBuckley 2012-05-24 15:20:28 UTC
(In reply to comment #20)
> I have just tried it on ubuntu 12.04 with gdb 7.4 and was not able to reproduce
> it.

I don't agree, the problem is still there, in our system we had a timer task that would cause gdb/netbeans problems. Tried using .gdbinit to handle the signals but it would still cause a F8 to act like an F5.

We removed the timer task for now and F8 started acting correctly. Seems like gdb is getting confused with multiple tasks doing things asynchronously

Terry Buckley
Comment 28 Egor Ushakov 2012-10-30 07:00:59 UTC
is it still an issue with the recent gdb?
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo