Bug 200039

Summary: LowPerformance took 57886 ms.
Product: webservices Reporter: Exceptions Reporter <exceptions_reporter>
Component: CodeAssignee: Denis Anisimov <ads>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 Keywords: PERFORMANCE
Version: 7.1   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard: EXCEPTIONS_REPORT perf-profileme
Issue Type: DEFECT Exception Report: 175979
Attachments: nps snapshot

Description Exceptions Reporter 2011-07-11 11:05:29 UTC
Build: NetBeans IDE 7.0 (Build 201104080000)
VM: Java HotSpot(TM) Client VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Windows 7
Maximum slowness yet reported was 57886 ms, average is 31587
Comment 1 Exceptions Reporter 2011-07-11 11:05:46 UTC
Created attachment 109361 [details]
nps snapshot
Comment 2 Denis Anisimov 2011-07-18 07:10:56 UTC
This is the consequence of JavaSource access from AWT thread on Component initializing.
Java infrastructure access should be moved into different thread avoiding AWT thread block. Component should be updated later when Java task will be finished.
Comment 3 Denis Anisimov 2011-09-28 13:05:03 UTC
web-main#99348e241ba9
Comment 4 Quality Engineering 2011-09-29 14:09:07 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/99348e241ba9
User: Denis Anisimov <ads@netbeans.org>
Log: Fix for BZ#200039 - LowPerformance took 57886 ms.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo