Bug 198453

Summary: Cannot expand Databases node
Product: db Reporter: Jiri Skrivanek <jskrivanek>
Component: CodeAssignee: Jiri Rechtacek <jrechtacek>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: anebuzelsky, EBashkoff, idle, mmirilovic
Version: 7.0Keywords: JDK_SPECIFIC
Target Milestone: 7.0.1   
Hardware: PC   
OS: Windows XP   
Whiteboard: 70patch1-verified
Issue Type: DEFECT Exception Report:
Attachments: messages.log with stact trace.

Description Jiri Skrivanek 2011-05-09 12:31:38 UTC
Created attachment 108195 [details]
messages.log with stact trace.

It is not possible to expand Databases node due to an exception. To reproduce:

- start IDE with JDK 1.7
- go to Services tab
- expand Databases node and exception is thrown

Product Version: NetBeans IDE Dev (Build 201105090000)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b10
System: Windows XP version 5.1 running on x86; Cp1250; en_US (nb)
Comment 1 Jiri Rechtacek 2011-05-09 14:15:41 UTC
1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b02;
Oracle Corporation Runtime = Java(TM) SE Runtime Environment 1.7.0-ea-b130
=> works w/o the exception.
After upgrade to 
1.7.0-ea; Java HotSpot(TM) 64-Bit Server VM 21.0-b11;
Oracle Corporation Runtime = Java(TM) SE Runtime Environment 1.7.0-ea-b141
the exception is thrown. Probably a incompatible change in recent jdk7 builds.
Comment 2 Antonin Nebuzelsky 2011-05-10 09:50:54 UTC
Caused by the check added in b136:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=5045147
Comment 3 Jiri Skrivanek 2011-05-10 10:48:46 UTC
*** Bug 198463 has been marked as a duplicate of this bug. ***
Comment 4 Jiri Rechtacek 2011-05-10 14:15:16 UTC
core-main/rev/5165794a86b6
Comment 5 Quality Engineering 2011-05-11 19:42:19 UTC
Integrated into 'main-golden', will be available in build *201105111436* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5165794a86b6
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #198453: Cannot expand Databases node since JDK1.7b136
Comment 6 Jiri Skrivanek 2011-05-12 06:34:00 UTC
Verified in dev build 201105120000.
Comment 7 Jiri Rechtacek 2011-05-16 13:31:51 UTC
backport to release70_fixes - http://hg.netbeans.org/releases/rev/ddd03282fc99
Comment 8 Tomas Danek 2011-05-18 12:59:07 UTC
*** Bug 198000 has been marked as a duplicate of this bug. ***
Comment 9 scelisl 2012-01-09 21:23:40 UTC
I have the same Problem:

Product Version: NetBeans IDE 7.0 (Build 201107282000)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows 7 version 6.1 running on x86; Cp1252; es_ES (nb)
Comment 10 Jiri Rechtacek 2012-01-10 08:31:49 UTC
Fixed in NB7.0.1, not NB7.0
Comment 11 Jiri Rechtacek 2012-01-17 12:35:56 UTC
*** Bug 198000 has been marked as a duplicate of this bug. ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo