Bug 197637

Summary: Project Source Folders can't have same sub-directory name
Product: cnd Reporter: camios
Component: ProjectAssignee: Thomas Preisler <thp>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: apepin
Version: 7.0   
Target Milestone: 7.0.1   
Hardware: PC   
OS: Windows 7   
Whiteboard: 70patch1-verified
Issue Type: DEFECT Exception Report:

Description camios 2011-04-11 23:46:40 UTC
I have added two source folders to my C++ project. src/ and common/src/, but only the common/src/ folder is showing in the Projects window as "src - <path>/src". 

None of the src/ folder's files are listed.
Comment 1 camios 2011-04-12 08:39:35 UTC
should have been ""src - <path>/common/src"
Comment 2 Leonid Lenyashin 2011-04-12 15:16:51 UTC
Thomas, please evaluate against showstopper status.
Comment 3 Alexander Pepin 2011-04-12 16:07:16 UTC
Currently I can not reproduce the problem.
 Camios, could you please clarify what kind of project are you using ("C/C++ Project with existing sources" or "C/C++ Application")? and if you use "C/C++ Application" then what type of folders did you create "logical" or "physical"? and if you created "physical" folders then how did you do that (from IDE or externally)? 
And could you please tell the version of your NB.
Comment 4 camios 2011-04-12 22:10:31 UTC
(In reply to comment #3)
> Currently I can not reproduce the problem.
>  Camios, could you please clarify what kind of project are you using ("C/C++
> Project with existing sources" or "C/C++ Application")?

Project was created using "C/C++ Project with existing sources"

Note: The source is on a mapped network drive.

Folder structure is like this:
<base_dir>/<project_dir>/src/
<base_dir>/<project_dir>/common/src/
<base_dir>/<project_dir>/common/src/<subdir1>
<base_dir>/<project_dir>/common/src/<subdir2>
<base_dir>/<project_dir>/common/src/<subdirN>
<base_dir>/<project_dir>/make

I added src/ and common/src/ to project's source folders.

I added some non-project includes from other network drives.
I also added some of the common src's subfolders as includes (because the commmon #includes haven't got the folder names prefixed).

In the Projects window, only the common src and common src subdir folders show up. And common src also has the subdirectories too which is a bit strange...


> And could you please tell the version of your NB.

NB 7.0 RC2 (Build 201104070802)
Comment 5 Thomas Preisler 2011-04-12 23:12:53 UTC
I think I can reproduce it: first add src then add common/src and only src shows up in the logical view. The work-around is to add common instead of common/src. Please try that. It's not a regression, the bug has been in several releases.
Comment 6 Thomas Preisler 2011-04-13 22:43:49 UTC
Fixed:

changeset:   192398:993cb73f9c03
user:        Thomas Preisler <thp@netbeans.org>
date:        Wed Apr 13 15:27:44 2011 -0700
summary:     #197637 - Project Source Folders can't have same sub-directory name
Comment 7 Quality Engineering 2011-04-15 08:39:39 UTC
Integrated into 'main-golden', will be available in build *201104150401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/993cb73f9c03
User: Thomas Preisler <thp@netbeans.org>
Log: #197637 - Project Source Folders can't have same sub-directory name
Comment 8 Alexander Pepin 2011-05-13 12:43:44 UTC
verified in trunk build 20110513
Comment 9 Alexander Pepin 2011-05-16 11:43:27 UTC
Thomas, please perform the following steps to complete the patch process:
- integrate the fix int release70_fixes clone
- change SW for appropriate issue from 70patch1-candidate to 70patch1-fixed
- increase the third version number by 1 (X.Y.Z -> X.Y.Z+1)
- increase spec. versions of all patched modules
- add following text into Long Description :
"For the list of included fixed bugs please check
http://wiki.netbeans.org/NetBeans70PatchesInfo"
Comment 10 Vladimir Voskresensky 2011-05-18 10:26:32 UTC
993cb73f9c03 transplanted to 9184ebf7d410
spec version was already increased in
http://hg.netbeans.org/releases?cmd=changeset;node=db29546cb780
Comment 11 Alexander Pepin 2011-05-20 10:22:21 UTC
verified in patch1 candidate
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo