Bug 195141

Summary: SVN + FTP download causes files to be deleted
Product: php Reporter: CheeseSucker
Component: FTP SupportAssignee: Petr Pisl <ppisl>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: CheeseSucker, leth, mmirilovic, phpsitesolutions, pjiricka, prasanthp
Version: 7.0   
Target Milestone: 7.0   
Hardware: PC   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description CheeseSucker 2011-02-07 20:16:10 UTC
Using a project with Subversion and FTP support:
 1) Create a file in the project
 2) Upload it to the FTP server
 3) Download it again

The file has now been deleted from the project. It is also hidden from the FTP-server, although any other FTP-client can see it.

Details can be found in bug #167552:
http://netbeans.org/bugzilla/show_bug.cgi?id=167552
Comment 1 Petr Pisl 2011-02-08 13:10:43 UTC
Which version of NetBeans do you use? Is it a devbuild or beta?
Comment 2 Petr Pisl 2011-02-08 13:32:17 UTC
One more question, how is the remote run configuration set up? Do you have the checkbox "Upload Files Directly" check on or off?
Comment 3 Petr Pisl 2011-02-08 13:52:49 UTC
Now I'm able to reproduce it. There are the files on the disk, but there are not visible on the project view.
Comment 4 Marian Mirilovic 2011-02-08 16:33:11 UTC
This is a stopper for Nb 7.0 Beta 2.
Comment 5 Petr Pisl 2011-02-10 15:21:30 UTC
This is probably a regression in DataSystem, see issue #195297 .
Comment 6 Petr Pisl 2011-02-11 16:09:54 UTC
Strange, today I'm not able to reproduce it. Yesterday I was able to reproduce it in 100% case. Today it works in 100% cases. I don't understand. Basically what's only changed is the network and this shouldn't influence the behavior. 

I'm downgrading it into P2 even if I cannot reproduce anymore, but I need to test it on the same network environment as yesterday.
Comment 7 Petr Pisl 2011-02-15 10:29:49 UTC
Fixed in the web-main. The change will be available from the build #2856 at  http://bertram.netbeans.org/hudson/job/PHP-build/ . Could someone check it. Thanks.

I have tested on both location with success.
Comment 8 Quality Engineering 2011-02-16 11:46:00 UTC
Integrated into 'main-golden', will be available in build *201102160501* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a7d34e4aaba8
User: Petr Pisl <ppisl@netbeans.org>
Log: #195141 - SVN + FTP download causes files to be deleted
Comment 9 Petr Pisl 2011-03-16 13:49:12 UTC
*** Bug 196706 has been marked as a duplicate of this bug. ***
Comment 10 Tomas Mysik 2011-06-17 06:35:36 UTC
*** Bug 196126 has been marked as a duplicate of this bug. ***
Comment 11 Tomas Mysik 2011-06-28 15:28:01 UTC
*** Bug 197128 has been marked as a duplicate of this bug. ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo