Bug 190695

Summary: "Step Over Expression" does not highlight code parts to be executed
Product: debugger Reporter: Jiri Kovalsky <jkovalsky>
Component: JavaAssignee: Martin Entlicher <mentlicher>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2    
Version: 6.x   
Target Milestone: 7.0   
Hardware: PC   
OS: Linux   
Whiteboard: 69patch2-verified
Issue Type: DEFECT Exception Report:
Attachments: Debugging session before calling "setText" method at line 58 of Anagrams.java file.

Description Jiri Kovalsky 2010-09-30 13:43:19 UTC
Created attachment 102212 [details]
Debugging session before calling "setText" method at line 58 of Anagrams.java file.

Product Version: NetBeans IDE 6.9.1 (Build 201007282301)
Java: 1.6.0_22; Java HotSpot(TM) Client VM 17.1-b03
System: Linux version 2.6.31-22-generic running on i386; UTF-8; en_US (nb)
Userdir: /home/cesilko/.netbeans/6.9

It is very hard to guess which part of a complex expression is being debugged, because the visual feedback is not useful. Whole line of code is light green but concrete part of the code to be executed is not highlighted. The only help comes from the Variables view that shows "Before call to <method>" hints and the like.

Since this makes the "Step Over Expression" feature almost unusable and it is actually a regression from NetBeans 6.8, I consider the bug P2.

Steps to reproduce:
===================
1. Launch NetBeans IDE with empty userdir.
2. Create new AnagramGame Java sample project.
3. Open Anagrams.java file and toggle line breakpoint at line 58.
4. Press Ctrl+F5 to start debugging main project.
5. Once the breakpoint at line 58 is hit, press Shift+F8 twice.
6. You will see that "setText" method call is not highlighted.
Comment 1 Martin Entlicher 2010-09-30 16:23:38 UTC
Reproduced. The highlighting is added, but it's not displayed.
It seems that it gets overdrawn by the light line annotation.
Comment 2 Martin Entlicher 2010-10-07 09:41:07 UTC
The fix was simple - changeset:   178957:72e29fba80a4
http://hg.netbeans.org/main/rev/72e29fba80a4
Comment 3 Quality Engineering 2010-10-08 03:24:33 UTC
Integrated into 'main-golden', will be available in build *201010080000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/72e29fba80a4
User: mentlicher@netbeans.org
Log: #190695 Increase the Z order of the operation highlight.
Comment 4 Jiri Kovalsky 2010-10-12 11:57:15 UTC
Feature almost unusable, regression from 6.8, fix straightforward & isolated -> potential candidate for 6.9.1

Would you agree Martine?
Comment 5 Martin Entlicher 2010-10-12 13:05:38 UTC
Yes, I'd agree definitely. The fix is safe.
Comment 6 Jiri Kovalsky 2010-10-13 09:16:50 UTC
Verified in NetBeans 7.0 M2 candidate build #201010112200.
Comment 7 Petr Suchomel 2010-10-18 09:32:43 UTC
Backported into release692 http://hg.netbeans.org/releases/rev/091a474355a0
Comment 8 Jiri Kovalsky 2010-10-22 13:25:36 UTC
Works fine in NetBeans IDE 6.9 Update 2 #201007282301.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo