Bug 189233

Summary: Folded block can not be displayed correctly in 6.9.1
Product: editor Reporter: Keiichi Oono <keiichio>
Component: Code foldingAssignee: Miloslav Metelka <mmetelka>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: czerny, gawrik, gooddreams, hmichel, jkovalsky, locutus, mco, misterm, mmirilovic, rednaxela, roti, Turbo
Version: 6.xKeywords: REGRESSION
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard: 69patch3-verified
Issue Type: DEFECT Exception Report:
Attachments: screen shot when mouse over folded block
Same operation in 6.9. The folded block is displayed completely.
IDE's log
Popup area for folded block takes place to the bottom of editor

Description Keiichi Oono 2010-08-05 06:00:31 UTC
Created attachment 101216 [details]
screen shot when mouse over folded block

NetBeans IDE 6.9.1 (Build 201007282301) (#3acac80d2b13)
Windows XP version 5.1 running on x86
1.6.0_21; Java HotSpot(TM) Client VM 17.0-b17; Sun Microsystems Inc.

to reproduce
  - collapse any block in the editor
  - mouse over the {...} symbol
  - the folded block is displayed, but it's incomplete

Please see attached png file for image.
Comment 1 Keiichi Oono 2010-08-05 06:02:12 UTC
Created attachment 101217 [details]
Same operation in 6.9. The folded block is displayed completely.

I've attached the result when I tried same operation in 6.9
Comment 2 Keiichi Oono 2010-08-05 06:03:29 UTC
Created attachment 101218 [details]
IDE's log 

I also attach IDE's log file (message.log), but no special things are logged.
Comment 3 Michel Graciano 2010-08-05 19:19:14 UTC
*** Bug 189244 has been marked as a duplicate of this bug. ***
Comment 4 Michel Graciano 2010-08-24 19:44:51 UTC
*** Bug 189757 has been marked as a duplicate of this bug. ***
Comment 5 Michel Graciano 2010-08-24 19:45:07 UTC
*** Bug 189639 has been marked as a duplicate of this bug. ***
Comment 6 Michel Graciano 2010-08-24 19:45:22 UTC
*** Bug 189426 has been marked as a duplicate of this bug. ***
Comment 7 Michel Graciano 2010-08-24 19:47:13 UTC
It is a regression and should be fixed asap. Any chance to have a patch for 6.9?
Comment 8 David Strupl 2010-08-25 10:01:52 UTC
Confirming that it is a regression between 6.9 and 6.9.1. The bug is no longer present in 6.10 (dev) builds (tested today's sources). I am trying to figure out what changes are related to this problem. It is 100% reproducible (visible) in 6.9.1 (in my setup).
Comment 9 Michel Graciano 2010-08-25 12:51:57 UTC
Yes, it was fixed at 6.10 but looks not nice to me. Now the preview fill the entire editor when before it just covered a necessary area (as small as possible) to show the collapsed text. The old version looks better to my eyes.

Regards
Comment 10 David Strupl 2010-08-26 09:08:08 UTC
I have pushed a small fix for 6.10

http://hg.netbeans.org/jet-main/rev/d401b5edcbfc

but the situation in 6.9.1 is still unsolved. Re-assigning to Mila ...
Comment 11 Michel Graciano 2010-10-18 15:29:39 UTC
Any chance to get it fixed soon? Looks like we will have a patch for 6.9 soon and would be good to see this at this time. It is a 6.9.1 regression and I am sure users will enjoy to see it fixed.
I have seen a lot of dups of it but I had no time to help you to mark all of them.

Regards
Comment 12 Michel Graciano 2010-10-18 15:30:46 UTC
*** Bug 190511 has been marked as a duplicate of this bug. ***
Comment 13 Michel Graciano 2010-10-18 15:30:59 UTC
*** Bug 190124 has been marked as a duplicate of this bug. ***
Comment 14 Michel Graciano 2010-10-20 18:12:21 UTC
*** Bug 189371 has been marked as a duplicate of this bug. ***
Comment 15 Michel Graciano 2010-11-19 15:21:53 UTC
Anyone could take a look at this please? This was caused by patch 1 and I think it should be a included in a future patch. It is the same case of issue #192098.
Comment 16 Michel Graciano 2010-11-19 15:24:30 UTC
It is still true even after updating to "6.9.2".
Comment 17 Michel Graciano 2010-11-19 15:29:14 UTC
We have a lot of dups and votes, IMHO it is a P1.
Comment 18 Miloslav Metelka 2010-11-29 10:44:39 UTC
Fixed in release692 branch.

changeset:   c66438f502b4
branch:      release692
user:        Miloslav Metelka <mmetelka@netbeans.org>
date:        Mon Nov 29 11:40:50 2010 +0100
summary:     #189233 - Folded block can not be displayed correctly in 6.9.1.
Comment 19 Michel Graciano 2010-11-29 11:51:43 UTC
Thanks Milo.
Comment 20 Jaromir Uhrik 2010-12-08 16:24:11 UTC
Fix is not available in the patch3. Seems like the spec version has not been increased. Milo, could you please fix it ASAP to be able to rebuild binaries immediately.
Thanks.
Comment 21 Marian Mirilovic 2010-12-08 17:05:22 UTC
(In reply to comment #20)
> Fix is not available in the patch3. Seems like the spec version has not been
> increased. Milo, could you please fix it ASAP to be able to rebuild binaries
> immediately.

Ups, I reallized Mila is in Brazil, so I asked Dusan Balek and he changed it just recently http://hg.netbeans.org/releases/rev/03a824aab129
Comment 22 Jaromir Uhrik 2010-12-10 13:40:21 UTC
Verified in patch3
Comment 23 zvk77 2010-12-11 00:19:24 UTC
Created attachment 103958 [details]
Popup area for folded block takes place to the bottom of editor

Sorry, I don't understand - this fix is included in the last dev builds?

I tried today last PHP build 2010-12-10, and I still see bug, described in comment #9. (see attachment picture)

Also, on this image appears other bug - functions BlaBlaBla{N} don't have folding feature. This bug is disappears after reopening file. But, I think, for this defect need to start new issue?
Comment 24 Marian Mirilovic 2010-12-13 12:07:03 UTC
*** Bug 193311 has been marked as a duplicate of this bug. ***
Comment 25 Michel Graciano 2010-12-13 12:14:50 UTC
(In reply to comment #23)
> Created an attachment (id=103958) [details]
> Popup area for folded block takes place to the bottom of editor
> 
> Sorry, I don't understand - this fix is included in the last dev builds?

This issue is about a regression at 6.9.1. Please file a new issue about 7.0 since they are different issues.
Comment 26 Marian Mirilovic 2010-12-14 10:04:00 UTC
NetBeans 6.9/.1 Patch 3 has just been released. Please update your installation to get this issue fixed in your NB installation.
Comment 27 Michel Graciano 2010-12-14 11:14:19 UTC
(In reply to comment #26)
> NetBeans 6.9/.1 Patch 3 has just been released. Please update your installation
> to get this issue fixed in your NB installation.

Thanks. It works like a charm.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo