Bug 188718

Summary: Starting PHPDoc comment in code causes freeze
Product: php Reporter: microugly <microugly>
Component: EditorAssignee: Petr Pisl <ppisl>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: ceyceyone, fzamboj, mgracio, pjiricka, ppisl, tmysik
Version: 6.xKeywords: THREAD
Target Milestone: 6.x   
Hardware: PC   
OS: Windows XP   
Whiteboard: 69patch2-verified
Issue Type: DEFECT Exception Report:
Attachments: Thread dump after freeze occurs
Message Log

Description microugly 2010-07-15 23:37:15 UTC
When starting a PHPDoc comment with '/**' and pressing <Enter> Netbeans will often freeze.

It doesn't happen everytime, but I can replicate the error within a few tens of attempts.

Netbeans freezes, but doesn't crash.  I have to kill the process in task manager.  I've left Netbeans overnight, just in case it was thinking for a long time, but it was still frozen in the morning.

When replicating, I'm adding the comment to a class method.
Comment 1 Tomas Mysik 2010-07-16 04:43:58 UTC
Please, reopen this issue and attach profiler snapshot [1] or several thread dumps [2] taken during the freeze.

Thanks.
[1] http://wiki.netbeans.org/FitnessViaPartnership
[2] http://wiki.netbeans.org/GenerateThreadDump
Comment 2 microugly 2010-07-16 05:13:55 UTC
Created attachment 100873 [details]
Thread dump after freeze occurs

Thread-dump was grabbed with the adaptj stacktrace tool.
Comment 3 Tomas Mysik 2010-07-16 06:44:54 UTC
Parsing & EditorBracesMatching threads - please evaluate, thanks.

BTW PHPBracketCompleter.beforeBreak() is run in AWT - is it OK, Petře?

Let's increase to P2, feel free to change after evaluation. Thanks.
Comment 4 Petr Pisl 2010-07-16 08:11:57 UTC
This is known, but unfortunately I'm not able to reproduce it. The problem is that something doesn't release a lock and all editor features are waiting for the lock. 

Microugly, do you have installed any other plugin, that is not in the standard distro? Could you please attach the message.log file? Thanks
Comment 5 Petr Pisl 2010-07-16 08:44:19 UTC
I have play with it more and now I'm able to reproduce. I'm going to fix it.
Comment 6 microugly 2010-07-16 08:58:55 UTC
Created attachment 100875 [details]
Message Log

I have two other log files, if you need them.

I don't believe I have any additional plugins installed.
Comment 7 Petr Pisl 2010-07-16 10:08:14 UTC
I have fixed this. At least I'm not able to reproduce it any more. The fix will be available in the next build at hutson http://bertram.netbeans.org/hudson/job/PHP-build/. Should be available at build number #2077. 

Could you check it? Just download the zip file, unzip and run from command line with --userdir switch. Thanks
Comment 8 Tomas Mysik 2010-07-16 14:47:38 UTC
http://hg.netbeans.org/web-main/rev/35dd79be2836
Comment 9 Quality Engineering 2010-07-17 03:46:16 UTC
Integrated into 'main-golden', will be available in build *201007170001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/35dd79be2836
User: Petr Pisl <ppisl@netbeans.org>
Log: #188718 -  Starting PHPDoc comment in code causes freeze
Comment 10 microugly 2010-07-18 22:05:12 UTC
I can confirm that the problem appears to be fixed in 201007170001.

Thank you for the prompt response.
Comment 11 Petr Pisl 2010-10-12 14:14:53 UTC
*** Bug 189351 has been marked as a duplicate of this bug. ***
Comment 12 Petr Pisl 2010-10-13 13:27:15 UTC
*** Bug 190622 has been marked as a duplicate of this bug. ***
Comment 13 Petr Suchomel 2010-10-18 09:27:39 UTC
Backported into release692 http://hg.netbeans.org/releases/rev/0a1c6d1a1a8a
Comment 14 Filip Zamboj 2010-10-22 11:51:48 UTC
verified in 6.9 patch 2
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo