Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 187739

Summary: Enter new watch does not work with sorting
Product: debugger Reporter: Egor Ushakov <gorrus>
Component: CodeAssignee: Martin Entlicher <mentlicher>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: apepin, rbalada
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard: 69patch1-verified
Issue Type: DEFECT Exception Report:

Description Egor Ushakov 2010-06-17 15:58:22 UTC
steps to reproduce:
- open watches view
- set sorting by name
- click on "enter new watch" and add "a"
It appears below "enter new watch" item
- click on "enter new watch" and add "b"
It appears above "enter new watch" and replaces "a". After that even without sorting "a" is invisible.
Comment 1 Alexander Pepin 2010-06-17 16:26:23 UTC
Please fix it as soon as possible to include the fix into 6.9.1. This is very needed for upcoming OSS IDE release.
Comment 2 Martin Entlicher 2010-06-20 12:38:18 UTC
Reproduced, the problem is in the changing of the node's display name, what confuses the sorting.
Comment 3 Martin Entlicher 2010-06-20 15:49:26 UTC
Fixed in changeset:   173295:bba92ab6b18d
http://hg.netbeans.org/main/rev/bba92ab6b18d
Comment 4 Quality Engineering 2010-06-21 03:22:23 UTC
Integrated into 'main-golden', will be available in build *201006210001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/bba92ab6b18d
User: mentlicher@netbeans.org
Log: #187739 Do not set directly node's display name in the watches editor.
Comment 5 rbalada 2010-06-21 16:01:17 UTC
Please verify bugfix for this bug, so it can be integrated into release691 repository.

Thanks,
-R
Comment 6 Marian Mirilovic 2010-06-22 07:52:30 UTC
verified in 201006220001
Comment 7 rbalada 2010-06-22 09:43:38 UTC
main #bba92ab6b18d transplanted to release691 #446be1852836
Comment 8 Martin Fousek 2010-07-09 12:23:13 UTC
I checked it in 6.9.1 and for assurance also compared it with 6.9. It's really fixed and transplanted well. Verified in NetBeans IDE 6.9.1 Dev (Build 201007062301).
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo