Bug 187615

Summary: Deadlock between POMModelImpl and CloneableOpenSupport$Listener
Product: projects Reporter: Jesse Glick <jglick>
Component: MavenAssignee: Jesse Glick <jglick>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: aldobrucale, anebuzelsky, dlichtenberger, elishae, jcrim, jpokorsky, mpetras, m_potociar, tboudreau
Version: 6.xKeywords: THREAD
Target Milestone: 6.x   
Hardware: PC   
OS: Linux   
Whiteboard: 69patch2-verified
Issue Type: DEFECT Exception Report:
Attachments: jstack output
Deadlock

Description Jesse Glick 2010-06-15 20:42:55 UTC
Created attachment 100103 [details]
jstack output

Some kind of lock ordering conflict. I had a POM open in one IDE; launched a second instance, in which I edited the POM (ultimately reverting it); then closed the second instance, giving focus back to the first.
Comment 1 Jesse Glick 2010-06-15 20:43:15 UTC
100614-1352aa1ebbfb, by the way.
Comment 2 Jesse Glick 2010-07-19 13:15:39 UTC
Created attachment 100913 [details]
Deadlock

Happened again in 100719.
Comment 3 Jesse Glick 2010-07-19 13:16:39 UTC
Happened to me again when switching back to an IDE after having edited an open POM in an external editor. Clear lock ordering conflict, needs to be fixed.
Comment 4 Jesse Glick 2010-07-19 16:33:32 UTC
...and again (no POM open this time).
Comment 5 Jesse Glick 2010-07-30 17:23:55 UTC
*** Bug 188736 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Glick 2010-07-30 19:42:08 UTC
Recurring problem, potentially leading to data loss. Reported in 6.9.1 so may be worth backporting.
Comment 7 Jesse Glick 2010-08-02 15:44:34 UTC
Easily reproducible: open Maven project; open pom.xml in IDE editor; from an external editor, make some edit e.g. to <name> and save; switch back to IDE.

Simple fix seems to be to force the reload to be processed before synching model. Probably does not prevent every possible occurrence but straightforward and should be safe. core-main #463572b0a8ef
Comment 8 Quality Engineering 2010-08-03 03:13:01 UTC
Integrated into 'main-golden', will be available in build *201008030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/463572b0a8ef
User: Jesse Glick <jglick@netbeans.org>
Log: #187615: deadlock when reloading externally modified pom.xml.
Comment 9 Jaroslav Pospisil 2010-08-03 12:12:40 UTC
v.
Comment 10 Jesse Glick 2010-08-11 10:51:40 UTC
*** Bug 189382 has been marked as a duplicate of this bug. ***
Comment 11 Jesse Glick 2010-08-17 14:29:35 UTC
*** Bug 189584 has been marked as a duplicate of this bug. ***
Comment 12 Jesse Glick 2010-08-17 14:35:33 UTC
Are there any 6.9.x updates still being released? This would be a prime candidate.
Comment 13 Jesse Glick 2010-09-16 15:30:33 UTC
*** Bug 190339 has been marked as a duplicate of this bug. ***
Comment 14 Jesse Glick 2010-09-20 22:10:52 UTC
*** Bug 190259 has been marked as a duplicate of this bug. ***
Comment 15 Jesse Glick 2010-09-22 17:38:31 UTC
*** Bug 190529 has been marked as a duplicate of this bug. ***
Comment 16 Jesse Glick 2010-10-06 12:30:53 UTC
*** Bug 190794 has been marked as a duplicate of this bug. ***
Comment 17 Petr Suchomel 2010-10-18 09:21:04 UTC
Backported into release692 http://hg.netbeans.org/releases/rev/f858c2832b19
Comment 18 Tomas Danek 2010-10-22 10:23:54 UTC
verified in 6.9 patch 2
Comment 19 jcrim 2010-10-22 17:46:50 UTC
I'm running 6.9.1.  What's the best way for me to get this issue patched?  This is a major issue that was found 4 months ago and has been fixed for 2.5 months, so I find it disturbing that no updates have been issued for the most current release version.
Comment 20 Jesse Glick 2010-10-22 18:27:44 UTC
(In reply to comment #19)
> I'm running 6.9.1.  What's the best way for me to get this issue patched?

Wait for the patch to be released.
Comment 21 Jesse Glick 2011-05-23 13:45:54 UTC
*** Bug 198673 has been marked as a duplicate of this bug. ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo