Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 186276

Summary: Test Output window doesn't handle Junit 4 ignored tests
Product: java Reporter: Alexei Mokeev <av-nb>
Component: JUnitAssignee: Theofanis Oikonomou <theofanis>
Status: RESOLVED DUPLICATE QA Contact: junit-issues <junit-issues.netbeans.org>
Priority: P3 CC: gborkowski, tomzi
Version: 6.x   
Target Milestone: TBD   
Hardware: PC   
OS: Linux   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:

Description Alexei Mokeev 2010-05-18 06:51:10 UTC
Steps:

1. Mark some Junit 4 test with @Ignore annotation
2. Execute tests

Ignored tests are not shown among test results, but this functionality might be quite useful.
A quote from JUnit javadoc:

"Native JUnit 4 test runners should report the number of ignored tests along with the number of tests that ran and the number of tests that failed."
Comment 1 Andrey Yamkovoy 2010-07-06 09:57:41 UTC
Blocked by the ant issue: https://issues.apache.org/bugzilla/show_bug.cgi?id=43969
Comment 2 Alexei Mokeev 2010-07-16 06:29:01 UTC
*** Bug 188716 has been marked as a duplicate of this bug. ***
Comment 3 gborkowski 2010-07-16 09:43:39 UTC
As I mentioned in Bug 188716, I see something completely opposite: ignored tests are visible in output, but they are all marked as "passed", which is far far worse than not seeing them at all. It was like this in NB 6.8, and is still in 6.9. Don't remember like is was in 6.7.
It is Maven-based project - perhaps this makes a difference?
Comment 4 Theofanis Oikonomou 2012-03-27 11:50:09 UTC
*** Bug 199939 has been marked as a duplicate of this bug. ***
Comment 5 Theofanis Oikonomou 2013-09-04 15:01:41 UTC

*** This bug has been marked as a duplicate of bug 212622 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo