Bug 186233

Summary: NoSuchMethodError: org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Ljava/util/concurrent/Callable;)Ljava/lang/Object;
Product: editor Reporter: b166er <b166er>
Component: Parsing & IndexingAssignee: Tomas Zezula <tzezula>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: b166er, exceptions_reporter, tzezula
Version: 6.x   
Target Milestone: 7.0   
Hardware: All   
OS: All   
Whiteboard: EXCEPTIONS_REPORT
Issue Type: DEFECT Exception Report: 169503
Attachments: stacktrace
stacktrace

Description b166er 2010-05-17 08:40:29 UTC
Build: NetBeans IDE Dev (Build 201004230200)
VM: Java HotSpot(TM) 64-Bit Server VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows 7

User Comments:
GUEST: I just opened a file that is in my project

b166er: install UML+Java plugins, with opened php-project. after restart NetBeans IDE, this exception.

GUEST: I tried to paste a *.cpp file into a managed makefile application, but the pasted file did not get included as compilable. This is bad!

GUEST: Please fix this!!! it's happening every time I open or use netbeans!




Stacktrace: 
java.lang.NoSuchMethodError: org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Ljava/util/concurrent/Callable;)Ljava/lang/Object;
   at org.netbeans.modules.java.source.usages.ClassIndexManager.takeWriteLock(ClassIndexManager.java:147)
   at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$Factory$1.run(JavaCustomIndexer.java:761)
   at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$Factory$1.run(JavaCustomIndexer.java:759)
   at org.netbeans.modules.java.source.usages.ClassIndexManager.prepareWriteLock(ClassIndexManager.java:114)
   at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$Factory.scanStarted(JavaCustomIndexer.java:759)
   at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.scanStarted(RepositoryUpdater.java:1500)
Comment 1 b166er 2010-05-17 08:40:32 UTC
Created attachment 99074 [details]
stacktrace
Comment 2 b166er 2010-05-17 09:22:52 UTC
Created attachment 99076 [details]
stacktrace

delete empty new project
Comment 3 David Strupl 2010-05-18 09:11:44 UTC
Tomas, can you have a look please?
Comment 4 Tomas Zezula 2010-05-18 09:21:48 UTC
The dependency among masterfs and parsing api seems to be correct. Seems as a bug in autoupdate.
Comment 5 Tomas Zezula 2010-05-18 09:23:23 UTC
The changeset: http://hg.netbeans.org/main-silver?cmd=changeset;node=894fe07157c0
Comment 6 Jaroslav Tulach 2010-05-18 09:30:36 UTC
Versioning between masterfs and parsing.api is OK, but there is (probably) no versioning between parsing.api and java.source. Tomáš will know more, I am sure.
Comment 7 Tomas Zezula 2010-05-18 09:40:43 UTC
OK, thanks.
Comment 8 Vitezslav Stejskal 2010-05-18 10:24:11 UTC
*** Bug 186279 has been marked as a duplicate of this bug. ***
Comment 9 Tomas Zezula 2010-05-19 08:06:49 UTC
Fixed jet-main a5a34ae2f297
Workaround is to update the whole IDE rather than just a java.source module.
Comment 10 Tomas Zezula 2010-05-19 08:07:20 UTC
Fixed jet-main a5a34ae2f297
Comment 11 Quality Engineering 2010-05-20 06:13:18 UTC
Integrated into 'main-golden', will be available in build *201005192201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a5a34ae2f297
User: Tomas Zezula <tzezula@netbeans.org>
Log: #186233:NoSuchMethodError: org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Ljava/util/concurrent/Callable;)Ljava/lang/Object;
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo