Bug 18475

Summary: Provide "EXECUTE" Action on SQL scripts
Product: db Reporter: Sakthivel Gopal <sakthivelg>
Component: CodeAssignee: Andrei Badea <abadea>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 3.x   
Target Milestone: 6.x   
Hardware: Sun   
OS: All   
Whiteboard:
Issue Type: TASK Exception Report:

Description Sakthivel Gopal 2001-12-08 00:20:14 UTC
Suppose SQL filles are visible on filesystem (Directories mounted).
Provide an Execute Action on these SQL files. i.e,. RIght Click & Popup menu to
have Execute - menu item.

This should bring up a wizard, asking for user to make new connection or choose
one of the existing connection.
Once connected/connection chosen, the SQL's from the file to be executed.
Results should ve viewable.

Whys this :

"Tutorials" are used by new users of the IDE to understand how IDE works
"Tutorials" are used by developers to learn new technologies.
IDE should get shipped with lot of tutorials providing wide variety of samples
These Tutorials  should be executable with minimum effort by the user.
Most of the tutorials need database to be setup and hence they would have an SQL
file.
Making things this way, tutorials can be executed in just a few clicks.

Once the user finds that he could execute the tutorial, he/she would spend time
in understanding the technology & the tutorial. This would attract lot of users
to the IDE.
Comment 1 Radko Najman 2001-12-08 17:17:40 UTC
We plan to add this feature to new database module based on MDR. This
feature will not be added to the current module.
Comment 2 Radko Najman 2002-03-13 08:47:11 UTC
*** Issue 18170 has been marked as a duplicate of this issue. ***
Comment 3 Quality Engineering 2003-06-30 17:16:16 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 4 Quality Engineering 2003-06-30 17:17:36 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 5 Jan Chalupa 2003-10-30 12:06:47 UTC
A mistakenly closed RESOLVED LATER/REMIND issue. Reopening.
Comment 6 Radko Najman 2004-09-24 10:24:18 UTC
*** Issue 34577 has been marked as a duplicate of this issue. ***
Comment 7 Martin Schovanek 2005-09-15 15:02:12 UTC
There is UI Spec for it now, see:
http://db.netbeans.org/uispecs/sqleditor/sqleditor-ui-spec-promo-g.html

changed to TASK 
Comment 8 Andrei Badea 2006-02-16 11:02:56 UTC
Issue 68844 provides a more up-to-date description of this issue, since it
describes the current UI. Therefore closing this issue as a duplicate of issue
68844.

*** This issue has been marked as a duplicate of 68844 ***
Comment 9 Lukasz Grela 2006-02-27 09:56:06 UTC
v.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo