Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 181509

Summary: Dot paths not available when adding new platform in Ruby Platform Manager
Product: ruby Reporter: rfields <rfields>
Component: PlatformAssignee: Erno Mononen <emononen>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: pupeno
Version: 6.x   
Target Milestone: 6.x   
Hardware: Macintosh   
OS: Mac OS X   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: Dialog show to pick a Ruby interpreter

Description rfields 2010-03-04 02:44:10 UTC
I use the Ruby Version Manager gem, rvm, to work with multiple versions of Ruby on one computer.  Rvm stores Ruby interpreters under /Users/username/.rvm, which makes those interpreters impossible to select.  Paths beginning with a dot are filtered out of the folder listings in the Open dialog that appears after clicking "Add Platform...".  Without the ability to traverse those paths, I cannot select my alternate Ruby installations.

I should note, however, that this was discovered during an attempt to see if I could use NetBeans with Ruby 1.9.  If there's no Ruby 1.9 support, then resolution of my issue might not be worth the trouble.
Comment 1 Erno Mononen 2010-03-04 02:53:36 UTC
You should be able to just type in the dot folder name in the open file dialog and click OK, then you can browse the contents of the folder. NB does support 1.9, let me know if this doesn't work for you - thanks!
Comment 2 rfields 2010-03-04 04:35:35 UTC
The open file dialog I'm receiving does not include a text field.  There's no place to actually type a path manually.  At the top of the dialog, I have a dropdown to select steps along the parent path.  Below that I have the folder listing, a two column table listing Name and Date Modified.  Beneath that, I have a File Format drop down that only contains "Ruby Interpreter".  There are no other controls present in the dialog except for the Cancel and Open buttons.
Comment 3 Erno Mononen 2010-03-04 04:58:48 UTC
I see, I guess the dialog is different on OS X. I'll try to take a look at this on a Mac.
Comment 4 Erno Mononen 2010-03-12 05:02:51 UTC
*** Bug 181765 has been marked as a duplicate of this bug. ***
Comment 5 pupeno 2010-03-13 07:50:07 UTC
Created attachment 95129 [details]
Dialog show to pick a Ruby interpreter

This is the dialog I'm being show to pick a ruby interpreter, it doesn't list hidden files or allow a way to type a file name.
Comment 6 Erno Mononen 2010-03-29 13:41:46 UTC
I've changed the dialog to display also hidden files in f6faaa844fa1, so this should be fixed now. Note that now that #181844 is fixed RVM ruby installations should be discovered automatically.
Comment 7 Quality Engineering 2010-04-02 05:19:15 UTC
Integrated into 'main-golden', will be available in build *201004020200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/f6faaa844fa1
User: Erno Mononen <emononen@netbeans.org>
Log: #181509 - Dot paths not available when adding new platform in Ruby Platform Manager
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo