Bug 180960

Summary: [69cat] IndexOutOfBoundsException: Index: 3, Size: 3
Product: platform Reporter: Exceptions Reporter <exceptions_reporter>
Component: Window SystemAssignee: Stanislav Aubrecht <saubrecht>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: 133794m3r, adben, alexey_vladykin, anebuzelsky, binotxa, diesil, dstrupl, esmithbss, flexjoly, gliesian, gorzala, gtg, guest, heroblues, ianmarshall, iceman81, jasondonmoyer, jasonlotito, jirka_x1, jlahoda, jmichelberger, jonavogt, jvsmith, kangaroody, kawazu428, lazarius, Lenter, lolo_101, mattball, misterm, mmirilovic, mpapamichael, mpetras, mtolmacs, neilg, nickbence, petkle, rbuss, simitron, slreynolds, tacomait, tboerkel, tprochazka, VictorDeveloper, vittal4u, xonev, zolta
Version: 6.x   
Target Milestone: 7.0   
Hardware: All   
OS: All   
Whiteboard: EXCEPTIONS_REPORT, 69patch2-fixed
Issue Type: DEFECT Exception Report: 164383
Attachments: stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace

Description Exceptions Reporter 2010-02-19 06:09:17 UTC
Build: NetBeans IDE Dev (Build 201002152000)
VM: Java HotSpot(TM) Client VM, 16.0-b13, Java(TM) SE Runtime Environment, 1.6.0_18-b07
OS: Windows 7

User Comments:
jasonlotito: Closing a project

GUEST: When I am trying to diff the file from the CVS




Stacktrace: 
java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
   at java.util.ArrayList.RangeCheck(ArrayList.java:547)
   at java.util.ArrayList.get(ArrayList.java:322)
   at org.netbeans.swing.tabcontrol.DefaultTabDataModel.fireIndicesChanged(DefaultTabDataModel.java:490)
   at org.netbeans.swing.tabcontrol.DefaultTabDataModel.setTabs(DefaultTabDataModel.java:120)
   at org.netbeans.core.windows.view.ui.tabcontrol.TabbedAdapter.setTopComponents(TabbedAdapter.java:234)
   at org.netbeans.core.windows.view.ui.TabbedHandler.setTopComponents(TabbedHandler.java:154)
Comment 1 Exceptions Reporter 2010-02-19 06:09:24 UTC
Created attachment 94332 [details]
stacktrace
Comment 2 neilg 2010-02-22 11:14:13 UTC
Created attachment 94391 [details]
stacktrace

Closed java source file
Comment 3 Jan Lahoda 2010-03-15 09:45:56 UTC
Created attachment 95164 [details]
stacktrace
Comment 4 jasondonmoyer 2010-03-16 18:28:59 UTC
Created attachment 95255 [details]
stacktrace

double clicked on an entry in the Call Stack tab in the debugger in order to go to the relevant code associated with the entry in the java editor
Comment 5 kawazu428 2010-03-18 20:07:40 UTC
Created attachment 95402 [details]
stacktrace

tried double-click-opening a .java file?
Comment 6 esmithbss 2010-04-05 02:16:38 UTC
Created attachment 96663 [details]
stacktrace

Closing a file  within the editor.
Comment 7 jasondonmoyer 2010-04-06 17:14:19 UTC
Created attachment 96802 [details]
stacktrace

double clicked on an item in the Mercurial status pane in order to open the diff tool
Comment 8 gliesian 2010-04-13 22:19:43 UTC
Created attachment 97260 [details]
stacktrace
Comment 9 kawazu428 2010-04-14 10:46:44 UTC
Created attachment 97305 [details]
stacktrace
Comment 10 jasondonmoyer 2010-04-20 20:35:00 UTC
Created attachment 97747 [details]
stacktrace

opening a file from the mercurial status window
Comment 11 kawazu428 2010-04-23 13:04:52 UTC
Created attachment 97921 [details]
stacktrace

opening .java file into editor?
Comment 12 David Strupl 2010-05-05 07:50:23 UTC
Created attachment 98467 [details]
stacktrace

Tried to close all documents.
Comment 13 Alexey Vladykin 2010-05-07 14:49:11 UTC
Created attachment 98637 [details]
stacktrace
Comment 14 Marian Petras 2010-05-12 10:58:25 UTC
Created attachment 98837 [details]
stacktrace

I double-clicked on a JSP file in the Projects view. The JSP file was inside a Maven web project.

Before that, there were 17 files opened in the editor area (.java, .jsp, .xml, .jpg) and I was about to open a yet another JSP file.
Comment 15 misterm 2010-05-24 19:11:25 UTC
Created attachment 99405 [details]
stacktrace
Comment 16 Marian Petras 2010-05-26 20:02:35 UTC
Created attachment 99513 [details]
stacktrace

1) in the Services tab, I established a connection to a database
2) expanded some of the database's node's subnodes
3) right-clicked on a node representing a database table
4) from the context menu, I selected "View Data..."
Comment 17 Marian Petras 2010-05-26 20:07:51 UTC
This bug has 142 duplicates in the exception reporter and 37 people on the Cc:
list so this is clearly a highly annoying bug - raising priority to P2.
Comment 18 Stanislav Aubrecht 2010-05-27 08:53:51 UTC
core-main b2b1a0f3ef6c
Comment 19 Quality Engineering 2010-05-28 08:03:48 UTC
Integrated into 'main-golden', will be available in build *201005280001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/b2b1a0f3ef6c
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #180960 - thread synchronization
Comment 20 Stanislav Aubrecht 2010-06-02 07:54:49 UTC
*** Bug 186913 has been marked as a duplicate of this bug. ***
Comment 21 Stanislav Aubrecht 2010-06-03 13:09:10 UTC
*** Bug 186701 has been marked as a duplicate of this bug. ***
Comment 22 Stanislav Aubrecht 2010-06-03 13:10:15 UTC
reopening to be fixed in 6.9 release
Comment 23 Jiri Rechtacek 2010-06-03 13:53:15 UTC
The patch look for me, reviewed.
Comment 24 Stanislav Aubrecht 2010-06-03 14:22:35 UTC
fixed in release69 clone as 6ceef8c0ee69
Comment 25 Stanislav Aubrecht 2010-09-14 13:26:57 UTC
*** Bug 190112 has been marked as a duplicate of this bug. ***
Comment 26 Stanislav Aubrecht 2010-09-29 13:18:12 UTC
*** Bug 180957 has been marked as a duplicate of this bug. ***
Comment 27 Marian Petras 2010-09-30 20:01:35 UTC
The bug is reported multiple times to occur in NB 6.9.1 (here or in #190112 or in #180957) so either this is a regression since NB 6.9 or the bug was not fixed properly in NB 6.9.

I confirm this happens in NB 6.9.1. It happened several times today in NB 6.9.1 to me (JDK 6u21 32-bit, Windows XP SP3 32-bit).

When this (the exception) happens, files cannot be saved. Neither Save nor Save All action works. The IDE detects that there are unsaved files while closing and displays the Save dialogue - but it does not save the files even if the user asks to save all unsaved files.

Reopened.
Comment 28 Stanislav Aubrecht 2010-10-01 09:06:51 UTC
the bug is fixed in release69 but for some reason the changeset didn't make it to the release691 clone
Comment 29 Stanislav Aubrecht 2010-10-06 13:59:59 UTC
switching target to 6.10 so that exceptions reporter doesn't open new issues with the same stack trace
Comment 30 Stanislav Aubrecht 2010-10-07 09:07:31 UTC
*** Bug 185962 has been marked as a duplicate of this bug. ***
Comment 31 Stanislav Aubrecht 2010-10-07 09:12:19 UTC
*** Bug 183940 has been marked as a duplicate of this bug. ***
Comment 32 Stanislav Aubrecht 2010-10-15 09:05:24 UTC
*** Bug 190256 has been marked as a duplicate of this bug. ***
Comment 33 Marian Mirilovic 2010-10-27 09:06:50 UTC
Agreed with integration into Patch 2
Comment 34 Stanislav Aubrecht 2010-11-18 16:08:28 UTC
*** Bug 191261 has been marked as a duplicate of this bug. ***
Comment 35 Marian Petras 2010-12-18 16:13:33 UTC
Are you really sure you have included the fix in Patch 3? I encountered the exception the first day I applied Patch 3 (of NB 6.9.1). Before the last update, I did not see the exception for weeks.
Comment 36 Stanislav Aubrecht 2010-12-20 12:49:49 UTC
(In reply to comment #35)
> Are you really sure you have included the fix in Patch 3? I encountered the
> exception the first day I applied Patch 3 (of NB 6.9.1). Before the last
> update, I did not see the exception for weeks.

i didn't build the patch, you need to check with RE
Comment 37 Martin Entlicher 2011-01-14 16:13:54 UTC
*** Bug 186669 has been marked as a duplicate of this bug. ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo