Bug 171222

Summary: Please provide a way to copy the full path to a file.
Product: platform Reporter: jtalbut <jtalbut>
Component: -- Other --Assignee: issues <issues.netbeans.org>
Status: RESOLVED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3    
Version: 6.x   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:

Description jtalbut 2009-09-01 08:47:06 UTC
I frequently need to open a file in an external program, or attach it to an email, and it would be very useful to have 
some kind of "Copy full path" feature (Visual Studio has such a feature from a right click on the tab for a file).
Without it the only option seems to be to hover over the tab to see the tooltip and then type it into another window.
Comment 1 Peter Pis 2009-09-07 10:36:41 UTC
Reassigning.
Comment 2 bht 2010-10-12 23:50:42 UTC
A good place for this would be a context menu item in the file save as, file open dialog where NetBeans defaults to the directory containing the file.

Please also refer to Bug 190961. You can also get the path for a file from within the explorer window, properties, "All Files" [Ctrl+A], [Ctrl+C].

In Windows, one can install a utility sendto extensions that provide an option "Sent do clibboard as name" in explorer and all file dialogs. But this will not work in NetBeans of course because it does not use the Windows dialog.
Comment 3 markiewb 2012-09-25 18:19:00 UTC

*** This bug has been marked as a duplicate of bug 153728 ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo