Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 167478

Summary: AssertionError: Start offset must be before the end offset. startOffset = 9025, endOffset = -1
Product: editor Reporter: compucoder <compucoder>
Component: -- Other --Assignee: issues <issues.netbeans.org>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: compucoder, sustaining
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=152897
Whiteboard: EXCEPTIONS_REPORT 67patch1-verified
Issue Type: DEFECT Exception Report: 152897
Attachments: stacktrace
stacktrace

Description compucoder 2009-06-22 19:20:04 UTC
This issue was originally marked as duplicate of issue 149174, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE Dev (Build 200906211401)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments:
compucoder: Just clicked into an HTML tag.



Stacktrace: 
java.lang.AssertionError: Start offset must be before the end offset. startOffset = 9025, endOffset = -1
        at org.netbeans.spi.editor.highlighting.support.OffsetsBag.addHighlightImpl(OffsetsBag.java:491)
        at org.netbeans.spi.editor.highlighting.support.OffsetsBag.addHighlight(OffsetsBag.java:161)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher.placeHighlights(MasterMatcher.java:301)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher.highlightAreas(MasterMatcher.java:278)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher.access$500(MasterMatcher.java:63)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher$Result$1.run(MasterMatcher.java:630)
Comment 1 compucoder 2009-06-22 19:20:13 UTC
Created attachment 83885 [details]
stacktrace
Comment 2 compucoder 2009-06-22 19:21:55 UTC
This issue was originally marked as duplicate of issue 149174, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE Dev (Build 200906211401)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments: 
Exception when I click into the </TD> tag in this block of code:

<TD <?=$html?>>
                          <A href="<?=REPORTING_PAGE."?class=$classID"?>" class="courseLink" width="100%" onclick="return checkHasChanged();">
                            <div>
														<?php
															$arrClass = explode("-", $classID);
														?>
                          	<?=$courseName."<br>( {$arrClass[1]} )";?>
                          	</div>
                          </A>
                        </TD>

All other </TD> on my page work fine but for some reason it doesn't like this one.

Stacktrace: 
java.lang.AssertionError: Start offset must be before the end offset. startOffset = 9025, endOffset = -1
        at org.netbeans.spi.editor.highlighting.support.OffsetsBag.addHighlightImpl(OffsetsBag.java:491)
        at org.netbeans.spi.editor.highlighting.support.OffsetsBag.addHighlight(OffsetsBag.java:161)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher.placeHighlights(MasterMatcher.java:301)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher.highlightAreas(MasterMatcher.java:278)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher.access$500(MasterMatcher.java:63)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher$Result$1.run(MasterMatcher.java:630)
Comment 3 compucoder 2009-06-22 19:22:04 UTC
Created attachment 83886 [details]
stacktrace
Comment 4 Vitezslav Stejskal 2009-06-23 09:59:20 UTC
local chageset: 8e4cb6a45dcc
Comment 5 Vitezslav Stejskal 2009-06-24 13:31:47 UTC
*** Issue 167531 has been marked as a duplicate of this issue. ***
Comment 6 Quality Engineering 2009-07-01 05:27:53 UTC
Integrated into 'main-golden', will be available in build *200907010200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/8e4cb6a45dcc
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #167478 - gracefully ignore invalid offsets supplied by custom BracesMatcher implementations
Comment 7 Petr Blaha 2009-07-02 13:27:42 UTC
verified in 090702 build
Comment 8 pgebauer 2009-07-07 15:45:29 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/21b1aff59300
Comment 9 Jiri Prox 2009-07-16 13:46:15 UTC
v. in 6.7.1
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo