Bug 162964

Summary: help font size way too small
Product: usersguide Reporter: Patrick Keegan <pkeegan>
Component: CodeAssignee: Irina Filippova <ifilippova>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: kganfield, vvg
Version: 6.x   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: screenshot of small font size
Small font size in help after changes: NetBeans IDE Dev (Build 200905051401)
A clip from smallhelpfont.jpg
Help fontsize
Patrick, on my Vista x64 a default font size on the Help pages is larger!
6.5 help compared to 6.7 help build 200905200201 on Solaris 10
resubmit, 6.5 help compared to 6.7 help build 200905200201 on Solaris 10
help size: NetBeans 6.9 M1 build on Win XP

Description Patrick Keegan 2009-04-17 16:36:11 UTC
daily trunk build from 4/17

As I mentioned in issue 32667, the small attribute renders way too small in JavaHelp (thus the hack to set <p> and
<body> tags to use medium in usersguide.css). 

Is there any way to change the <body> and <p> tags to use small again without breaking the fix to #32667?
Comment 1 Patrick Keegan 2009-04-17 16:39:57 UTC
Created attachment 80374 [details]
screenshot of small font size
Comment 2 Victor Vasilyev 2009-04-17 17:55:10 UTC
Changing ide.css can't break the status of the issue #32667.
Because, the fix only adds possibility to set up a default font size for the help content pane of the Help window. 
So, the help content pane will display a font with a size that is the the same as for other UI components of the
NetBeans until another style will be specified and associated with elements (<body>, <p>, <h1> ...) of the displayed page.

Current implementation of the 
http://hg.netbeans.org/main/file/e4c589c3b55b/csl.api/src/org/netbeans/modules/csl/hints/infrastructure/ide.css
establishes that only the style h3 has font-size: medium, 
i.e. only text with the style h3 will be displayed with a default font size, 
For instance, please compare the text <h3>Using the Index</h3> and the text used by the labels on the Contents tab (e.g.
"Legal Notices") in the attached picture. 
Comment 3 Patrick Keegan 2009-04-20 20:22:05 UTC
OK. That's fine. Then the CSS should probably be reverted back to what it was. The font size is way to small in the help.
Comment 4 Irina Filippova 2009-04-22 07:56:01 UTC
In the usersguide\javahelp\org\netbeans\modules\usersguide\ide.css - changed the following attributes:

Line 28: body  {font-size: medium;
Line 35: p  {font-size: medium;
Comment 5 Irina Filippova 2009-05-12 07:14:51 UTC
Changing the font size attributes in the ide.css file to <medium>:
Line 28: body  {font-size: medium;
Line 35: p  {font-size: medium;

did not help. The default font size remains way too small (see the following attachment from dev 6.7 build 200905051401).
 
Guys, can you help with any suggestions?
Comment 6 Irina Filippova 2009-05-12 07:17:39 UTC
Created attachment 81936 [details]
Small font size in help after changes: NetBeans IDE Dev (Build 200905051401)
Comment 7 Kenneth Ganfield 2009-05-12 10:18:44 UTC
in mac os x, font size in recent builds [eg 200905110201] seem fine to me
Comment 8 Victor Vasilyev 2009-05-12 11:56:57 UTC
Created attachment 81948 [details]
A clip from smallhelpfont.jpg
Comment 9 Victor Vasilyev 2009-05-12 12:08:12 UTC
Please, look in the clip attached by me...
Font size used in the paragraph is the same as a system font size used for the labels on the Contents tab.
Now, you can choose desired default font size in the system and the same font size will be used on the help pages.

From my viewpoint this issue is resolved.
Comment 10 Patrick Keegan 2009-05-12 14:47:43 UTC
I still get a paragraph font size that is smaller than what appears on the tabs in the viewer, much like what is in
Irina's screenshot.

BTW, what's the correct place to change the css. I had tried the copy in usersguide, which all of the help topics point
to. Should it be
http://hg.netbeans.org/main/file/e4c589c3b55b/csl.api/src/org/netbeans/modules/csl/hints/infrastructure/ide.css instead?
Comment 11 Victor Vasilyev 2009-05-12 16:21:58 UTC
To have an effect with the font sizes you need change a CSS associated with your HTML help page.
See a tag in your HTML help page like this:
<html>
   <head>
       <link rel="stylesheet" href="../ide.css" type="text/css">
...
In the example above, you need make changes in the ../ide.css file.

Note, a linked CSS file should be always accessible at the run-time for any configuration of the NetBeans IDE/RCP when a
module containing the help page is installed. So, you can use the following URI if there are guaranties that the
usersguide module will be also installed at the run-time:
nbdocs://org.netbeans.modules.usersguide/org/netbeans/modules/usersguide/ide.css

Comment 12 Patrick Keegan 2009-05-12 17:01:19 UTC
The usersguide module is always installed in NB IDE distros, even if the IDE is running in ergonomics mode (I just
checked in today's build), and all help pages link to it. And
nbdocs://org.netbeans.modules.usersguide/org/netbeans/modules/usersguide/ide.css defines <p> and <body> to use medium (I
also confirmed that in the build). Yet, at least on Vista, the font size for body text is definitely smaller than the
font in the window tabs.
Comment 13 Victor Vasilyev 2009-05-13 14:41:07 UTC
Do you see smaller font on your pages only or all pages have the same wrong font size for body text too?
Comment 14 Patrick Keegan 2009-05-13 14:59:56 UTC
all topics that I click on have this problem. I have tried topics in 5 help sets (usersguide, ruby, java.helpset, j2ee,
apisupport)
Comment 15 Victor Vasilyev 2009-05-13 19:38:55 UTC
I've noticed that font family used in body of the help pages is different from other UI components of the IDE. 
May be it is only a visual effect when font of the text on the help pages is visible as with smaller size, because it
belongs to a different family?



Comment 16 Irina Filippova 2009-05-14 11:08:05 UTC
On my system (Win XP) it seems that the help default fontsize is the same as that of NetBeans UI controls and e.g. menu
items in Mozilla FF - see the attached screenshot.

Victor, do you think it would be possible to do smth with ide.css file to increase the default help fontsize?

Comment 17 Irina Filippova 2009-05-14 11:09:42 UTC
Created attachment 82108 [details]
Help fontsize
Comment 18 Victor Vasilyev 2009-05-14 14:20:57 UTC
I guess we already have a default font size in both bodies and paragraphs after specifying it as "medium".
Because, the medium font size is defined as a default font size in the CSS specification. 

Note, if we use default values for the font styles then any issues on the particular platforms may be addressed to these
platforms or to a User Agent (in our case UA is the SWING's JEditorPane component).
For example, the Cascading Style Sheets Level 2 Revision 1 (CSS 2.1) Specification says [1]:
"Note 1. To preserve readability, a UA applying these guidelines should nevertheless avoid creating font-size resulting
in less than 9 pixels per EM unit on a computer display."

In any cases, our users have an ability to change default behavior of the NetBeans to make the text of the help pages
readable, i.e. a user has at least two options:
* set a larger default font size in GUI of the operating system
* use the --fontsize option of the netbeans command.

My opinion is that it is enough for closing this issue against the userguide.

[1] http://www.w3.org/TR/CSS2/fonts.html#font-size-props
Comment 19 Irina Filippova 2009-05-14 17:26:03 UTC
Thank you very much for your explanation!

So, if Patrick agrees, the issue can be closed. I do not see any other way how the default fontsize can be enlarged.
Patrick, what is your opinion?
Comment 20 Patrick Keegan 2009-05-14 17:34:07 UTC
The explanation is helpful, but I don't think this issue can be closed. The font was a reasonable size up through 6.5
and it is way too small now (at least on Vista). That's a regression. A workaround exists (as far from obvious as it
is), so it's not a P1, but it is a bug.
Comment 21 Victor Vasilyev 2009-05-15 11:01:15 UTC
Created attachment 82176 [details]
Patrick, on my Vista x64 a default font size on the Help pages is larger!
Comment 22 Victor Vasilyev 2009-05-15 11:11:23 UTC
To create the result above I've used the latest build from the hg.netbeans.org/main repository. 

Product Version: NetBeans IDE Dev (Build 090515)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Windows Vista version 6.0 running on x86; Cp1251; ru_RU (nb)
Comment 23 Susan Morgan 2009-05-21 14:58:54 UTC
I tried 6.5 and 6.7 on Solaris 10, and 6.7 font in help is smaller, see attachment
Comment 24 Susan Morgan 2009-05-21 15:01:00 UTC
Created attachment 82554 [details]
6.5 help compared to 6.7 help build 200905200201 on Solaris 10
Comment 25 Troy Giunipero 2009-05-21 15:17:18 UTC
[ 200905210001 ]

Just looked at the font on Vista in the latest nightly build, and it _does_ display with normal-sized font (i.e., it is
bigger than the original screenshot submitted on Apr. 17.

+1 for closing the issue.
Comment 26 Susan Morgan 2009-05-21 15:17:18 UTC
Created attachment 82556 [details]
resubmit, 6.5 help compared to 6.7 help build 200905200201 on Solaris 10
Comment 27 Patrick Keegan 2009-05-21 15:45:00 UTC
Troy, could you add a screenshot and give other details, e.g. which version of the build? I just downloaded the zip
version of [200905210001] and get the same (small) results as in the beta build.
Comment 28 Irina Filippova 2010-03-17 04:37:35 UTC
Created attachment 95266 [details]
help size: NetBeans 6.9 M1 build on Win XP
Comment 29 Irina Filippova 2010-03-17 04:40:15 UTC
Guys,
It seems that we need another round of comparisons of help on:
- Win Vista or 7
- mac
- solaris
to decide what to do with this issue.

Please take the original screenshot submitted on April 17, 2009, and compare the help text size with the size of TOC entries and NB UI labels.

On Win XP the size of NB UI labels and TOC is the same - see the screenshot of March 17, 2010 taken on NB 6.9 M1 build.
Comment 30 Victor Vasilyev 2010-03-17 06:37:20 UTC
I do not have any problems with reading the help pages on all systems that I usually use:
* Windows Vista Ultimate x64
* Windows Vista Business
* Windows XP SP3
* OpenSolaris 2008.5
* Fedora 11, 12, 13
* Ubuntu 9.04

So I vote to close this bug.

BTW we should not be responsible if a user system is misconfigured or buggy fonts are installed.
Comment 31 Irina Filippova 2010-03-25 05:51:03 UTC
Closing this issue as Resolved/Fixed as no other comments for keeping it open were received.
Thanks to everyone who evaluated it.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo