Bug 162279

Summary: [68cat][67cat] Make bugtracking api public
Product: connecteddeveloper Reporter: Peter Nabbefeld <epdv>
Component: Issuetracking FrameworkAssignee: Tomas Stupka <tstupka>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: adamgmetzler, anebuzelsky, jrechtacek, maxxer, smburch, swpalmer
Version: 6.xKeywords: PLAN
Target Milestone: 7.2   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:
Bug Depends on: 238275    
Bug Blocks:    

Description Peter Nabbefeld 2009-04-09 09:16:52 UTC
[ JDK VERSION : 1.6.* ]

Please, make the bugzilla api public, so other (probably even
private) bugtracking applications can be integrated.
Comment 1 Tomas Stupka 2009-07-27 13:36:44 UTC
*** Issue 168780 has been marked as a duplicate of this issue. ***
Comment 2 Tomas Stupka 2010-02-05 02:28:32 UTC
*** Bug 180302 has been marked as a duplicate of this bug. ***
Comment 3 adamgmetzler 2010-02-05 02:37:52 UTC
This really affects all platforms not just windows.
Comment 4 Tomas Stupka 2010-02-18 12:20:08 UTC
due to the current resource situation in the bugtracking team this issue won't be resolved in 6.9
Comment 5 wraithguard01 2013-04-04 17:38:27 UTC
Any update on the priority of this bug? There are so many bugtracking frameworks that people use other than bugzilla, that making a generic bugtracker framework and making that API public would make it far easier for other people to write plugins for specific bug trackers in the future.
Comment 6 matthias42 2013-06-25 10:26:22 UTC
The missing api seriously hinders any motivation to continue developing the mantis plugin (See: bug #231766). On each release (also patch releases) you basicly breack the plugin. The same holds true for the redmine plugin.

API stability is nice, but currently I would take any API, even if it just survives one netbeans version.

This is interesting : https://github.com/quangtin3/module-friendlizer

But this (looks like redmine team tried it and failed): https://kenai.com/jira/browse/REDMINENB-38
Comment 7 anchialos 2013-07-02 11:22:14 UTC
(In reply to comment #6)

Unfortunately I must agree with the statement of mathias42! I'm a developer of the redmine plugin and I need a more or less stable API. Now.

An option: set the mantis and redmine plugin codebase as friend to the Issue Tracking module.

Another option is a minor modification to the module dependency system: 
allow more than one entry as implementation dependency version. So we can support more than one NetBeans version with the same distribution.

This issue is more than 4 years old, has the priority P1 but nothing happens on it... Please hear on this community votes!


> The missing api seriously hinders any motivation to continue developing the
> mantis plugin (See: bug #231766). On each release (also patch releases) you
> basicly breack the plugin. The same holds true for the redmine plugin.
> 
> API stability is nice, but currently I would take any API, even if it just
> survives one netbeans version.
> 
> This is interesting : https://github.com/quangtin3/module-friendlizer
> 
> But this (looks like redmine team tried it and failed):
> https://kenai.com/jira/browse/REDMINENB-38
Comment 8 Tomas Stupka 2014-01-06 12:42:29 UTC
bugtracking api is public now 
see also issue #238275
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo