Bug 161733

Summary: JavaFX : Code formatting proposed but does nothing
Product: javafx Reporter: pgerland <pgerland>
Component: EditorAssignee: Anton Chechel <manowar>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: g11n, lhasik, mmirilovic, sirfabel, tor
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard: NO68_BETA
Issue Type: DEFECT Exception Report:

Description pgerland 2009-04-02 08:11:57 UTC
First option of Contextual menu for fx code editor is "Format".
But no formatting is processed when selecting this option.
Tools/Options/Editor/Formatting gives only choice for Java/All language.
Comment 1 mslukin 2009-04-03 20:07:00 UTC
I'm not sure why this would be labeled as 'feature'.  There is a format option in the menu, there is the ability to set
up how you want your code to be formatted.  However when actually selecting 'format' it does nothing.  
Comment 2 Anton Chechel 2009-04-30 13:33:10 UTC
Tools/Options/Editor/Formatting will be disabled until we have formatting feature again.
Comment 3 Anton Chechel 2009-06-04 14:01:16 UTC
Unable to disable Tools/Options/Editor/Formatting now. We should wait till this will be implemented in the NetBeans editor.
Comment 4 sirfabel 2009-09-05 04:43:00 UTC
Please consider this as blocking... how you can be productive without automatic code formatting?? Do we need to switch 
back to VIM or Emacs? I am a little sarcastic here, but I can ensure you that this bug makes JavaFx coding really really 
fastidious... I don't understand why it is consider as P4 ("incorrect behavior"), to me it is a true P2 (Product feature 
doesn't work, a workaround may exist but it's difficult to use or impractical").

Thank you,
Fabien
Comment 5 Anton Chechel 2009-09-06 11:40:08 UTC
*** Issue 170734 has been marked as a duplicate of this issue. ***
Comment 6 Anton Chechel 2009-09-06 11:41:11 UTC
*** Issue 160709 has been marked as a duplicate of this issue. ***
Comment 7 Anton Chechel 2009-09-06 11:43:39 UTC
*** Issue 160882 has been marked as a duplicate of this issue. ***
Comment 8 Anton Chechel 2009-09-06 11:44:21 UTC
*** Issue 154215 has been marked as a duplicate of this issue. ***
Comment 9 Anton Chechel 2009-10-13 13:50:47 UTC
Code formatting will be released in 6.8 when compiler with all necessary fixes in javafx parser will be available.

*** This issue has been marked as a duplicate of 173487 ***
Comment 10 Lukas Hasik 2009-10-20 15:44:37 UTC
v
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo