Bug 161435

Summary: NullPointerException at java.io.Reader.<init>
Product: javaee Reporter: xinjun405 <xinjun405>
Component: Web ProjectAssignee: David Konecny <dkonecny>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: jsedek, mkhramov, mryzl, pjiricka, rbalada, rsaravanakumar, xpilot, YohXF15
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=110266
Whiteboard: 69patch2-verified, EXCEPTIONS_REPORT
Issue Type: DEFECT Exception Report: 110266
Attachments: stacktrace
stacktrace
stacktrace

Description xinjun405 2009-03-30 09:07:04 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-rc2-b32
OS: Windows XP, 5.1, x86

User Comments:
marfous: creating new project
click on FINISH



Stacktrace: 
java.lang.NullPointerException
        at java.io.Reader.<init>(Reader.java:61)
        at java.io.InputStreamReader.<init>(InputStreamReader.java:55)
        at org.netbeans.modules.web.project.api.WebProjectUtilities.readResource(WebProjectUtilities.java:908)
        at org.netbeans.modules.web.project.api.WebProjectUtilities.createProjectImpl(WebProjectUtilities.java:225)
        at org.netbeans.modules.web.project.api.WebProjectUtilities.access$000(WebProjectUtilities.java:114)
        at org.netbeans.modules.web.project.api.WebProjectUtilities$1.run(WebProjectUtilities.java:181)
Comment 1 xinjun405 2009-03-30 09:07:16 UTC
Created attachment 79028 [details]
stacktrace
Comment 2 David Konecny 2009-04-07 02:19:52 UTC
Any hint how to reproduce?
Comment 3 Exceptions Reporter 2009-07-02 01:52:40 UTC
This issue already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=110266
Comment 4 Petr Jiricka 2010-02-12 06:53:21 UTC
This happened again to me. Not sure how to reproduce, but for me, restarting the IDE helped as a workaround. After the exception, the project was left in a half-finished state, containing the files below. This was a project with shared libraries + GlassFish and the JSF framework selected.

lib
nbproject
src

./lib:
GlassFish_v3
nblibraries.properties

./lib/GlassFish_v3:
bean-validator.jar
glassfish-embedded-static-shell.jar
javaee6-doc-api.zip
javax.annotation.jar
javax.ejb.jar
javax.enterprise.deploy.jar
javax.jms.jar
javax.management.j2ee.jar
javax.persistence.jar
javax.resource.jar
javax.security.auth.message.jar
javax.security.jacc.jar
javax.servlet.jar
javax.servlet.jsp.jar
javax.servlet.jsp.jstl.jar
javax.transaction.jar
jaxb-api-osgi.jar
jaxb-osgi.jar
jsf-api.jar
jsf-impl.jar
jsr311-api.jar
jstl-impl.jar
mail.jar
webservices-api-osgi.jar
webservices-osgi.jar
weld-osgi-bundle.jar

./nbproject:
ant-deploy.xml
private
project.xml

./nbproject/private:
private.properties

./src:
conf
java

./src/conf:

./src/java:
Comment 5 Jindrich Sedek 2010-02-23 02:49:30 UTC
Created attachment 94413 [details]
stacktrace

creating new web application with JSF framework enabled
Comment 6 Maksim Khramov 2010-06-23 14:25:38 UTC
Created attachment 100364 [details]
stacktrace
Comment 7 Exceptions Reporter 2010-06-23 14:25:49 UTC
This bug already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=110266
Comment 8 David Konecny 2010-06-27 23:20:37 UTC
I'm not sure why it should be throwing NPE but usage of current thread is strange as well so I changed it to regular pattern using a class the load the resource and that should resolve it. 495d54ec4afb
Comment 9 David Konecny 2010-06-28 19:01:45 UTC
One more fix: eb10ea14e5fc

There is lot of exception reports but they were accumulated over several years (since NB 6.5 times) and therefore it is not stopper for 6.9.1 and can be included in next patches.
Comment 10 rbalada 2010-06-28 19:51:34 UTC
Davide,

nominations for 6.9.1_CANDIDATE have been already closed. Please consult nomination of this bug with release boss.

Thanks,
Your GateKeeper
Comment 11 David Konecny 2010-06-28 20:39:17 UTC
I just wanted to mark this issue as general candidate for any next patch release. Perhaps '6.9.1_CANDIDATE' is wrong keyword for that?
Comment 12 Martin Ryzl 2010-06-29 06:41:02 UTC
It is marked as P1. Please re-evaluate the priority - if it is still P1 it should be fixed in 6.9.1.
Comment 13 Petr Jiricka 2010-07-07 12:36:13 UTC
Davide, the changesets you refer to above are not yet in the repository - or I did not find them. Did you push them yet? Or, do you know where they are?
Comment 14 David Konecny 2010-07-07 20:18:54 UTC
Pushed.
Comment 15 Petr Jiricka 2010-08-19 14:14:30 UTC
Clarification: this change did NOT make it into 6.9.1. For main trunk, the changesets are:
http://hg.netbeans.org/main-silver/rev/495d54ec4afb
http://hg.netbeans.org/main-silver/rev/eb10ea14e5fc
Comment 16 David Konecny 2010-08-22 21:49:19 UTC
*** Bug 189682 has been marked as a duplicate of this bug. ***
Comment 17 Petr Suchomel 2010-10-18 09:16:45 UTC
Backported into release692 http://hg.netbeans.org/releases/rev/312d114d9f4f
Comment 18 rbalada 2010-11-03 15:00:27 UTC
Petr you forgot to mention the changeset http://hg.netbeans.org/releases/rev/00015c243df7 has been also ported into release692 branch.

Verified.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo