Bug 160826

Summary: NoSuchMethodError: <init>
Product: versioncontrol Reporter: ideasman42 <ideasman42>
Component: SubversionAssignee: issues <issues.netbeans.org>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: 007pig, andypb123, brutzman, dizzzz, dkurz, eggsyntax, fincatto, frogman63, gmatera64, gtzabari, kuerbo, litianzzk, lopespt, lruiz, lstroud, majiknet, michalsrodek, mmirilovic, monguz, nk228, omarzeballos, ostatnicky, palexander, pastulio, rdiazcampo, rloschmann, romych, thilina01, tjclancy, tolaware, witstart
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=146762
Whiteboard: EXCEPTIONS_REPORT 65fixes4-verified
Issue Type: DEFECT Exception Report: 146762
Attachments: stacktrace

Description ideasman42 2009-03-22 18:08:27 UTC
Build: NetBeans IDE Dev (Build 200902231810)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Linux, 2.6.28-ARCH, i386

User Comments:
GUEST: Import project

GUEST: opening python project on mac os x

ideasman42: Just opened netbeans and this error came up



Stacktrace: 
java.lang.NoSuchMethodError: <init>
        at org.tigris.subversion.javahl.SVNClient.status(SVNClient.java:0)
        at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getStatus(AbstractJhlClientAdapter.java:476)
        at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getStatus(AbstractJhlClientAdapter.java:462)
        at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getStatus(AbstractJhlClientAdapter.java:455)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(NativeMethodAccessorImpl.java:0)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
Comment 1 ideasman42 2009-03-22 18:08:32 UTC
Created attachment 78599 [details]
stacktrace
Comment 2 bolek 2009-03-23 09:21:47 UTC
if you are using ARCH linux, downgrade subversion from 1.6.0-1 to 1.5.6-1
Comment 3 Michael Nazarov 2009-03-23 16:30:10 UTC
*** Issue 160865 has been marked as a duplicate of this issue. ***
Comment 4 g4rf13ld 2009-03-24 10:37:31 UTC
Netbeans fails to start after upgrading to subversion 1.6.0
Comment 5 Tomas Stupka 2009-03-25 18:00:34 UTC
the svnClientAdapter version we bundle with netbeans doesn't work with javahl and svn >= 1.6

hotfixed the svn module so that it falls back on the cli client instead of throwing an exception

changeset   : 122697:cd092da880f9
author      : Tomas Stupka <tstupka@netbeans.org>
date        : Wed Mar 25 17:53:35 CET 2009

still - we should see that we get nb running with 1.6, so keeping this issue open for now
Comment 6 Quality Engineering 2009-03-26 14:34:57 UTC
Integrated into 'main-golden', will be available in build *200903260733* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/cd092da880f9
User: Tomas Stupka <tstupka@netbeans.org>
Log: #160826 - NoSuchMethodError: <init>
workaround
Comment 7 schaleff 2009-04-01 00:17:51 UTC
Will this be back ported in nb 5 or 6.
Comment 8 cyrill 2009-04-02 19:55:10 UTC
Tried with netbeans 6.7 m3 on MacOS X with subversion 1.6 installed. The same error/stack trace occures as originally reported:

java.lang.NoSuchMethodError: <init>
	at org.tigris.subversion.javahl.SVNClient.status(Native Method)
	at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getStatus(AbstractJhlClientAdapter.java:476)
	at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getStatus(AbstractJhlClientAdapter.java:462)
	at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getStatus(AbstractJhlClientAdapter.java:455)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.handle(SvnClientInvocationHandler.java:262)
	at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.invokeMethod(SvnClientInvocationHandler.java:226)
	at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.invoke(SvnClientInvocationHandler.java:123)
	at $Proxy8.getStatus(Unknown Source)
	at org.netbeans.modules.subversion.FileStatusCache.scanFolder(FileStatusCache.java:628)
	at org.netbeans.modules.subversion.FileStatusCache.getScannedFiles(FileStatusCache.java:596)
	at org.netbeans.modules.subversion.FileStatusCache.getStatus(FileStatusCache.java:265)
	at org.netbeans.modules.subversion.Annotator.annotateFolderIcon(Annotator.java:688)
	at org.netbeans.modules.subversion.Annotator.annotateIcon(Annotator.java:621)
	at org.netbeans.modules.subversion.FileStatusProvider.annotateIcon(FileStatusProvider.java:75)
	at org.netbeans.modules.versioning.VersioningAnnotationProvider.annotateIcon(VersioningAnnotationProvider.java:100)
	at org.netbeans.modules.masterfs.filebasedfs.FileBasedFileSystem$StatusImpl.annotateIcon(FileBasedFileSystem.java:306)
	at org.openide.loaders.DataFolder$FolderNode.getIcon(DataFolder.java:1189)
	at org.openide.nodes.FilterNode.getIcon(FilterNode.java:566)
	at org.openide.nodes.FilterNode.getIcon(FilterNode.java:566)
	at org.netbeans.modules.project.ui.ProjectsRootNode$BadgingNode.getIcon(ProjectsRootNode.java:640)
	at org.openide.explorer.view.VisualizerNode.getIcon(VisualizerNode.java:584)
	at org.openide.explorer.view.NodeRenderer.configureFrom(NodeRenderer.java:203)
	at org.openide.explorer.view.NodeRenderer.getTreeCellRendererComponent(NodeRenderer.java:141)
	at javax.swing.plaf.basic.BasicTreeUI$NodeDimensionsHandler.getNodeDimensions(BasicTreeUI.java:2693)
	at javax.swing.tree.AbstractLayoutCache.getNodeDimensions(AbstractLayoutCache.java:475)
	at javax.swing.tree.FixedHeightLayoutCache.getBounds(FixedHeightLayoutCache.java:535)
	at javax.swing.tree.FixedHeightLayoutCache.getBounds(FixedHeightLayoutCache.java:181)
	at javax.swing.tree.AbstractLayoutCache.getPreferredWidth(AbstractLayoutCache.java:215)
	at javax.swing.plaf.basic.BasicTreeUI.updateCachedPreferredSize(BasicTreeUI.java:1731)
	at javax.swing.plaf.basic.BasicTreeUI.getPreferredSize(BasicTreeUI.java:1901)
	at javax.swing.plaf.basic.BasicTreeUI.getPreferredSize(BasicTreeUI.java:1889)
	at javax.swing.JComponent.getPreferredSize(JComponent.java:1624)
	at javax.swing.ScrollPaneLayout.layoutContainer(ScrollPaneLayout.java:769)
	at org.openide.explorer.view.TreeView$ExplorerScrollPaneLayout.layoutContainer(TreeView.java:1698)
	at java.awt.Container.layout(Container.java:1401)
	at java.awt.Container.doLayout(Container.java:1390)
	at java.awt.Container.validateTree(Container.java:1473)
	at java.awt.Container.validateTree(Container.java:1480)
	at java.awt.Container.validateTree(Container.java:1480)
	at java.awt.Container.validateTree(Container.java:1480)
	at java.awt.Container.validateTree(Container.java:1480)
	at java.awt.Container.validateTree(Container.java:1480)
	at java.awt.Container.validateTree(Container.java:1480)
	at java.awt.Container.validate(Container.java:1448)
	at org.netbeans.core.windows.view.ui.DesktopImpl$LayeredLayout.layoutContainer(DesktopImpl.java:466)
	at java.awt.Container.layout(Container.java:1401)
	at java.awt.Container.doLayout(Container.java:1390)
	at java.awt.Container.validateTree(Container.java:1473)
	at java.awt.Container.validateTree(Container.java:1480)
	at java.awt.Container.validateTree(Container.java:1480)
	at java.awt.Container.validateTree(Container.java:1480)
	at java.awt.Container.validateTree(Container.java:1480)
	at java.awt.Container.validate(Container.java:1448)
	at javax.swing.RepaintManager.validateInvalidComponents(RepaintManager.java:379)
[catch] at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:113)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 9 Jaromir Uhrik 2009-04-02 21:22:50 UTC
I cannot reproduce with the last trunk build of 2009/Apr/02. It seems like the fix is not integrated in 6.7 M3.
Comment 10 Tomas Stupka 2009-04-03 09:25:02 UTC
> Tried with netbeans 6.7 m3 on MacOS X with subversion 1.6 installed. The same error/stack trace occures as originally
> reported:
i could not reproduce with m3 on osx with svn 1.6.0

cyrill:
could you please run netbeans with the switch -J-Dorg.netbeans.modules.subversion.level=-1
reproduce the problem and attach your messages log file to the issue

thanks

juhrik:
at least the fix we made in trunk is also a part of nb m3. it still might be it doesn't work for everybody

Comment 11 Tomas Stupka 2009-04-03 09:25:37 UTC
we will backport to 6.5
Comment 12 Exceptions Reporter 2009-04-04 02:17:14 UTC
This issue has already 250 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=146762
Comment 13 Ondrej Vrabec 2009-04-06 17:13:03 UTC
Hi everyone, until the patch is backported to 6.5.1 (and for those who still have problems even with #cd092da880f9
), could you run netbeans with this switch?
-J-DsvnClientAdapterFactory=commandline

Open NB_INSTALL_DIR/etc/netbeans.conf and add the switch to "netbeans_default_options" option.

This switch will force subversion plugin to run with svn commandline client and not to use incompatible javahl libraries.

I am also trying to improve the hotfix #cd092da880f9 to be able to deal with more scenarios (e.g. cyrill's case)
Comment 14 Ondrej Vrabec 2009-04-07 10:54:32 UTC
fixing in #15fd20b15c3b
Comment 15 Ondrej Vrabec 2009-04-07 12:38:19 UTC
back-port to 6.5
fixed as:
release65_fixes #4b8a4a1098be
release65_fixes #eb198ba0aad8
Comment 16 Quality Engineering 2009-04-08 07:48:56 UTC
Integrated into 'main-golden', will be available in build *200904080201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/15fd20b15c3b
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #160826 - NoSuchMethodError: <init>
better javahl version check
Comment 17 Jaromir Uhrik 2009-04-08 18:08:31 UTC
Verified with the following build/config + patch4 while svn1.6.0-9 was installed:

Product Version: NetBeans IDE 6.5.1 (Build 200903060201)
Java: 1.6.0_12; Java HotSpot(TM) Client VM 11.2-b01
System: Windows Vista version 6.0 running on x86; Cp1250; cs_CZ (nb)
Comment 18 Quality Engineering 2009-04-08 20:01:37 UTC
Integrated into 'main-golden', will be available in build *200904081400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/15fd20b15c3b
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #160826 - NoSuchMethodError: <init>
better javahl version check
Comment 19 Marian Petras 2009-05-29 12:09:07 UTC
*** Issue 166229 has been marked as a duplicate of this issue. ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo