Bug 160709

Summary: Code formatting does not work
Product: javafx Reporter: Alexandr Scherbatiy <sunflower>
Component: EditorAssignee: Anton Chechel <manowar>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: masaki, tor
Version: 6.x   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:

Description Alexandr Scherbatiy 2009-03-20 10:25:50 UTC
JavaFX_NB_651_Plugin #69 19-Mar-2009 20:09:59 	JavaFX SDK 1.1.1 promoted build b01 - SDK respin

  Product Version         = NetBeans IDE 6.5 (Build 200811100001)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_12-ea; Java HotSpot(TM) Client VM 11.2-b01; Sun Microsystems Inc.


Steps to reproduce:

- Copy the code to the editor:
------------------------------------------------------
import javafx.stage.Stage;
import javafx.scene.Scene;
import javafx.scene.text.Text;
import javafx.scene.text.Font;


Stage {
title: "Application title"
width: 250
height: 80
scene: Scene {
content: Text {
font : Font {
size : 16
}
x: 10, y: 30
content: "Application content"
}
}
}
------------------------------------------------------

- Format the code
The code is not formatted
Comment 1 Anton Chechel 2009-03-20 11:54:47 UTC
Sure it does not since old buggy formatter has been disabled. New one is the enhancement which will be implemented later
whan language itself will be more or less stabilized.
Comment 2 Alexandr Scherbatiy 2009-08-10 10:20:16 UTC
Could you attach the JIRA issues that block the code formating feature in NetBeans?
Comment 3 perlundholm 2009-08-11 12:43:39 UTC
I'd like to vote for this one but the voting system is just bananas.
Comment 4 Anton Chechel 2009-09-06 11:41:12 UTC

*** This issue has been marked as a duplicate of 161733 ***
Comment 5 Alexandr Scherbatiy 2009-09-14 10:31:16 UTC
verified
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo