Bug 160156

Summary: No response from server
Product: connecteddeveloper Reporter: Jaromir Uhrik <juhrik>
Component: ChatAssignee: Jan Becicka <jbecicka>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: Messages.log attached...

Description Jaromir Uhrik 2009-03-12 09:15:38 UTC
Product Version: NetBeans IDE Dev (Build cdev-365-on-090312)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)

The exception dialog appears when I log in to testkenai. It seems like the chat support is disabled only partially (main
menu action is disabled but kenai dashboard still uses the chat code). I looks like the exception appears when each of
my project is opening in kenai dashboard. This issue must be fixed before the merge to trunk.

No response from server.: 
	at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:468)
	at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:362)
	at org.netbeans.modules.kenai.collab.chat.KenaiConnection.join(KenaiConnection.java:128)
	at org.netbeans.modules.kenai.collab.chat.KenaiConnection.createChat(KenaiConnection.java:120)
	at org.netbeans.modules.kenai.collab.chat.KenaiConnection.initChats(KenaiConnection.java:226)
	at org.netbeans.modules.kenai.collab.chat.KenaiConnection.tryConnect(KenaiConnection.java:157)
	at org.netbeans.modules.kenai.collab.chat.KenaiConnection$1.run(KenaiConnection.java:274)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
Comment 1 Jaromir Uhrik 2009-03-12 09:19:57 UTC
Created attachment 78099 [details]
Messages.log attached...
Comment 2 Jaromir Uhrik 2009-03-12 10:55:03 UTC
*** Issue 160154 has been marked as a duplicate of this issue. ***
Comment 3 Jan Becicka 2009-03-12 14:05:52 UTC
Fixed 120583:faee2db7fdd4
Comment 4 Jaromir Uhrik 2009-04-22 16:56:57 UTC
Verified in the following build:
Product Version: NetBeans IDE 6.7 Beta (Build 200904220001)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)
Comment 5 Jaromir Uhrik 2009-04-22 16:57:13 UTC
v
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo