Bug 160121

Summary: Chain of exceptions when unseen modified bug
Product: connecteddeveloper Reporter: Jaromir Uhrik <juhrik>
Component: BugzillaAssignee: Tomas Stupka <tstupka>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 6.x   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: Messages log...

Description Jaromir Uhrik 2009-03-11 17:23:50 UTC
Product Version: NetBeans IDE Dev (Build cdev-340-on-090310)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)

In the saved query panel I tried to change a modified bug to "unseen" (push the flag icon by the right on the bug line).
There appeared the chain of exception dialogs and I need to kill IDE.

java.lang.AssertionError: status MODIFIED yet zero changes found
	at org.netbeans.modules.bugzilla.issue.BugzillaIssue.getRecentChanges(BugzillaIssue.java:286)
	at org.netbeans.modules.bugtracking.spi.IssueNode$RecentChangesProperty.getValue(IssueNode.java:233)
	at
org.netbeans.modules.bugtracking.ui.issuetable.IssueTable$CellRenderer.getTableCellRendererComponent(IssueTable.java:347)
	at javax.swing.JTable.prepareRenderer(JTable.java:3928)
	...
Comment 1 Jaromir Uhrik 2009-03-11 17:26:02 UTC
Created attachment 78063 [details]
Messages log...
Comment 2 Tomas Stupka 2009-03-11 19:41:28 UTC
fixed in scope of 

changeset:   119589:2e3000d6b3d9
tag:         tip
user:        Tomas Stupka <tstupka@netbeans.org>
date:        Wed Mar 11 19:40:49 2009 +0100
Comment 3 Jaromir Uhrik 2009-03-16 14:20:43 UTC
Verified. Cannot reproduce in the following build:

Product Version: NetBeans IDE Dev (Build cdev-380-on-090315)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.6 running on i386; MacRoman; en_US (nb)
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo