Bug 159922

Summary: Deadlock in Dashboard
Product: connecteddeveloper Reporter: Jan Becicka <jbecicka>
Component: Team FrameworkAssignee: Stanislav Aubrecht <saubrecht>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: tstupka
Version: 6.x   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Jan Becicka 2009-03-09 16:01:22 UTC
"Default RequestProcessor":                         
        at java.awt.KeyboardFocusManager.clearMostRecentFocusOwner(KeyboardFocusManager.java:1776)
        - waiting to lock <0x00007fbe86aae700> (a java.awt.Component$AWTTreeLock)                 
        at java.awt.Component.setFocusable(Component.java:6728)                                   
        at org.netbeans.modules.kenai.ui.dashboard.LinkButton.init(LinkButton.java:117)           
        at org.netbeans.modules.kenai.ui.dashboard.LinkButton.<init>(LinkButton.java:92)          
        at org.netbeans.modules.kenai.ui.dashboard.ProjectNode.getComponent(ProjectNode.java:123) 
        - locked <0x00007fbe9fc9f6b0> (a java.lang.Object)                                        
        at org.netbeans.modules.kenai.ui.treelist.RendererPanel.configure(RendererPanel.java:118) 
        at org.netbeans.modules.kenai.ui.treelist.TreeListNode.getRenderer(TreeListNode.java:160) 
        at org.netbeans.modules.kenai.ui.treelist.TreeList$TreeListRenderer.getListCellRendererComponent(TreeList.java:179)
        at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1349)                                     
        at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1299)                                
        at javax.swing.plaf.basic.BasicListUI$Handler.valueChanged(BasicListUI.java:2612)                                  
        at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:167)                      
        at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:147)                      
        at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:194)                      
        at javax.swing.DefaultListSelectionModel.insertIndexInterval(DefaultListSelectionModel.java:615)                   
        at javax.swing.plaf.basic.BasicListUI$Handler.intervalAdded(BasicListUI.java:2570)                                 
        at javax.swing.AbstractListModel.fireIntervalAdded(AbstractListModel.java:130)                                     
        at org.netbeans.modules.kenai.ui.treelist.TreeListModel.addRoot(TreeListModel.java:93)
        at org.netbeans.modules.kenai.ui.dashboard.DashboardImpl.addProjectsToModel(DashboardImpl.java:540)
        at org.netbeans.modules.kenai.ui.dashboard.DashboardImpl.setOtherProjects(DashboardImpl.java:467)
        - locked <0x00007fbe88682dd8> (a java.lang.Object)
        at org.netbeans.modules.kenai.ui.dashboard.DashboardImpl.access$1900(DashboardImpl.java:85)
        at org.netbeans.modules.kenai.ui.dashboard.DashboardImpl$OtherProjectsLoader.run(DashboardImpl.java:615)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
"AWT-EventQueue-1":
        at org.netbeans.modules.kenai.ui.dashboard.ProjectNode.getComponent(ProjectNode.java:116)
        - waiting to lock <0x00007fbe9fc9f6b0> (a java.lang.Object)
        at org.netbeans.modules.kenai.ui.treelist.RendererPanel.configure(RendererPanel.java:118)
        at org.netbeans.modules.kenai.ui.treelist.TreeListNode.getRenderer(TreeListNode.java:160)
        at org.netbeans.modules.kenai.ui.treelist.TreeList$TreeListRenderer.getListCellRendererComponent(TreeList.java:179)
        at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1349)
        at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1299)
        at javax.swing.plaf.basic.BasicListUI.getPreferredSize(BasicListUI.java:566)
        at javax.swing.JComponent.getPreferredSize(JComponent.java:1632)
        at java.awt.BorderLayout.preferredLayoutSize(BorderLayout.java:702)
        - locked <0x00007fbe86aae700> (a java.awt.Component$AWTTreeLock)
        at java.awt.Container.preferredSize(Container.java:1581)
        - locked <0x00007fbe86aae700> (a java.awt.Component$AWTTreeLock)
        at java.awt.Container.getPreferredSize(Container.java:1566)
        at javax.swing.JComponent.getPreferredSize(JComponent.java:1634)
        at javax.swing.ScrollPaneLayout.layoutContainer(ScrollPaneLayout.java:769)
        at java.awt.Container.layout(Container.java:1398)
        at java.awt.Container.doLayout(Container.java:1387)
        at java.awt.Container.validateTree(Container.java:1485)
        at java.awt.Container.validate(Container.java:1457)
        - locked <0x00007fbe86aae700> (a java.awt.Component$AWTTreeLock)
        at javax.swing.RepaintManager.validateInvalidComponents(RepaintManager.java:670)
        at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:127)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
        at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 1 Stanislav Aubrecht 2009-03-10 07:47:42 UTC

*** This issue has been marked as a duplicate of 159896 ***
Comment 2 Petr Dvorak 2009-05-27 13:05:14 UTC
Verified, duplicate
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo